You are not logged in.

#1 2012-10-09 03:50:46

OakRaider4Life
Member
Registered: 2012-02-08
Posts: 98

[SOLVED] I no longer want Krunner

It takes up almost as much memory as the entire plasma-desktop process, and its functionality is entirely redundant to that of the search bar in the kickoff menu (at least insofar as I use it).

My problem is I can't find a way to gracefully disable its status as an auto-starting process.

I already checked out the "startup and shutdown" part of my system settings, and krunner is nowhere to be found.

Any ideas?

Last edited by OakRaider4Life (2012-10-10 00:01:09)

Offline

#2 2012-10-09 04:02:14

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,975

Re: [SOLVED] I no longer want Krunner

does find ~/.config -name krunner\* -print  return anything useful ?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#3 2012-10-09 04:28:39

OakRaider4Life
Member
Registered: 2012-02-08
Posts: 98

Re: [SOLVED] I no longer want Krunner

Nothing. I also ran find ~/.kde4 -name krunner*, which returned only the krunnerrc files and a few .svgz theming files.

Oh, and it would probably help to mention that I am running kde 4.9.1.

Last edited by OakRaider4Life (2012-10-09 04:29:32)

Offline

#4 2012-10-09 06:42:17

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: [SOLVED] I no longer want Krunner

krunner is an integral part of the KDE desktop, I don't think it can be disabled. What you can do is go to 'settings' and uncheck all runners, that should make it use a minimal amount of resources

Also notice that the process manager (what you get when pressing Ctrl+Esc) is part of krunner, so if you're using that window to check the CPU usage then krunner's usage is probably due to the process manager window itself.

Last edited by arojas (2012-10-09 06:47:35)

Offline

#5 2012-10-09 07:46:11

Box0
Member
From: Italy
Registered: 2011-09-21
Posts: 218

Re: [SOLVED] I no longer want Krunner

create a krunner.desktop file in ~/.kde4/share/autostart like this:

[Desktop Entry]
Exec=krunner
Hidden=true
X-DBUS-StartupType=none
Name=Command Runner
Type=Service
X-KDE-StartupNotify=false
OnlyShowIn=KDE;
X-KDE-autostart-phase=1

logout and in again, krunner will not start automatically anymore. If you right click on the desktop and select "run a command" krunner will start again, so you you shouldn't do that.

oh, and you may want to know that if krunner is disabled, you can't use the ctrl+esc shortcut to see running processes, cause that is a krunner feature. To see processes with krunner disabled you have to use the ps command from a terminal, like

ps aux | less

Last edited by Box0 (2012-10-09 08:08:27)

Offline

#6 2012-10-09 19:38:02

OakRaider4Life
Member
Registered: 2012-02-08
Posts: 98

Re: [SOLVED] I no longer want Krunner

arojas wrote:

krunner is an integral part of the KDE desktop, I don't think it can be disabled. What you can do is go to 'settings' and uncheck all runners, that should make it use a minimal amount of resources

Also notice that the process manager (what you get when pressing Ctrl+Esc) is part of krunner, so if you're using that window to check the CPU usage then krunner's usage is probably due to the process manager window itself.

It's really not that integral... It's just a gnome-do type thingy, that the plasma desktop can very capably function without. It can be easily quit from without any problems, it's just a bit of a puzzle as to how to prevent it from starting up in the first place.

Last edited by OakRaider4Life (2012-10-09 19:44:52)

Offline

#7 2012-10-09 19:44:21

OakRaider4Life
Member
Registered: 2012-02-08
Posts: 98

Re: [SOLVED] I no longer want Krunner

Box0 wrote:

create a krunner.desktop file in ~/.kde4/share/autostart like this:

[Desktop Entry]
Exec=krunner
Hidden=true
X-DBUS-StartupType=none
Name=Command Runner
Type=Service
X-KDE-StartupNotify=false
OnlyShowIn=KDE;
X-KDE-autostart-phase=1

logout and in again, krunner will not start automatically anymore. If you right click on the desktop and select "run a command" krunner will start again, so you you shouldn't do that.

oh, and you may want to know that if krunner is disabled, you can't use the ctrl+esc shortcut to see running processes, cause that is a krunner feature. To see processes with krunner disabled you have to use the ps command from a terminal, like

ps aux | less

To tell you the truth, I didn't even know about the ctrl-esc shortcut for process management that is included with krunner. I use top, ps, kill, etc., for all my process management, and very much prefer it that way. So losing the process manager I never knew about is very much a non-issue for me tongue

Thank you for this solution though! I'm a little disappointed that it seems to require the creation of a desktop file (which I would not have been able to come up with on my own) in order to disable a service like krunner, especially when older versions of KDE 4 allowed krunner to be disabled from the startup/shutdown settings in the system settings panel. I guess I'll have to go complain in the KDE community wink

Last edited by OakRaider4Life (2012-10-09 19:47:12)

Offline

#8 2012-10-10 04:44:10

jeorgun
Member
Registered: 2011-01-19
Posts: 12

Re: [SOLVED] I no longer want Krunner

I can en/disable KRunner without any problems from System Settings -> Startup and Shutdown -> Autostart (or kcmshell4 autostart, if you prefer).

Offline

Board footer

Powered by FluxBB