You are not logged in.

#1 2012-10-09 07:36:00

daGrevis
Member
From: Riga, Latvia
Registered: 2011-10-16
Posts: 81
Website

[SOLVED] Xmonad is unresolvable dependency

[dagrevis@localhost ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 core                                                                                                                 106.7 KiB   137K/s 00:01 [########################################################################################] 100%
 extra                                                                                                               1422.7 KiB   786K/s 00:02 [########################################################################################] 100%
 community                                                                                                           1785.7 KiB   860K/s 00:02 [########################################################################################] 100%
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "haskell-extensible-exceptions", a dependency of "xmonad"
warning: cannot resolve "haskell-extensible-exceptions", a dependency of "xmonad"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      xmonad  xmonad-contrib

Do you want to skip the above packages for this upgrade? [y/N]

How to deal w/ this problem?

Last edited by daGrevis (2012-10-09 10:13:47)

Offline

#2 2012-10-09 08:12:16

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,790

Re: [SOLVED] Xmonad is unresolvable dependency

It appears the new version of xmonad was moved to [community] from [community-testing] without haskell-extensible-exceptions also being moved at the same time. Either wait for this to resolve itself (the maintainer will realize eventually, I'd guess) or file a bug report.

You could also try to use [community-testing], but PLEASE read the wiki before doing so.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#3 2012-10-09 08:21:50

linux-ka
Member
From: ADL
Registered: 2010-05-07
Posts: 232

Re: [SOLVED] Xmonad is unresolvable dependency

Why don't you just use cabal to build and install xmonad. This will not end up in a chain of pains regarding dependencies which are hardly resolved with pacman....

Offline

#4 2012-10-09 08:41:36

crazymaik
Member
Registered: 2012-10-09
Posts: 1

Re: [SOLVED] Xmonad is unresolvable dependency

The bug is already fixed, haskell-extensible-exceptions is now in Community. http://www.archlinux.org/packages/commu … xceptions/

Offline

#5 2012-10-09 10:13:31

daGrevis
Member
From: Riga, Latvia
Registered: 2011-10-16
Posts: 81
Website

Re: [SOLVED] Xmonad is unresolvable dependency

Thanks, now it is fixed.

Offline

Board footer

Powered by FluxBB