You are not logged in.

#1 2012-10-09 08:16:23

soul_rebel
Member
Registered: 2012-09-06
Posts: 24

[SOLVED] Unusable keyboard with systemd

When booting with systemd the system boots very quickly, but I am left with an unusable keyboard: all keys are random, even the enter key is not there and ctrl-alt-del does not work.
In gdm the touchpad stops working after a few seconds and only the "trackpoint" is still usable. Switching to a VT does not work.

This happens with a relatively new install, which is working fine with initscripts, on a dell latitude e6430 with an italian keyboard.

So far I tried to narrow down the issue, but it is still present even in the most minimal environment:
I removed keymap and consolefont hooks from mkinitcpio.conf and regenerated the initramfs file,
I commented /etc/vconsole.conf,
I booted with "init=/bin/systemd single" and could not enter the root password or even press control-D

I don't know systemd well enough to diagnose this. Any idea?

UPDATE: the problem is not consistent: after a few tries the boot completed without messing up the keyboard. I am trying to access the logs of what happens now.

Last edited by soul_rebel (2012-10-14 08:19:54)

Offline

#2 2012-10-09 14:22:55

DarkCerberus
Member
From: /dev/null
Registered: 2011-12-31
Posts: 247

Re: [SOLVED] Unusable keyboard with systemd

It maybe due to the locale settings - have you gone through this tutorial https://wiki.archlinux.org/index.php/Locale ?

Offline

#3 2012-10-10 07:50:20

soul_rebel
Member
Registered: 2012-09-06
Posts: 24

Re: [SOLVED] Unusable keyboard with systemd

in locale.conf I have:
LANG="it_IT.UTF-8"

I think that's not it.

Offline

#4 2012-10-11 04:14:26

ackt1c
Member
From: Visalia, California
Registered: 2012-10-10
Posts: 215

Re: [SOLVED] Unusable keyboard with systemd

LANG=it_IT.UTF-8
LC_COLLATE=C

your /etc/vconsole.conf shouldn't be commented it should be defined
KEYMAP=
FONT_MAP=
FONT=

& /etc/locale.gen?

locale-gen

also ctrl+alt+del is unset as default (think I read that somewhere)

and try ctrl+m at login if not responding.

mkinitcpio -p linux successful locale generation?

Last edited by ackt1c (2012-10-11 19:04:25)

Offline

#5 2012-10-14 08:19:11

soul_rebel
Member
Registered: 2012-09-06
Posts: 24

Re: [SOLVED] Unusable keyboard with systemd

Thanks for the suggestions, anyhow the problem is not happening anymore: I think one of the recent updates fixed it.

Offline

Board footer

Powered by FluxBB