You are not logged in.

#1 2012-10-09 18:44:47

eherranzr
Member
Registered: 2011-06-28
Posts: 112

[SOLVED] Problem upgrading & after upgrade

Hi!

I ahve a problem, when I try to execute chromium-dev I receive the following output:

/usr/lib/chromium-dev/chromium: error while loading shared libraries: libv8.so: cannot open shared object file: No such file or directory

And if I try to upgrade:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlinuxfr is up to date
 bereflected : Orphan         
 focusbooster : Orphan        
 fortune-mod-es : Orphan      
 kcometen4 : Orphan           
 neverball-svn : Orphan       
 ogre-pagedgeometry : Orphan  
 pomodairo : Orphan           
 smplayer-themes-svn : Orphan  
 Foreign packages: | 148 / 148

==> Package upgrade only (new release):
core/iputils               20101006-4     4 -> 7
core/libltdl               2.4.2-6        6 -> 7
core/libtool               2.4.2-6        6 -> 7
multilib/lib32-libltdl     2.4.2-6        6 -> 7
aur/moodbar                0.1.2-7        7 -> 8
aur/rar                    4.2.0-3        3 -> 4

==> Software upgrade (new version) :
core/linux-api-headers     3.5.1-1        -> 3.5.5-1
extra/chromium             22.0.1229.79-2 -> 22.0.1229.92-1
multilib/lib32-gcc-libs    4.7.1-6        -> 4.7.2-1
multilib/gcc-libs-multilib 4.7.1-6        -> 4.7.2-1
multilib/gcc-multilib      4.7.1-6        -> 4.7.2-1
aur/fontconfig-ubuntu      2.8.0-10       -> 2.10.1-3
aur/google-chrome-dev      23.0.1262.0-1  -> 24.0.1284.2-1
aur/skanlite               0.8-2          -> 0.9-1

==> Continue upgrade ? [Y/n]
==> [V]iew package detail   [M]anually select packages
==> --------------------------------------------------
==> y
:: Starting full system upgrade...
resolving dependencies...
warning: dependency cycle detected:
warning: lib32-gcc-libs will be installed before its gcc-libs-multilib dependency
looking for inter-conflicts...

Targets (9): chromium-22.0.1229.92-1  gcc-libs-multilib-4.7.2-1  gcc-multilib-4.7.2-1  iputils-20101006-7
             lib32-gcc-libs-4.7.2-1  lib32-libltdl-2.4.2-7  libltdl-2.4.2-7  libtool-2.4.2-7
             linux-api-headers-3.5.5-1

Total Installed Size:   195,77 MiB
Net Upgrade Size:       -1,66 MiB

Proceed with installation? [Y/n] y
(9/9) checking package integrity                                 [------------------------------------] 100%
error: linux-api-headers: signature from "Allan McRae <me@allanmcrae.com>" is invalid
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Thanks
Regards

Last edited by eherranzr (2012-10-09 19:26:21)

Offline

#2 2012-10-09 18:48:17

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Problem upgrading & after upgrade

Wrt to chromium-dev, you can post errors on its AUR page https://aur.archlinux.org/packages.php?ID=37244
Wrt to the update, read https://wiki.archlinux.org/index.php/Pa … 9.22_error (next to last question)

Last edited by karol (2012-10-09 18:49:02)

Offline

#3 2012-10-09 19:05:45

eherranzr
Member
Registered: 2011-06-28
Posts: 112

Re: [SOLVED] Problem upgrading & after upgrade

Thanks karol
The upgrade problems seems to be fixed, but related to the chromium error I'm not quite sure if it's problem about the version (I've used this version) ot if it's an error concerning another upgrade, that's why I posted here and not on the AUR page

Offline

#4 2012-10-09 19:07:59

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Problem upgrading & after upgrade

It's just a guess, but try installing v8 package.

Offline

#5 2012-10-09 19:15:27

eherranzr
Member
Registered: 2011-06-28
Posts: 112

Re: [SOLVED] Problem upgrading & after upgrade

karol wrote:

It's just a guess, but try installing v8 package.

There are a lot of packages, which one do I install?

 extra/v86d 0.1.10-4
    userspace helper for uvesafb that runs x86 code in an emulated environment
2 community/nodejs 0.8.11-1
    Evented I/O for V8 javascript
3 community/v8 3.13.0-1
    A fast and modern javascript engine
4 multilib/dev86 0.16.18-3
    Simple C compiler to generate 8086 code
5 aur/bin32-nodejs 0.8.11-1 (1)
    Evented I/O for V8 javascript (i686 build for x86_64)
6 aur/libv8-convert 20120219-1 (0)
    The v8-convert API is a spin-off of the core-most components of the v8-juice library.
7 aur/libv8-juice 20101126-1 (0)
    An library extending the V8 engine
8 aur/mingw32-v8 3.9.9-1 (0)
    A fast and modern javascript engine (mingw32)
9 aur/musepack-tools-svn 481-1 (3)
    Musepack sv8 decoder/encoder
10 aur/node-git 20091022-1 (4)
    Evented I/O for V8 javascript (git)
11 aur/nodejs-git 20110613-1 (Out of Date) (11)
    Evented I/O for V8 javascript
12 aur/nodejs-hardfp 0.8.8-1 (0)
    Evented I/O for V8 javascript
13 aur/nodejs-unstable 0.7.12-1 (Out of Date) (4)
    Evented I/O for V8 javascript, unstable version
14 aur/nodejs4 0.4.12-1 (1)
    Evented I/O for V8 javascript
15 aur/nodejs6 0.6.19-1 (3)
    Evented I/O for V8 javascript
16 aur/python-pyv8 0.9-2 (Out of Date) (6)
    a python wrapper for Google V8 javascript engine
17 aur/python-pyv8-svn 247-1 (2)
    a python wrapper for Google V8 javascript engine
18 aur/qt5-qtjsbackend-git 20121004-1 (4)
    Qt 5: qtjsbackend module (includes QtV8)
19 aur/qtjsbackend-git 20120620-1 (0)
    Qt 5: qtjsbackend module (includes QtV8)
20 aur/teajs 0.9.4-2 (1)
    Your cup of server-side Javascript. Formerly known as v8cgi.
21 aur/v8-current latest-1 (2)
    A fast and modern javascript engine
22 aur/v8-debug 10521-1 (1)
    Debug build of Google's C++ javascript engine
23 aur/v8-docs 3.4.12.1-1 (0)
    API reference guide for google v8 javascript engine
24 aur/v8-gearbox-git 20110514-1 (1)
    A shell for the v8 Javascript engine
25 aur/v8-static 2.1.2.3-2 (11)
    building Google V8 as static library required by python-pyv8
26 aur/v8-static-svn 4328-1 (2)
    building Google V8 as static library required by python-pyv8
27 aur/v8-svn 4328-1 (13)
    V8 is Google's open source JavaScript engine
28 aur/v86d-fbcondecor 0.1.9-2 (Out of Date) (12)
    v86d is the userspace helper for uvesafb that runs x86 code in an emulated environment
29 aur/v86d-zen 0.1.3-2 (Out of Date) (12)
    v86d is the userspace helper for uvesafb that runs x86 code in an emulated environment

Number 3?

EDIT: I'm sorry to tell you that it was the solution. That stupid thing made me lose a lot of time (and yours)
Thank you very much
Regards

Last edited by eherranzr (2012-10-09 19:26:08)

Offline

Board footer

Powered by FluxBB