You are not logged in.

#1 2012-09-29 15:01:50

Lowra
Member
Registered: 2009-09-21
Posts: 192

[SOLVED] nm-applet won't let me connect to WiFi network

Hey,
I'm sorry to post this, but I've been reading the wiki/forum searches for hours now without success hmm

.xinitrc

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

exec ck-launch-session openbox-session
# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice

No "dbus-launch" as you can see, I had to remove it to allow my external hdd to be mounted by users

Openbox's autostart

#
# These things are run when an Openbox X Session is started.
# You may place a similar script in $HOME/.config/openbox/autostart
# to run user-specific things.
#

# If you want to use GNOME config tools...
#
#if test -x /usr/lib/openbox/gnome-settings-daemon >/dev/null; then
#  /usr/lib/openbox/gnome-settings-daemon &
#elif which gnome-settings-daemon >/dev/null 2>&1; then
#  gnome-settings-daemon &
#fi

# If you want to use XFCE config tools...
#
#xfce-mcs-manager &

nitrogen --restore &
tint2 &
(sleep 3 && /usr/bin/nm-applet --sm-disable) &
setxkbmap fr &
numlockx &

groups

[david@laptop ~]$ groups david
wheel network video audio optical storage power users

[david@laptop ~]$ sudo cat /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla

[sudo] password for david: 
[nm-applet]
Identity=unix-group:network
Action=org.freedesktop.NetworkManager.*
ResultAny=yes
ResultInactive=no
ResultActive=yes

[david@laptop ~]$ cat /etc/rc.conf

#
# /etc/rc.conf - configuration file for initscripts
#
# Most of rc.conf has been replaced by various other configuration
# files. See archlinux(7) for details.
#
# For more details on rc.conf see rc.conf(5).
#

DAEMONS=(dbus networkmanager)

# Storage
#
# USEDMRAID="no"
# USELVM="no"

# Network
#
# interface=
# address=
# netmask=
# gateway=

In case somebody sees something I'm missing...
Thanks

EDIT: Weirdly enough, it is now solved. The only thing I did was to remove "ck-launch-session" from my .xinitrc and it worked.

Last edited by Lowra (2012-09-29 15:08:31)

Offline

#2 2012-10-11 19:28:44

ackt1c
Member
From: Visalia, California
Registered: 2012-10-10
Posts: 215

Re: [SOLVED] nm-applet won't let me connect to WiFi network

consider

pacman -S wicd wicd-gtk
systemctl enable wicd.service

~/.config/openbox/autostart

wicd-gtk --tray & (if no wicd tray icon)

I had problems with NetworkManager without consolekit.

[edit]
this is for systemd, doesn't apply to you, my bad.

Last edited by ackt1c (2012-10-11 19:30:16)

Offline

Board footer

Powered by FluxBB