You are not logged in.

#1 2012-10-11 20:42:12

fettouhi
Member
Registered: 2007-05-07
Posts: 652

[SOLVED] Black screen halfway through boot before login screen appears

I originally installed my Arch Linux 64 system on a quad core intel cpu with 4GB RAM and a Nvidia 9600 GT graphics card. Arch is installed on 2 500 GB HDD running on software RAID and LVM. A few months ago I decided I wanted to upgrade my machine to an i7-2600K with 8 GB RAM and a Nvidia 580 GTX graphics card. Since I was using pure software RAID I knew that I could just reuse my installation. So I popped in the drives into the new machine and glory glory Arch booted just fine. One thing I notied though and this has been bothered me since then. On my old machine I could see the whole boot process from start to finish. On my new machine I only see the first few seconds and then a black screen for few seconds and then I get the login screen (KDM in my case). Now I'm running a pure systemd system and I can see the boot process until

[ok]     started loading random ...

and then the black screen sets in. Why does this happen? Why can't see if udev, samba etc. start correctly anymore?

Last edited by fettouhi (2012-10-11 21:46:56)

Offline

#2 2012-10-11 20:45:50

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,840
Website

Re: [SOLVED] Black screen halfway through boot before login screen appears

KMS?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2012-10-11 20:53:33

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Black screen halfway through boot before login screen appears

Enable early start.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#4 2012-10-11 21:00:40

fettouhi
Member
Registered: 2007-05-07
Posts: 652

Re: [SOLVED] Black screen halfway through boot before login screen appears

DSpider wrote:

Enable early start.

What do you mean by early start?

BTW I'm using the nvidia proprietary driver. I did that also on my old machine with the 9600 GT card.

Last edited by fettouhi (2012-10-11 21:00:50)

Offline

#5 2012-10-11 21:10:14

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Black screen halfway through boot before login screen appears

Then remove Nouveau completely, undo any changes to mkinitcpio.conf, and re-generate your initramfs.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#6 2012-10-11 21:46:36

fettouhi
Member
Registered: 2007-05-07
Posts: 652

Re: [SOLVED] Black screen halfway through boot before login screen appears

DSpider wrote:

Then remove Nouveau completely, undo any changes to mkinitcpio.conf, and re-generate your initramfs.

I don't have the nouveau driver installed at all. But I finally got rid of the black screen. I simply added nomodeset to the kernel parameters in grub and now everything ass before.

Offline

Board footer

Powered by FluxBB