You are not logged in.

#1 2012-10-11 10:34:35

RobF
Member
Registered: 2006-10-10
Posts: 157

Update fails - /var filesystem change and glibc problem combined

I haven't updated my Arch install (i686) since April 2012. Why? I can only get on the internet through the G3 cellular network where I have to pay $$$ for every MB transferred, and regular monthly Arch updates would cost me >$5 each. Since 2006 I've never had a problem with updating Arch a few months apart; that's how good it is.

However, since April two changes in the filesystem have been implemented that give me trouble updating the system now.

1. /var/lock and /var/run -> /run/lock and /run, resp.
2. /lib -> /usr/lib

When I run # pacman -Syu now, it exits with this message:

error: failed to commit transaction (conflicting files)
glibc: /lib exists in filesystem
filesystem: /var/lock exists in filesystem
filesystem: /var/run exists in filesystem
Errors occurred, no packages were upgraded.

The version of filesystem currently running on my system is filesystem 2012.2-4. The appropriate symlinks are already in place, so it would appear the simple fix suggested in Arch News [http://www.archlinux.org/news/filesystem-upgrade-manual-intervention-required-1/ ] might work. However, pacman then still stumbles over the second filesystem change /lib -> /usr/lib, i.e.

# pacman -Syu --ignore filesystem && pacman -S filesystem --force
.......
error: failed to commit transaction (conflicting files)
glibc: /lib exists in filesystem
Errors occurred, no packages were upgraded.

If I apply the fix suggested in https://wiki.archlinux.org/index.php/De … iki:usrlib and combine it with the above /var filesystem fix, i.e. run

# pacman -Syu --ignore filesystem,glibc,curl && pacman -S filesystem --force

I get this:

.........
.........
warning: ignoring package glibc-2.16.0-4
warning: cannot resolve "glibc>=2.16", a dependency of "gcc-libs"
warning: ignoring package glibc-2.16.0-4
warning: cannot resolve "glibc>=2.16", a dependency of "gcc-libs"
:: The following packages cannot be upgraded due to unresolvable dependencies:
...... [list of hundreds of packages] .......
Do you want to skip the above packages for this upgrade? [y/N] y
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: pyqt: requires python-sip

When I then try to install the required dependencies (for pyqt) this quickly fails, as all the required /usr/lib/xxxxx files "exist in the filesystem." The idea to ignore glibc and curl and all the packages dependent on them and later to install them with pacman -Sd ....... , followed by pacman -Su, as suggested in https://wiki.archlinux.org/index.php/De … iki:usrlib, doesn't seem to be workable in my situation.

How can I get myself out of this hole? Is there a way of fixing the /var filesystem problem first, and then attend to the problem with glibc? And how do I then attack the latter problem?

Offline

#2 2012-10-11 20:53:46

jonathan183
Member
Registered: 2008-06-11
Posts: 14

Re: Update fails - /var filesystem change and glibc problem combined

Have you tried using pacman -U http://pkgbuild.com/~allan/glibc-2.16.0 … pkg.tar.xz to install glibc? that might get you out of the hole ...

Offline

#3 2012-10-12 04:12:08

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 924

Re: Update fails - /var filesystem change and glibc problem combined

ignore libarchive too or you want a pacman unable to work
and update separate the gcc and gcc-lib
rebuild you kernel post updating  ALL and pre reboot

I recomend desintal base-devel download all packages after 'pacman -Swu' and them fetch how make it work

pacman -Swu
pacman -Su --ignore gcc,glibc,filesystem,curl,libarchive,pacman
pacman -Su --ignore gcc,curl,libarchive,pacman,glibc --force filesystem
pacman -Sudd gcc gcc-lib --ignore curl,libarchive,glibc,pacman
pacman -Su glibc pacman libarchive curl

remmember that if libarchive, curl or glibc are intaled previous to pacman you are doomed

Last edited by Jristz (2012-10-12 04:19:44)


Well, I suppose that this is somekind of signature, no?

Offline

Board footer

Powered by FluxBB