You are not logged in.

#1 2012-10-11 15:52:41

kleskjr
Member
Registered: 2011-12-31
Posts: 33

[Solved]freeplane doesn't run

Hi there!
I just installed freeplane (freeplane 1.2.18-1) from AUR but it doesn't run at all.
Here is the output:

~/ freeplane 
Knopflerfish OSGi framework, version 4.1.10
Copyright 2003-2009 Knopflerfish. All Rights Reserved.

See http://www.knopflerfish.org for more information.
Loading xargs file /usr/share/freeplane/props.xargs
Loading xargs file /usr/share/freeplane/init.xargs
Installed and started: reference:file:/usr/share/freeplane/core/org.freeplane.core (id#1)
Loaded properties from bundle://1.0:0/freeplane.properties
Loaded properties from bundle://1.0:1/org/freeplane/main/application/
User properties not found, new file created
Installed: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.formula (id#2)
Installed: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.script (id#3)
Installed: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.svg (id#4)
Installed: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.bugreport (id#5)
Installed: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.latex (id#6)
Started: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.formula (id#2)
Started: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.script (id#3)
Started: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.svg (id#4)
Started: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.bugreport (id#5)
Started: reference:file:/usr/share/freeplane/plugins/org.freeplane.plugin.latex (id#6)
Oct 11, 2012 5:50:02 PM org.freeplane.core.util.LogUtils info
INFO: language resources for en found
Oct 11, 2012 5:50:02 PM org.freeplane.core.util.LogUtils info
INFO: freeplane_version = 1.2.18; freeplane_xml_version = freeplane 1.2.0
bzr revision = dpolivaev-20120812102816-u9tnzc0m8xndi66v
java_version = 1.7.0_07; os_name = Linux; os_version = 3.5.6-1-ARCH
Oct 11, 2012 5:50:03 PM org.freeplane.core.util.LogUtils info
INFO: added parsing support for standard date format M/d/yy
Oct 11, 2012 5:50:03 PM org.freeplane.core.util.LogUtils info
INFO: added parsing support for standard date time format M/d/yy h:mm a

STDOUT: Loaded properties from bundle://2.0:0/org/freeplane/plugin/formula/defaults.properties
STDOUT: Loaded properties from bundle://3.0:1/org/freeplane/plugin/script/defaults.properties
STDOUT: Framework launched
STDERR: Exception in thread "AWT-EventQueue-0" 
STDERR: java.lang.NullPointerException
STDERR:         at org.freeplane.main.application.FreeplaneStarter.loadMaps(FreeplaneStarter.java:258)
STDERR:         at org.freeplane.main.application.FreeplaneStarter.access$000(FreeplaneStarter.java:77)
STDERR:         at org.freeplane.main.application.FreeplaneStarter$1.run(FreeplaneStarter.java:213)
STDERR:         at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
STDERR:         at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:721)
STDERR:         at java.awt.EventQueue.access$200(EventQueue.java:103)
STDERR:         at java.awt.EventQueue$3.run(EventQueue.java:682)
STDERR:         at java.awt.EventQueue$3.run(EventQueue.java:680)
STDERR:         at java.security.AccessController.doPrivileged(Native Method)
STDERR:         at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
STDERR:         at java.awt.EventQueue.dispatchEvent(EventQueue.java:691)
STDERR:         at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
STDERR:         at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
STDERR:         at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
STDERR:         at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
STDERR:         at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
STDERR:         at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)

I tried with both java dependencies :

:: There are 2 providers available for java-runtime:
:: Repository extra
   1) jre7-openjdk  2) openjdk6

Any ideas where might be the problem?
thanks!

Last edited by kleskjr (2012-10-22 19:26:56)

Offline

#2 2012-10-12 09:23:32

inglor
Member
Registered: 2008-07-22
Posts: 46

Re: [Solved]freeplane doesn't run

Hello kleskjr,

Can you post the output of:
java -version

Do you have JAVA_HOME set up as variable?

I will do some tests but in my environment/ test was working with java7 and oracle-java-6 (from aur)

Offline

#3 2012-10-12 11:06:45

aurelieng
Member
Registered: 2010-02-02
Posts: 80

Re: [Solved]freeplane doesn't run

Exact same problem here:

Here is the output of java --version

java version "1.7.0_07"
OpenJDK Runtime Environment (IcedTea7 2.3.2) (ArchLinux build 7.u7_2.3.2-2-x86_64)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)


And that of echo $JAVA_HOME:

/usr/lib/jvm/java-7-openjdk

Any idea ?

Offline

#4 2012-10-12 12:34:12

inglor
Member
Registered: 2008-07-22
Posts: 46

Re: [Solved]freeplane doesn't run

Do you get the same results when you download /unzip it from here?
http://downloads.sourceforge.net/source … 1.2.18.zip

Offline

#5 2012-10-12 20:40:21

inglor
Member
Registered: 2008-07-22
Posts: 46

Re: [Solved]freeplane doesn't run

Offline

#6 2012-10-12 22:24:37

kleskjr
Member
Registered: 2011-12-31
Posts: 33

Re: [Solved]freeplane doesn't run

I have exactly the same outputs as aurelieng.

if I run this

 sh freeplane.sh 

in the unpacked freeplane_bin-1.2.20_03.zip (from the link), it runs just fine.

Seems we need the new version in AUR?

Offline

#7 2012-10-13 12:23:49

inglor
Member
Registered: 2008-07-22
Posts: 46

Re: [Solved]freeplane doesn't run

1.2.20_03 is still Beta, I can make a new aur package for beta but it suppose to be fixed in 1.2.20_04 according to the developer not in 1.2.20_03.

Offline

#8 2012-10-15 12:28:45

inglor
Member
Registered: 2008-07-22
Posts: 46

Re: [Solved]freeplane doesn't run

Beta 04 just released to public: Grab it here: http://sourceforge.net/projects/freepla … ne%20beta/
This should solve the problem. Working on a beta package in the meantime.

Offline

#9 2012-10-16 22:29:09

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,977

Re: [Solved]freeplane doesn't run

Also noticed the same, downgraded to previous version for time being.  java -version 1.7.0_07


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#10 2012-10-21 21:41:11

inglor
Member
Registered: 2008-07-22
Posts: 46

Re: [Solved]freeplane doesn't run

Aur package updated to 1.2.20 (stable) which fix this NPE. Update your packages, thanks.

Offline

#11 2012-10-22 01:32:14

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,977

Re: [Solved]freeplane doesn't run

Nice working now.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#12 2012-10-22 17:33:47

inglor
Member
Registered: 2008-07-22
Posts: 46

Re: [Solved]freeplane doesn't run

Thanks for letting me know.
@kleskjr: You can change title to [SOLVED]

Thanks

Offline

#13 2012-10-22 19:27:17

kleskjr
Member
Registered: 2011-12-31
Posts: 33

Re: [Solved]freeplane doesn't run

thanks dude!

Offline

Board footer

Powered by FluxBB