You are not logged in.

#1 2012-10-12 20:36:28

agkbill
Member
Registered: 2011-06-13
Posts: 85

[SOLVED] Highlighted text in the shell, appearance rxvt-unicode

Hi,

Short question, when I highlight text in the shell or when text get highlighted in ncmpcpp or outer app running in the shell it gets basically impossible to read. Because background to text get the same color and strength then the text.

what setting should I look for to change what it look like when I mark and highlight text in the shell?


Thank you!

All the best,
Christer

Last edited by agkbill (2012-10-13 20:41:41)

Offline

#2 2012-10-12 21:50:17

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

Shell?  Like the gas stations?

Offline

#3 2012-10-12 22:40:56

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,699
Website

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

I guess you mean when using a terminal emulator in X as (AFAIK) that's the only way you could highlight text in a sense that would fit your description.

So the answer is two fold: First, it's always seemed to just be reverse-video when highlighted, so white on black becomes black on white.  Second, this could be changed by the terminal emulator, in which case it would depend on which emulator you were using.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2012-10-12 23:48:03

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

Of course this could also be a reference to using a tty with gpm, though I assume you are probably right Trilby

Offline

#5 2012-10-13 07:32:21

agkbill
Member
Registered: 2011-06-13
Posts: 85

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

WonderWoofy:  It is not the first time my spelling make people smile. Well me and words are not the best friends all the time.

Even if English is not my first langue I still want to learn, so I guess I will spreed more smiles in the future due to my spelling smile

Offline

#6 2012-10-13 07:41:00

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

Back on topic - which DE/WM and terminal emulator do you use, agkbill?


To know or not to know ...
... the questions remain forever.

Offline

#7 2012-10-13 08:26:03

agkbill
Member
Registered: 2011-06-13
Posts: 85

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

Additional info.

I am using i3 as window manager and  terminal emulator "rxvt-unicode-256color"

.xinitrc

# set the cursor
 xsetroot -cursor_name left_ptr
 # set German keyboard layout
# setxkbmap -layout de
# start xmonad

#Power management turn off monitor etc
#xset dpms 0 7200 10800 &
xset -dpms; xset s off

# xloadimage laddar bakgrundsbild fick det inte att fungera tillsamans med xcompmgr som man 
# använder för att få genomskinliga terminal fönster mm. Ersätter med bildvisaren "feh"
#xloadimage -onroot -fullscreen /home/christer/devices-extern/windows7/archlinux/stone_wall_ce.png
xrdb -merge ~/.Xresources  # Denna rad behövs ifall man vill använda TERMINAL/emulator "urxvt"


feh --bg-scale /home/christer/devices-extern/windows7/archlinux/stone_wall_ce.png

setxkbmap -layout "us, se" -option "grp:alt_shift_toggle" #alt"grp:caps_toggle"

xcompmgr -c &
#xmonad
#awesome
exec /usr/bin/i3 -V -d all >~/i3log/i3log-$(date +'%F-%k-%M-%S') 2>&1

.Xresources

# transparency - true or false (default)
#URxvt*transparent: true

# tint with any color; i.e., blue, red, tomato4, olivedrab2, etc.
#   some nice listings are at:
#     http://www.nisrv.com/drupal/?q=node/11
#     http://www.htmlgoodies.com/tutorials/colors/article.php/3478921
URxvt*tintColor: white
URxvt*inheritPixmap: true

# shading - 0 to 99 darkens, 101 to 200 lightens.
#   Don't use with tintColor; just use a darker or lighter color instead.
#URxvt*shading: 40

# scrollback buffer lines - 65535 is max on most machines (64 is default)
URxvt*saveLines: 12000

# font color (default is black)
URxvt*foreground: DarkSlateGray1

# background color (prior to tinting) (default is white)
URxvt.depth: 32
URxvt.background: [10]#black

# Xft (X FreeType) with Bitstream, DejaVu, Liberation, or Terminus fonts:
#  Fedora/debian packages: libXft/libxft2 
#  An anti-aliased font setup with Xft looks fantastic; it can be a bit choppy 
#  on older systems. You can always turn off anti-aliasing (antialias=false) if
#  your terminal is sluggish. Use only ONE of the Xft pairs below:
#
# Xft: Bitstream fonts
#  Fedora/debian packages: bitstream-vera-sans-mono-fonts/ttf-bitstream-vera 
#URxvt*font: xft:Bitstream Vera Sans Mono:pixelsize=12:antialias=true:hinting=true
#URxvt*boldFont: xft:Bitstream Vera Sans Mono:bold:pixelsize=12:antialias=true:hinting=true
#
# Xft: DejaVu fonts
#  Fedora/debian packages: dejavu-sans-mono-fonts/ttf-dejavu 
URxvt*font: xft:DejaVu Sans Mono:pixelsize=12:antialias=true:hinting=true
URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=12:antialias=true:hinting=true
#
# Xft: Liberation fonts
#  Fedora/debian packages: liberation-mono-fonts/ttf-liberation
#URxvt*font: xft:Liberation Mono:pixelsize=13:antialias=true:hinting=true
#URxvt*boldFont: xft:Liberation Mono:bold:pixelsize=13:antialias=true:hinting=true
#
# Xft: Terminus fonts
#  Fedora/debian packages: terminus-fonts/xfonts-terminus
#URxvt*font: xft:terminus:pixelsize=15
#URxvt*boldFont: xft:terminus:bold:pixelsize=15

# Traditional fonts - a more traditional font setup in lieu of xft
#URxvt*font:-*-courier-medium-r-normal-*-14-*-*-*-*-*-iso8859-1
#URxvt*boldFont:-*-courier-bold-r-normal-*-14-*-*-*-*-*-iso8859-1

# Replace blue folder colors with a lighter shade for clarity. To
#  set colored folders and files within urxvt, xterm, and aterm, add
#  the following line to your ~/.bashrc ($HOME/.bashrc) file under
#  the heading "# User specific aliases and functions":
#   alias ls="ls -h --color=auto"
URxvt*color4: RoyalBlue
URxvt*color12: RoyalBlue

# scrollbar - true (default) or false
URxvt*scrollBar: false

# scrollbar position - left=false (default) or right=true
URxvt*scrollBar_right: false

# scrollbar style - rxvt (default), plain, next, or xterm
URxvt*scrollstyle: plain

#Fade the text by the given percentage when focus is lost.
URxvt*enable-fading on
URxvt*fade 50
URxvt*fadecolor black

Biggest problem is when I running console based applications like ncmpcpp or ranger.

Last edited by agkbill (2012-10-13 08:34:28)

Offline

#8 2012-10-13 18:22:40

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,047
Website

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

Your font color is set to DarkGray and your background color is set to black. Now i stop wondering why you complain about readability.
Try using black on white as for example in a book.

Last edited by teateawhy (2012-10-13 18:23:24)

Offline

#9 2012-10-13 18:50:54

agkbill
Member
Registered: 2011-06-13
Posts: 85

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

teateawhy: That is not the colors I see when I use the terminal. Normal use the text is very light green and no background, I use transparency.

Offline

#10 2012-10-13 19:36:48

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,699
Website

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

And when you highlight text, those are the colors you see.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#11 2012-10-13 19:58:29

agkbill
Member
Registered: 2011-06-13
Posts: 85

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

When I highlight text the background get color very similar to foreground text.

After your help that the setting should be with the terminal emulator I have looked into the doc of rxvt-unicode and there is a whole range of options.
Difficult to sort out what all of them do, but I am playing around to see what I can find.

Offline

#12 2012-10-13 20:23:57

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,699
Website

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

*headdesk*

You SET the foreground and background color to be very similar.  So when the foreground and background color are reversed, they are still very similar.

I said in the second response on this thread that highlight shows in reverse video mode meaning the foreground becomes background and background foreground.  You have set these colors to be nearly the same.  Yes, normally that's fine as it's transparent so your background doesn't show ... but when you highlight it does.  Change you background color.

Last edited by Trilby (2012-10-13 20:26:34)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#13 2012-10-13 20:40:40

agkbill
Member
Registered: 2011-06-13
Posts: 85

Re: [SOLVED] Highlighted text in the shell, appearance rxvt-unicode

Thank you Trilby!

I changed the background to black and now it looks great, very easy to read the text.
It looks so easy now when I understand how it works.

All the best!
Christer

PS: Also found out other great things with rxvt-unicode like fading. smile

Offline

Board footer

Powered by FluxBB