You are not logged in.

#1 2012-10-12 17:15:55

Kebertx
Member
Registered: 2012-01-02
Posts: 69

[SOLVED] How might I stop the blinking text in urxvt?

Just installed rxvt-unicode because supposedly it's really good or something, and here's the first thing I noticed:
tZnV0OA
tZnV0OQ
It blinks! I have no idea why this is or how to make it stop.
My .Xdefaults looks like this: (I just pulled it from here)

URxvt.foreground: #dcdccc

!URxvt.depth: 32
URxvt*background: #3f3f3f

URxvt.saveLines:32767
URxvt.scrollBar: false

URxvt*font: xft:Terminus:pixelsize=12

URxvt.perl-ext-common: default,matcher
URxvt.urlLauncher: uzbl-browser
URxvt.matcher.button: 2
URxvt.matcher.pattern.1: \\bwww\\.[\\w-]\\.[\\w./?&@#-]*[\\w/-]

URxvt*colorUL: #c5f779
URxvt*underlineColor: #c5f779

URxvt*color0:	#3f3f3f
URxvt*color1:       #705050
URxvt*color2:     #60b48a
URxvt*color3:    #dfaf8f
URxvt*color4:      #506070
URxvt*color5:   #dc8cc3
URxvt*color6:      #8cd0d3
URxvt*color7:     #DCDCCC

URxvt*color8:      #709080
URxvt*color9:      #cc9393
URxvt*color10:    #7f9f7f
URxvt*color11:   #f0dfaf
URxvt*color12:     #94bff3
URxvt*color13:  #ec93d3
URxvt*color14:    #93e0e3
URxvt*color15:          #ffffff

!black
xterm*color0:         #353535
xterm*color8:         #666666
!red
xterm*color1:         #AE4747
xterm*color9:         #EE6363
!green
xterm*color2:         #556B2F
xterm*color10:        #9ACD32
!brown/yellow
xterm*color3:         #DAA520
xterm*color11:        #FFC125
!blue
xterm*color4:         #6F99B4
xterm*color12:        #7C96B0
!magenta
xterm*color5:         #8B7B8B
xterm*color13:        #D8BFD8
!cyan
xterm*color6:         #A7A15E
xterm*color14:        #F0E68C
!white
xterm*color7:         #DDDDDD
xterm*color15:        #FFFFFF

And I can't figure out how to define the blinking attribute for urxvt. I don't know why that's a thing in the first place, no one could possibly have an easy time reading text that is in this way. Any advice would be appreciated. I wouldn't lose a wink of sleep though if at the end of the day I just switched back to guake.

Last edited by Kebertx (2012-10-13 19:30:12)

Offline

#2 2012-10-13 00:03:46

Thanoulis
Member
From: Thessaloniki, Greece
Registered: 2009-05-03
Posts: 31
Website

Re: [SOLVED] How might I stop the blinking text in urxvt?

Try this:

URxvt.cursorBlink: false

Also, you might want to check man urxvt for further documentation.

EDIT: Oops, i just realized your problem. It seems to me that you have some ANSI terminal code to enable blink text (check your shell rc file), or maybe you played with tput, or you have a bugged terminfo file.
I use urxvt as my standard terminal application, and works fine here. (community/rxvt-unicode 9.15-3)

Last edited by Thanoulis (2012-10-13 00:20:19)


-- Beware of he who would deny you access to information, for in his heart he dreams himself your master.

Offline

#3 2012-10-13 02:52:18

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [SOLVED] How might I stop the blinking text in urxvt?

What output do you get when you issue

echo $TERM

?


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#4 2012-10-13 10:12:05

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,307
Website

Re: [SOLVED] How might I stop the blinking text in urxvt?

What's your PS1?

Offline

#5 2012-10-13 16:09:34

Kebertx
Member
Registered: 2012-01-02
Posts: 69

Re: [SOLVED] How might I stop the blinking text in urxvt?

x33a wrote:

What's your PS1?

Some builtin zsh nonsense, why?

%B%F{black}┌%b%F{green}┌%B%F{blue}(%b%F{green}%n%B%F{black}@%b%F{green}%m%B%F{blue})%b%F{green}┌%B%F{blue}(%b%F{green}%D{%I:%M%P}%B%F{black}:%b%F{green}%D{%m/%d/%y}%B%F{blue})%b%F{green}┌[%?]%B%F{black}-%b%f
%{
%}%B%F{black}└%b%F{green}┌%B%F{blue}(%b%F{green}%#%B%F{black}:%b%F{green}%~%B%F{blue})%b%F{green}┌%B%F{black}-%b%f
URxvt.cursorBlink: false

Didn't help, but was worth a shot.

Thanoulis wrote:

EDIT: Oops, i just realized your problem. It seems to me that you have some ANSI terminal code to enable blink text (check your shell rc file), or maybe you played with tput, or you have a bugged terminfo file.
I use urxvt as my standard terminal application, and works fine here. (community/rxvt-unicode 9.15-3)

Checking my .zshrc, I see... wait...

LS_COLORS='di=00:fi=05:ln=05:pi=05:so=05:bd=05:cd=05:or=05:mi=31:ex=01;05;31:*.png=36:*.jpg=36:*.gif=36:*.xcf=36:*.tar=95:*.gz=95:*.xz=95:*.rar=95:*.zip=95:*.7z=95:*.avi=33:*.mp4=33:*.m4v=33::*.mkv=33:*.wmv=33:*.flv=33:*.mp3=34:*.wav=34:*.doc=37:*.ppt=37:*.pdf=37:*.iso=35'

That must be it! THE LS COLORS! That's the answer! 05 is for flashing text!

Isn't it cool how Arch works perfectly unless you've done something wrong in the past?

Anyways, thank you. I'm marking this as solved now.

Offline

#6 2012-10-13 18:18:34

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,047
Website

Re: [SOLVED] How might I stop the blinking text in urxvt?

Check out /usr/bin/dircolors to generate your color line correctly. Also mark as solved.

Offline

Board footer

Powered by FluxBB