You are not logged in.

#1 2012-10-13 16:12:40

Caspian
Member
Registered: 2007-05-22
Posts: 190

[SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Hi everyone,

I'm experiencing significant video tearing on full screen videos under kde 4.9. I've read many posts and suggestions and have tried most of them:
-disabling vsync
-disabling effects
-disabling OpenGl 2 shaders
-trying several video players such as mplayer, vlc, etc....

No matter what I'm experiencing video tearing which is mostly visible on the top of the video. Any suggestions would be very welcome. I managed to solve these issues in Gnome by adding "CLUTTER_PAINT=disable-clipped-redraws:disable-culling" to /etc/environment...
I apologize if this has already been solved and written, I simply couldn't find anything that was helpful in solving this issue.

Last edited by Caspian (2012-10-16 08:28:36)

Offline

#2 2012-10-13 17:27:39

stressat
Member
From: Romania
Registered: 2010-10-10
Posts: 69
Website

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

System settings- multimedia- phonon- backend: install and change gstreamer with phonon-vlc or phonon-mplayer-git (AUR).

Offline

#3 2012-10-13 17:34:58

Caspian
Member
Registered: 2007-05-22
Posts: 190

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Thanks for your reply stressat. I've changed the frontend to vlc but this didn't help as well. Still the same tearing... sad

Offline

#4 2012-10-13 23:09:25

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Which acceleration method are you using? Have you tried the other one? Details are on the intel wiki page if you aren't sure what I'm talking about. (One is sna but I forget the name of the other right now.)

(I actually get more issues with the one which is supposed to do better but I rarely watch video.)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2012-10-14 08:29:05

Caspian
Member
Registered: 2007-05-22
Posts: 190

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

I've tried the SNA acceleration method and nothing changed. I forgot to mention that there is a tearing while moving windows. It is not "hardware related" since this is not happening in gnome with the above mentioned fix...

Offline

#6 2012-10-14 10:08:00

Nimatek
Member
Registered: 2009-09-22
Posts: 23

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

I started experiencing the same issue. Enabling SNA, adding Option "TearFree" "true", and installing libva-intel-driver seems to have fixed it.

Offline

#7 2012-10-14 18:08:46

Caspian
Member
Registered: 2007-05-22
Posts: 190

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Nimatek wrote:

I started experiencing the same issue. Enabling SNA, adding Option "TearFree" "true", and installing libva-intel-driver seems to have fixed it.

Hey Nimatek, thanks for the tip. I've added Option "TearFree" "true" along with SNA acceleration method. This solved the tearing problem, however now I'm having performance issues. It is so slow, it makes it unusable sad To change the topic a bit: I have Nvidia optimus in my lapto. I bet that most of you know the problems with optimus. I've read almost everything regarding optimus and bumblebee. I know that I can disable Nvidia and use only integrated Intel (this is what I'm using now). Does anyone know if I can do the opposite (disable Intel and use Nvidia)? I presume thta using Nvidia would solve the tearing problem as well...

Offline

#8 2012-10-15 08:05:04

Caspian
Member
Registered: 2007-05-22
Posts: 190

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

What ever I've tried so far didn't help at all except the SNA method along with TearFree option, but this makes the KDE unusable because it's very slow. I guess that I'll need to go back to Gnome... sad Anyone else experiencing this issue and can't solve it?

Offline

#9 2012-10-15 17:31:12

damiarch
Member
Registered: 2012-08-10
Posts: 9

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Caspian wrote:

What ever I've tried so far didn't help at all except the SNA method along with TearFree option, but this makes the KDE unusable because it's very slow. I guess that I'll need to go back to Gnome... sad Anyone else experiencing this issue and can't solve it?

It appears to be a regression that appeared with the big update to Mesa 9 and the new Xorg server.

TearFree kills performance in KDE for me as well; for now, I fixed it by going into Desktop Effects->Advanced and changing the compositing type from OpenGL to XRender.  Unfortunately, not all effects work with it but it at least provides a usable speed for me until this bug is fixed.

Offline

#10 2012-10-15 19:34:31

Caspian
Member
Registered: 2007-05-22
Posts: 190

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Thanks for the reply damiarch. This seems to have solved my problem. Now using sna, TearFree option, xrender and everything seems to be in order. Do you know where can we track the status of this bug in order to know when it's been fixed?

Offline

#11 2012-10-15 20:31:30

damiarch
Member
Registered: 2012-08-10
Posts: 9

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Caspian wrote:

Thanks for the reply damiarch. This seems to have solved my problem. Now using sna, TearFree option, xrender and everything seems to be in order. Do you know where can we track the status of this bug in order to know when it's been fixed?

Bug report here :
https://bugs.freedesktop.org/show_bug.cgi?id=55998

If you have time, please post your experiences there.  The more confirmations, the better.

Offline

#12 2012-10-16 08:28:19

Caspian
Member
Registered: 2007-05-22
Posts: 190

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

Great! Will do. Marking this as solved (sort of)

Offline

#13 2012-11-23 18:44:53

snoxu
Member
Registered: 2010-01-24
Posts: 141

Re: [SOLVED]Video tearing with KDE 4.9 on Intel i915/ Optimus

What's the status on this? Is the tearing in Kwin/opengl fixed?

I've also been experiencing video hickups in Gnome.

Offline

Board footer

Powered by FluxBB