You are not logged in.

#1 2012-10-12 18:48:22

melongex
Member
Registered: 2012-09-26
Posts: 10

OpenCV needs libIlmImf.so.6

Hi guys!
I'm programming with opencv and after todays upgrade I get following message when compiling:

:-1: warning: libIlmImf.so.6, needed by /usr/lib/libopencv_highgui.so, not found (try using -rpath or -rpath-link)

Heres 'pacman -Qo /usr/lib/libIlmImf*'

/usr/lib/libIlmImf.a is owned by openexr 1.7.1-1
/usr/lib/libIlmImf.so is owned by openexr 1.7.1-1
/usr/lib/libIlmImf.so.7 is owned by openexr 1.7.1-1
/usr/lib/libIlmImf.so.7.0.0 is owned by openexr 1.7.1-1

so there's really no libIlmImf.so.6 .


Cheers

Offline

#2 2012-10-12 18:52:35

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: OpenCV needs libIlmImf.so.6

That file used to be provided by openexr.
https://bugs.archlinux.org/task/31917

Last edited by karol (2012-10-12 18:53:32)

Offline

#3 2012-10-13 03:33:34

walmartshopper
Member
Registered: 2010-03-31
Posts: 30

Re: OpenCV needs libIlmImf.so.6

This is preventing Digikam from starting too.

Offline

#4 2012-10-13 04:05:19

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,408
Website

Re: OpenCV needs libIlmImf.so.6

Looks like there was an unexpected soname bump that was missed. (they are unusual with a minor version bump of the package...).  Made a TODO list to get this fixed: http://www.archlinux.org/todolists/#187

Offline

#5 2012-10-13 04:08:06

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: OpenCV needs libIlmImf.so.6

walmartshopper wrote:

This is preventing Digikam from starting too.

And blender too: https://bugs.archlinux.org/task/31918
Symlinking libraries like that is a bad practice but may work - just remember to remove the symlink later.

Last edited by karol (2012-10-13 04:11:27)

Offline

#6 2012-10-13 09:05:44

strigyskow
Member
Registered: 2009-04-20
Posts: 6

Re: OpenCV needs libIlmImf.so.6

I've edited the PKGBUILD to create a symlink in the package. Not sure if that's a better practice, though...

# $Id: PKGBUILD 168476 2012-10-12 12:47:54Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>

pkgname=openexr
pkgver=1.7.1
pkgrel=1
pkgdesc="An high dynamic-range image file format library"
url="http://www.openexr.com/"
arch=('i686' 'x86_64')
license=('BSD')
depends=('zlib' 'ilmbase')
options=('!libtool')
source=("https://github.com/downloads/${pkgname}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
        'gcc43.patch')

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  patch -p0 -i ${srcdir}/gcc43.patch
  ./configure --prefix=/usr
  make
}

package() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  make DESTDIR="${pkgdir}" install
  install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# The line that fixes problems
  ln -s "${pkgdir}/usr/lib/libIlmImf.so.7" "${pkgdir}/usr/lib/libIlmImf.so.6"
}

md5sums=('a9e0369dfd68941c50cdaa93e9d7a8d1'
         'd91fae759053a70bcedcf02eb33ca4a2')

Offline

#7 2012-10-13 09:12:29

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,408
Website

Re: OpenCV needs libIlmImf.so.6

No...   symlinks are bad.  Library soname change for a reason.

Updating would be the solution.  Almost all rebuilds are now done.

Offline

#8 2012-10-13 12:37:29

strigyskow
Member
Registered: 2009-04-20
Posts: 6

Re: OpenCV needs libIlmImf.so.6

Good to know, thanks. I promise to revert to the original openexr package, once the new blender package is on my mirror smile

Offline

#9 2012-10-13 13:13:22

smakked
Member
From: Gold Coast , Australia
Registered: 2008-08-14
Posts: 419

Re: OpenCV needs libIlmImf.so.6

Darktable has the same error but will wait for the new packages


Certified Android Junkie
Arch 64

Offline

#10 2012-10-13 18:53:07

Kopfweh
Member
Registered: 2011-08-06
Posts: 72

Re: OpenCV needs libIlmImf.so.6

What? Now I can't even install xf86-video-nouveau and the proprietary driver anymore as xf86-video-nouveau needs libgl even without nouveau-dri!

Offline

#11 2012-10-13 19:06:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: OpenCV needs libIlmImf.so.6

Kopfweh wrote:

What? Now I can't even install xf86-video-nouveau and the proprietary driver anymore as xf86-video-nouveau needs libgl even without nouveau-dri!

AFAICS, xf86-video-nouveau 1.0.2-2 depends on nouveau-dri 9.0-1 which in turn depends on libgl 9.0-1.
How are you using nouveau w/o nouveau-dri?

Offline

#12 2012-10-13 19:41:51

Kopfweh
Member
Registered: 2011-08-06
Posts: 72

Re: OpenCV needs libIlmImf.so.6

I don't use it at all, just as "fallback" for the case that the proprietary driver doesn't start anymore after any failed upgrade or kernel-rebuild or stuff like that. xf86-video-nouveau doesn't have 3d-acceleration without nouveau-dri but I also didn't need it because it was just an emergancy-insurance. But now I cannot even install xf86-video-nouveau only even more.

Offline

#13 2012-10-13 19:47:30

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: OpenCV needs libIlmImf.so.6

Ah, now I get it: https://projects.archlinux.org/svntogit … 646bbd32b4
nouveau-dri used to be an optdepend.

Offline

#14 2012-10-13 20:34:13

Kopfweh
Member
Registered: 2011-08-06
Posts: 72

Re: OpenCV needs libIlmImf.so.6

Ah, exactly, thanks again, karol! wink That's it! I thought it might be somehow connected with this opencv-thing.

Offline

Board footer

Powered by FluxBB