You are not logged in.

#1 2012-10-12 17:36:46

kalle97
Member
Registered: 2012-07-18
Posts: 80

Alsamixer won't start, only for root

$ sudo pacman -S alsa-utils
resolving dependencies...
looking for inter-conflicts...

Targets (1): alsa-utils-1.0.26-1

Total Installed Size:   2.04 MiB
Net Upgrade Size:       0.00 MiB

Proceed with installation? [Y/n] y
(1/1) checking package integrity              [##########] 100%
(1/1) loading package files                   [##########] 100%
(1/1) checking for file conflicts             [##########] 100%
(1/1) checking available disk space           [##########] 100%
(1/1) upgrading alsa-utils                    [##########] 100%
$ alsamixer
cannot open mixer: No such file or directory
$ sudo alsamixer
*launches alsamixer*

I don't understand, but I can't simply launch alsamixer from my user, I've added my user to audio group and all, please tell if I need to apply further info. Anyone know what is causing this problem? Thanks in advance!

Last edited by kalle97 (2012-10-12 17:38:07)

Offline

#2 2012-10-12 17:57:53

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: Alsamixer won't start, only for root

Does your user have ~/.asoundrc?

Offline

#3 2012-10-12 17:58:41

kalle97
Member
Registered: 2012-07-18
Posts: 80

Re: Alsamixer won't start, only for root

No, can I configure my audio volume there?

Offline

#4 2012-10-12 18:15:18

DarkCerberus
Member
From: England, United Kingdom
Registered: 2011-12-31
Posts: 246

Re: Alsamixer won't start, only for root

Have you read the archlinux wiki about the alsa sound system if not - here https://wiki.archlinux.org/index.php/Alsa#Configuration


"Time travel is not just some technological marvel. It's the family business." - Mr Escher - Continuum

Offline

#5 2012-10-12 18:18:56

kalle97
Member
Registered: 2012-07-18
Posts: 80

Re: Alsamixer won't start, only for root

Yes, but when my cards seem to only be available for root, this might be a permission problem, I'm not sure what file/whatever that I don't have permission to...

Offline

#6 2012-10-12 18:21:53

DarkCerberus
Member
From: England, United Kingdom
Registered: 2011-12-31
Posts: 246

Re: Alsamixer won't start, only for root

What would happen if you tried pulseaudio and its audio manager pavucontrol? Some systems which I have require pulseaudio - see if yours is the same.


"Time travel is not just some technological marvel. It's the family business." - Mr Escher - Continuum

Offline

#7 2012-10-12 19:15:12

brebs
Member
Registered: 2007-04-03
Posts: 3,413

Re: Alsamixer won't start, only for root

Just do some simple checks:

As root:

which alsamixer

As your normal user:
Log out, then log back in, then:

groups
echo $PATH
/usr/bin/alsamixer

Offline

#8 2012-10-12 19:32:41

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Alsamixer won't start, only for root

The "/usr/bin" path should already be set from /etc/profile ...


Are you in the "audio" group?

Last edited by DSpider (2012-10-12 19:32:54)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#9 2012-10-12 19:34:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,426

Re: Alsamixer won't start, only for root

DSpider wrote:

Are you in the "audio" group?

He said he is in the first post.

Offline

#10 2012-10-12 20:12:34

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Alsamixer won't start, only for root

Log out (or reboot), because the group changes to not take effect until you do.

This is easy to overlook, especially if you're on a laptop and you're always putting it to sleep instead of shutting it down.


Edit: By the way, is this a fresh install? Because the "audio" group was removed just the other day from the Beginners' Guide: https://wiki.archlinux.org/index.php?ti … did=227617

16:12, 10 October 2012 Thestinger (Talk | contribs) . . (-75) . . (should not add users to the audio group by default, it is not needed to play sounds from a local login and change mixer levels)

So maybe it's needed after all? ...

Last edited by DSpider (2012-10-12 20:18:58)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#11 2012-10-13 20:18:30

madeye
Member
From: Denmark
Registered: 2006-07-19
Posts: 331
Website

Re: Alsamixer won't start, only for root

I have the same problem as kalle97.
This is on a new install. And what I have discovered (although I have no solution yet) is that the snd files have some weird permission settings.

[root@Marcher ~]# ls -l /dev/snd
total 0
drwxr-xr-x 2 root root       60 Oct 13 21:56 by-id
drwxr-xr-x 2 root root       80 Oct 13 21:56 by-path
crw-rw---- 1 root audio 116,  9 Oct 13 21:56 controlC0
crw-rw---- 1 root audio 116,  3 Oct 13 21:56 controlC1
crw-rw---- 1 root audio 116,  8 Oct 13 21:56 hwC0D0
crw-rw---- 1 root audio 116,  7 Oct 13 21:58 pcmC0D0c
crw-rw---- 1 root audio 116,  6 Oct 13 21:58 pcmC0D0p
crw-rw---- 1 root audio 116,  5 Oct 13 21:56 pcmC0D1p
crw-rw---- 1 root audio 116,  4 Oct 13 21:56 pcmC0D2c
crw-rw---- 1 root audio 116,  2 Oct 13 21:58 pcmC1D0c
crw-rw---- 1 root audio 116,  1 Oct 13 21:56 seq
crw-rw---- 1 root audio 116, 33 Oct 13 21:56 timer
[root@Marcher ~]# 

See the group! "audio 116," doesn't really make sense to me?


MadEye | Registered Linux user #167944 since 2000-02-28 | Homepage

Offline

#12 2012-10-13 20:20:33

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: Alsamixer won't start, only for root

madeye wrote:

See the group! "audio 116," doesn't really make sense to me?

That's because the 116 is the device major. You're looking at character devices, so ls displays the major/minor device numbers.

Offline

#13 2012-10-13 20:21:10

karol
Archivist
Registered: 2009-05-06
Posts: 25,426

Re: Alsamixer won't start, only for root

I too have 'audio 116,' stuff but I have no problems launching alsamixer.

Offline

#14 2012-10-14 12:08:43

madeye
Member
From: Denmark
Registered: 2006-07-19
Posts: 331
Website

Re: Alsamixer won't start, only for root

Some extra information that might help. (I don't want to hijack this thread, but seeing as the OP and me have the same problems I thought it better to keep the information in the same thread)

On this new installation I've done, I've activated systemd. Seeing as this will be the default at some point I thought it to be a good idea.
Just for making sure this was not the problem, I tried to disable it again.
This did not alter the problem until I made my user a member of the audio group (again, I should say, as I had tried this before without any luck). And of course logging out and in again. Now access to the sound card is working.

Then I tried to enable systemd again. And I still seem to have access to the audio card? Now I'm even more confused? roll

EDIT: I should clarify that when I decided to disable systemd I had tried uninstalling consolekit (and everything that depended on it). These were installed again while systemd was disabled.
Whether this had any impact on the audio problem, I don't know.

Last edited by madeye (2012-10-15 18:55:18)


MadEye | Registered Linux user #167944 since 2000-02-28 | Homepage

Offline

#15 2012-10-14 12:33:52

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: Alsamixer won't start, only for root

udev tags sound devices. logind later applies ACLs for an authenticated session so that it has the ability to play audio without any further requirements.

$ ls -l /dev/snd
total 0
drwxr-xr-x   3 root root      160 Oct  6 17:32 .
drwxr-xr-x  17 root root     2960 Oct  6 17:32 ..
drwxr-xr-x   2 root root       60 Oct  6 17:32 by-path
crw-rw----+  1 root audio 116,  5 Oct  6 17:32 controlC0
crw-rw----+  1 root audio 116,  2 Oct  6 17:32 midiC0D0
crw-rw----+  1 root audio 116,  4 Oct  7 11:29 pcmC0D0c
crw-rw----+  1 root audio 116,  3 Oct 13 15:18 pcmC0D0p
crw-rw----+  1 root audio 116, 33 Oct  6 17:32 timer

note the '+' at the end of the file mode. This indicates that ACLs are applied.

$ getfacl /dev/snd/pcmC0D0p
getfacl: Removing leading '/' from absolute path names
# file: dev/snd/pcmC0D0p
# owner: root
# group: audio
user::rw-
user:noclaf:rw-
group::rw-
mask::rw-
other::---

$ whoami
noclaf
$ groups
adm disk wheel users

Last edited by falconindy (2012-10-14 12:34:34)

Offline

Board footer

Powered by FluxBB