You are not logged in.

#1 2012-10-14 10:38:16

jk121960
Member
Registered: 2011-12-09
Posts: 254

Upgrade problem possibly evdev [Solved]

Sorry posted to wrong forum, put link in hardware.

Hi, I am experiencing a strange problem, I updated and my movement from screen to screen by keys is not functioning properly. I am using awesome-git. I have 3 screens and when I move between them with keys it skips over the middle screen after I booted again it skipped the thrid screen. I update regularly and I checked pacman.log and the last awesome git update was 6/3/2012 so I am at a loss why this is happening. I noticed that xf86-input-evdev was updated. I tried to downgrade ev-dev but lost mouse support, so obviously there are a number of files that need to be downgraded togeather so I had to bring it back up. Here is a list of the apps updates If someone has an insight into this I would be very grateful.

[2012-10-14 03:12] Running 'pacman -S -u'
[2012-10-14 03:12] starting full system upgrade
[2012-10-14 03:18] upgraded calligra-filters (2.5.3-1 -> 2.5.3-2)
[2012-10-14 03:18] upgraded calligra-templates (2.5.3-1 -> 2.5.3-2)
[2012-10-14 03:18] upgraded calligra-servicetypes (2.5.3-1 -> 2.5.3-2)
[2012-10-14 03:18] upgraded calligra-libs (2.5.3-1 -> 2.5.3-2)
[2012-10-14 03:18] upgraded calligra-plugins (2.5.3-1 -> 2.5.3-2)
[2012-10-14 03:18] installed glu (9.0.0-1)
[2012-10-14 03:18] upgraded glew (1.8.0-1 -> 1.8.0-2)
[2012-10-14 03:18] upgraded calligra-krita (2.5.3-1 -> 2.5.3-2)
[2012-10-14 03:18] upgraded compiz-core (0.8.8-3 -> 0.8.8-4)
[2012-10-14 03:18] upgraded compiz-decorator-gtk (0.8.8-3 -> 0.8.8-4)
[2012-10-14 03:18] upgraded compiz-decorator-kde (0.8.8-3 -> 0.8.8-4)
[2012-10-14 03:18] upgraded erlang (R15B01-1 -> R15B01-2)
[2012-10-14 03:18] upgraded mesa (8.0.4-3 -> 9.0-1)
[2012-10-14 03:18] upgraded ftgl (2.1.3rc5-3 -> 2.1.3rc5-4)
[2012-10-14 03:18] upgraded gnash-common (0.8.10-4 -> 0.8.10-5)
[2012-10-14 03:18] upgraded systemd (194-1 -> 194-3)
[2012-10-14 03:18] upgraded sysvinit-tools (2.88-8 -> 2.88-9)
[2012-10-14 03:18] warning: /etc/rc.conf installed as /etc/rc.conf.pacnew
[2012-10-14 03:18] ----
[2012-10-14 03:18] > systemd no longer reads MODULES from rc.conf.
[2012-10-14 03:18] ----
[2012-10-14 03:18] upgraded initscripts (2012.09.2-2 -> 2012.10.1-1)
[2012-10-14 03:18] upgraded jasper (1.900.1-7 -> 1.900.1-8)
[2012-10-14 03:18] upgraded khrplatform-devel (8.0.4-3 -> 9.0-1)
[2012-10-14 03:18] upgraded libglapi (8.0.4-3 -> 9.0-1)
[2012-10-14 03:18] upgraded lib32-libglapi (8.0.4-4 -> 9.0-1)
[2012-10-14 03:18] upgraded lib32-libgl (8.0.4-4 -> 9.0-1)
[2012-10-14 03:18] upgraded libgbm (8.0.4-3 -> 9.0-1)
[2012-10-14 03:18] upgraded libegl (8.0.4-3 -> 9.0-1)
[2012-10-14 03:18] upgraded libgles (8.0.4-3 -> 9.0-1)
[2012-10-14 03:18] upgraded libreoffice-en-US (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-common (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-base (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-calc (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-draw (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-extension-nlpsolver (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-extension-pdfimport (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-extension-presentation-minimizer (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-extension-presenter-screen (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-extension-report-builder (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-extension-wiki-publisher (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-gnome (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-impress (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-kde4 (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-math (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:18] upgraded libreoffice-postgresql-connector (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:19] upgraded libreoffice-sdk (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:19] upgraded libreoffice-sdk-doc (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:19] upgraded libreoffice-writer (3.6.2-1 -> 3.6.2-2)
[2012-10-14 03:19] upgraded qt3 (1:3.3.8b-1 -> 1:3.3.8b-2)
[2012-10-14 03:19] upgraded sysvinit (2.88-8 -> 2.88-9)
[2012-10-14 03:19] upgraded xf86-input-evdev (2.7.3-1 -> 2.7.3-2)
[2012-10-14 03:19] upgraded xine-lib (1.2.2-1 -> 1.2.2-2)
[2012-10-14 03:19] upgraded xorg-server-common (1.12.4-1 -> 1.13.0-2)
[2012-10-14 03:19] upgraded xorg-server (1.12.4-1 -> 1.13.0-2)
[2012-10-14 03:19] upgraded xorg-server-xephyr (1.12.4-1 -> 1.13.0-2)

thanks

--jerry

PS I have also found a few errors that have now appeared in the 'messages'log'

dbus[680]: [system] Activated service 'org.bluez' failed: Launch helper exited with unknown return code 1
dbus[680]: [system] Activated service 'org.freedesktop.NetworkManager' failed: Launch helper exited with unknown return code 1
chromium[2106]: segfault at b68005a ip 00007f98dd167343 sp 00007fff8486f8f0 error 6 in chromium[7f98dbd2c000+3f27000]
dbus[679]: [system] Failed to activate service 'org.freedesktop.Avahi': timed out

Last edited by jk121960 (2012-10-18 00:38:18)


Arch Awesome, Ranger & Vim the coding triple threat.

Offline

#2 2012-10-14 13:43:56

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,548

Re: Upgrade problem possibly evdev [Solved]

mod action: moved to correct subforum. jk121960, next time please use the handy dandy report feature to inform us moderators faster. Thanks. smile


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#3 2012-10-14 15:56:14

vrg
Member
Registered: 2012-06-18
Posts: 34

Re: Upgrade problem possibly evdev [Solved]

Glad to see I'm not the only one with this problem. I'm having similar issues with my Toshiba Qosmio X505 laptop since yesterday's update. I cannot use many of my custom shortcuts, cannot adjust the volume/brightness using the volume/brightness keys, cannot poweroff with the power button, etc.

I also think it's because of yesterday's xf86-input-evdev update, from 2.7.3-1 to 2.7.3-2. I tried to downgrade the package and I lost both mouse and keyboard support sad

Also looking forward to any insights on this...

------------------------------------------------------
EDIT: These topics seem to be related:

https://bbs.archlinux.org/viewtopic.php?id=150636
https://bbs.archlinux.org/viewtopic.php?pid=1175368

Note that the last one is marked as [SOLVED], but it's clearly not solved yet.

Last edited by vrg (2012-10-14 16:07:13)

Offline

#4 2012-10-17 13:39:20

jk121960
Member
Registered: 2011-12-09
Posts: 254

Re: Upgrade problem possibly evdev [Solved]

Hi, I have noticed another problem now, is that my Shift-k now sends the focus to another screen. This all coincided with the xf86-input-evdev update, from 2.7.3-1 to 2.7.3-2 hopefully there is a fix soon. I would be very grateful if somone knows all the files to downgrade from the last upgrade while I await the next version.

thanks for any help

--jerry


Arch Awesome, Ranger & Vim the coding triple threat.

Offline

#5 2012-10-18 00:37:50

jk121960
Member
Registered: 2011-12-09
Posts: 254

Re: Upgrade problem possibly evdev [Solved]

vrg wrote:

Glad to see I'm not the only one with this problem. I'm having similar issues with my Toshiba Qosmio X505 laptop since yesterday's update. I cannot use many of my custom shortcuts, cannot adjust the volume/brightness using the volume/brightness keys, cannot poweroff with the power button, etc.

I also think it's because of yesterday's xf86-input-evdev update, from 2.7.3-1 to 2.7.3-2. I tried to downgrade the package and I lost both mouse and keyboard support sad

Also looking forward to any insights on this...

------------------------------------------------------
EDIT: These topics seem to be related:

https://bbs.archlinux.org/viewtopic.php?id=150636
https://bbs.archlinux.org/viewtopic.php?pid=1175368

Note that the last one is marked as [SOLVED], but it's clearly not solved yet.

I didn't try this at first because it was not solved but the info on pid=1175368 solved my problem.

thanks again

--jerry


Arch Awesome, Ranger & Vim the coding triple threat.

Offline

Board footer

Powered by FluxBB