You are not logged in.

#1 2012-10-14 16:53:37

Konsyst
Member
Registered: 2012-10-14
Posts: 3

Samsung NP900X4C: System does not resume from suspend on lid open

Hi,

I just installed Arch on my Samsung Series 9 laptop and it's working great, except I can't get my system to wake from suspend when I open the lid. I'm using only systemd, all other power managers are uninstalled(no laptop-mode-tools, acpid, or pm-utils). I also have samsung-tools and samsung_laptop installed and running.

I have logind.conf on:
HandleLidSwitch=suspend
LidSwitchIgnoreInhibited=yes
with all other settings default.

Using Openbox as a WM, no DE.

I did a search and this should be a toggle, but I cant find LID0 in my /proc/acpi/wakeup.
/proc/acpi/button/lid/LID0/state exists, however.

/proc/acpi/wakeup:

Device	S-state	  Status   Sysfs node
P0P1	  S4	*disabled  
GLAN	  S4	*disabled  
XHC	  S4	*disabled  
HDEF	  S4	*disabled  pci:0000:00:1b.0
RP01	  S4	*disabled  pci:0000:00:1c.0
PXSX	  S4	*disabled  pci:0000:01:00.0
RP02	  S4	*disabled  
PXSX	  S4	*disabled  
RP03	  S4	*disabled  
PXSX	  S4	*disabled  
RP04	  S4	*disabled  pci:0000:00:1c.3
PXSX	  S4	*enabled   pci:0000:02:00.0
RP06	  S4	*disabled  
PXSX	  S4	*disabled  
RP07	  S4	*disabled  
PXSX	  S4	*disabled  
RP08	  S4	*disabled  
PXSX	  S4	*disabled  
PEG0	  S4	*disabled  
PEGP	  S4	*disabled  
PEG1	  S4	*disabled  
PEG2	  S4	*disabled  
PEG3	  S4	*disabled  
PWRB	  S4	*enabled   

Last edited by Konsyst (2012-10-14 19:38:15)

Offline

#2 2012-10-16 03:24:42

Konsyst
Member
Registered: 2012-10-14
Posts: 3

Re: Samsung NP900X4C: System does not resume from suspend on lid open

Anyone? Is it possible to set this up if LID isn't in wakeup?

Offline

#3 2012-10-18 18:43:00

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,326
Website

Re: Samsung NP900X4C: System does not resume from suspend on lid open

Moving to Laptop Issues...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#4 2012-10-28 01:33:25

Konsyst
Member
Registered: 2012-10-14
Posts: 3

Re: Samsung NP900X4C: System does not resume from suspend on lid open

Still an issue, bump...

Offline

#5 2012-11-05 16:15:07

Zariel
Member
Registered: 2008-10-07
Posts: 446

Re: Samsung NP900X4C: System does not resume from suspend on lid open

I had this issue on my 900x3c, fixed it by disabling acpicd which seems to duplicate work which systemd (logind) now does.

/edit. Turns out this is an ACPI bug

Last edited by Zariel (2012-11-05 17:32:20)

Offline

Board footer

Powered by FluxBB