You are not logged in.

#4376 2012-10-13 22:00:30

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

Unia wrote:

Do we know if Legacy will be updated to work with Xorg 1.13?

In a century or two... maybe... smile

Offline

#4377 2012-10-13 22:03:58

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

snack wrote:
Unia wrote:

Do we know if Legacy will be updated to work with Xorg 1.13?

In a century or two... maybe... smile

big_smile By then I'll hopefully have a new laptop with Intel graphics!


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4378 2012-10-13 22:08:21

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

Unia wrote:

Do we know if Legacy will be updated to work with Xorg 1.13?

Only AMD knows it for sure.
AMD said that legacy will be updated when there will be such a need, so it should be. Though it could take some time.

Offline

#4379 2012-10-13 22:08:48

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Let's edit the Wiki then.


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4380 2012-10-13 22:10:24

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

Unia wrote:

Let's edit the Wiki then.

You mean with snack's info about century or two? cool

Offline

#4381 2012-10-13 22:11:07

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
Unia wrote:

Let's edit the Wiki then.

You mean with snack's info about century or two? cool

Sure! Little humor won't hurt big_smile


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4382 2012-10-13 22:12:56

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

Unia wrote:
Vi0L0 wrote:
Unia wrote:

Let's edit the Wiki then.

You mean with snack's info about century or two? cool

Sure! Little humor won't hurt big_smile

Especially when we are writing about catalyst smile


BTW: Ubuntu should be our heroes, they've saved our (amd linux users) asses once again :>

Edit: Thanks Unia!

Last edited by Vi0L0 (2012-10-13 22:21:18)

Offline

#4383 2012-10-13 22:18:06

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Wiki updated. Both the Installing from unofficial repositories and Installing from AUR have a warning now, telling users they should rollback Xorg to 1.12 when using the Legacy driver.


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4384 2012-10-14 01:26:35

ChemBro
Member
Registered: 2008-10-22
Posts: 678

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

BTW: Ubuntu should be our heroes, they've saved our (amd linux users) asses once again :>

Ubuntu and heroes? :3

Offline

#4385 2012-10-14 15:59:16

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: The AMD/ATI Bar & Grill

I wasn't following this for a few weeks, missed the important note about incompatibilities with Xorg 1.13, only to discover that the brightness controls don't work. Rolling back doesn't seem to have fixed it. Erk… what might I be missing?

I've got the HD 7520G and HD 7600M cards on my laptop, and am using Catalyst[-hook] 12.9 from Vi0l0's repositories.

EDIT Downgrading Catalyst to version 12.8 fixed the brightness issue.

Last edited by zoqaeski (2012-10-14 16:30:13)

Offline

#4386 2012-10-14 18:11:30

caerolle
Member
Registered: 2012-09-28
Posts: 19

Re: The AMD/ATI Bar & Grill

OK, no doubt I am doing something really stupid, but I can't get the new catalyst packages from the community-testing. I have the following in my pacman.conf atm (I have all the other repos commented out so I don't get the old packages):


[testing]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[community-testing]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

-Syy seems to go fine, but when try to get (-S) the packages (either catalyst-dkms or catalyst-utils), I get 'error: target not found: <package>'.

I am using the same mirrors I use for core, extra, and community. I did some poking around, didn't find anything that said the testing repos used a special mirror.

What am I spacing on here?

Thanks so much!

caerolle  smile

Offline

#4387 2012-10-14 18:53:29

nob.dir
Member
Registered: 2011-10-08
Posts: 16

Re: The AMD/ATI Bar & Grill

@Unia: is this possible to add in the wiki that people which are using Wine to play or to use 3D application must disable TLS (UseFastTLS in xorg.conf) ? I had to search on the one or two hour to understand why a game froze quite all times... I think it would be nice for wine users ^^

Thanks!

Offline

#4388 2012-10-14 19:08:58

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

^ Sure! The Wiki is a community project though, so you can make an account yourself and add it!

I can do it for you too, what information do I have to add? Please list the steps needed here smile


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4389 2012-10-14 19:15:20

nob.dir
Member
Registered: 2011-10-08
Posts: 16

Re: The AMD/ATI Bar & Grill

Oh okay ^^ I though that it was as on the AUR, a page has its own maintainer.

There are two ways to activate this option:
-Entering the command line (under root) aticonfig --tls=off.
-Adding the line Option "UseFastTLS" "off" in the Device section of xorg.conf.

This need a Xorg restart to get applied.

Offline

#4390 2012-10-14 19:30:09

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

nob.dir wrote:

Oh okay ^^ I though that it was as on the AUR, a page has its own maintainer.

There are two ways to activate this option:
-Entering the command line (under root) aticonfig --tls=off.
-Adding the line Option "UseFastTLS" "off" in the Device section of xorg.conf.

This need a Xorg restart to get applied.

Please review: https://wiki.archlinux.org/index.php/AM … ons_freeze


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4391 2012-10-14 19:48:05

nob.dir
Member
Registered: 2011-10-08
Posts: 16

Re: The AMD/ATI Bar & Grill

Only a little thing: "If you use Wine or a 3D application and it hangs" would be "If you use 3D wine application and it hangs" or something like that wink
Otherwise it's great!

Thank very much again smile

Offline

#4392 2012-10-14 19:56:04

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Fixed! Thanks for notifying us! big_smile


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4393 2012-10-14 21:00:38

goll
Member
From: Croatia
Registered: 2007-10-29
Posts: 50

Re: The AMD/ATI Bar & Grill

Ok so I just updated my system (3.5.6) and I removed catalyst-total (12.8) and installed catalyst-dkms, catalyst-utils, lib32-catalyst-utils (12.9) from community. I also had xorg-server updated to 1.13.0
My fgl_glxgears results are really bad, around 300 FPS vs ~1000 before. The rest of my system seems ok so far, although I still have the very annoying black screen after a couple of seconds with mplayer-vaapi hmm

And also, fglrxinfo now reports OpenGL renderer string: AMD Radeon HD 7400M Series, but I have a 6470M series card in a HP EliteBook 8560p.

Would you recommend a xorg downgrade or a catalyst downgrade or both?

EDIT (15.10.2012.): I just updated to linux 3.6.2-1 and testing fgl_glxgears returns the same results as before this catalyst upgrade, around 1000 FPS so it appears it's working better.

Last edited by goll (2012-10-15 08:10:59)

Offline

#4394 2012-10-14 21:19:42

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

^ I don't know what could be wrong. I just ran glxgears and got

┌─[jente @ lappy ~] 23:18:19 
└─■ fgl_glxgears
Using GLX_SGIX_pbuffer
294 frames in 5.0 seconds = 58.800 FPS
300 frames in 5.0 seconds = 60.000 FPS
297 frames in 5.0 seconds = 59.400 FPS
^C

Fglrxinfo:

┌─[jente @ lappy ~] 23:18:36 
└─■ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5000 Series
OpenGL version string: 4.2.11903 Compatibility Profile Context

That's also with Xorg 1.13 and Catalyst-dkms 12.9. I don't know what could be wrong.


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4395 2012-10-15 01:32:13

Commander
Member
Registered: 2011-02-12
Posts: 37

Re: The AMD/ATI Bar & Grill

nob.dir wrote:

Only a little thing: "If you use Wine or a 3D application and it hangs" would be "If you use 3D wine application and it hangs" or something like that wink
Otherwise it's great!

Thank very much again smile

Is this when 3d applications just stop rendering?

Edit;

Also could anyone check out if the graphic card goes up in the power profiles for you in 12.9 beta?
Mine is stuck all the time in the lowest setting and does not want to go up.

Last edited by Commander (2012-10-15 08:43:33)

Offline

#4396 2012-10-15 09:41:25

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Commander wrote:

Also could anyone check out if the graphic card goes up in the power profiles for you in 12.9 beta?
Mine is stuck all the time in the lowest setting and does not want to go up.

How do we check?


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

#4397 2012-10-15 13:15:12

siavashserver
Member
From: Tehran, Iran
Registered: 2011-02-11
Posts: 73

Re: The AMD/ATI Bar & Grill

Unia wrote:
Commander wrote:

Also could anyone check out if the graphic card goes up in the power profiles for you in 12.9 beta?
Mine is stuck all the time in the lowest setting and does not want to go up.

How do we check?

You can check it using amdoverdrivectrl package in Vi0l0's repositories.

Offline

#4398 2012-10-15 15:21:50

crshbndct
Member
Registered: 2010-08-06
Posts: 11

Re: The AMD/ATI Bar & Grill

Forgive me for my stupidity here, but 12.9 is supposed to support up to and including 3.7 kernel?

I am getting this:

error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst: requires linux<3.6

When I try to upgrade my system.

What is going on here? I have catalyst 12.9 installed

EDIT: It seems I had an old non functioning version installed from the AUR somehow?? I removed that and all is well now.

Last edited by crshbndct (2012-10-15 15:42:49)

Offline

#4399 2012-10-15 15:27:00

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

crshbndct wrote:

Forgive me for my stupidity here, but 12.9 is supposed to support up to and including 3.7 kernel?

I am getting this:

error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst: requires linux<3.6

When I try to upgrade my system.

What is going on here? I have catalyst 12.9 installed

Package dependence does not strictly reflect actual compatibility between packages. Maybe catalyst has been tested with kernels up to 3.5.x, that's why the package maintainer put a dependency on linux<3.6, even if catalyst maybe could work with higher kernels. There are many methods to install catalyst with linux 3.6 (I assume you are on [testing]): you can recompile catalyst from aur or using abs and change the dependency in the PKGBUILD or force the upgrade in pacman. Both these methods could  leave you with an unusable system. Do it only if you know what you are doing and you are willing to face troubles...

Last edited by snack (2012-10-15 15:28:11)

Offline

#4400 2012-10-15 16:15:10

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

I'm using Catalyst-DKMS from [community], which works with kernel 3.6


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Online

Board footer

Powered by FluxBB