You are not logged in.

#1 2012-10-10 13:17:26

Xstary
Member
Registered: 2010-08-05
Posts: 15

Keymap/font not working

Until now my /etc/rc.conf file included

KEYMAP="de-latin1-nodeadkeys"
CONSOLEFONT=
CONSOLEMAP=

Now, while moving most settings from /etc/rc.conf to the new configuration files that should be used,
I deleted these lines and put the following in /etc/vconsole.conf instead:

KEYMAP=de-latin1-nodeadkeys
FONT_MAP=8859-1
FONT=lat1-16

But in consoles, characters like "ä", "ö", "ü", "´", "`", "€" (euro sign) do not work, "?" is shown instead.
With the setting in rc.conf everything worked fine.

I also tried de-latin1-nodeadkeys.map.gz like to be found in de-latin1-nodeadkeys.map.gz or without the FONT lines.

How do I set keymaps/fonts correctly? The wiki pages are not really informative for now or the suggestions do to work.

Last edited by Xstary (2012-10-13 16:27:52)

Offline

#2 2012-10-10 13:23:40

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Keymap/font not working

https://wiki.archlinux.org/index.php/Be … and_keymap

The default (blank) is safe, but some foreign characters may show up as white squares or as other symbols. It's recommended that you change it to Lat2-Terminus16, because according to /usr/share/kbd/consolefonts/README.Lat2-Terminus16, it claims to support "about 110 language sets".


Edit: Don't forget to mark the topic as solved (by editing the first post) so that other people (including yourself sometimes) may find useful.

Last edited by DSpider (2012-10-10 13:25:06)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-10-13 15:26:55

Xstary
Member
Registered: 2010-08-05
Posts: 15

Re: Keymap/font not working

Thanks for the answer.
For clarification: I do not mean the TTY, but consoles under xorg.
I tried Lat2-Terminus16 and it changed the font in TTYs (e.g. at boot),
but didn´t help for X-consoles. I´ll check if the old one (lat2-16) works in TTYs.

So is /etc/vconsole.conf only for TTYs?

For X, I have in .xinitrc:

setxkbmap -layout de nodeadkeys

what worked before...

I´ll try putting some settings back to /etc/rc.conf to check which one it was exactly..

Edit:

  • Putting back settings to /etc/rc.conf did not help

  • Fonts work correctly in Firfox, gvim, libreoffice, pcmanfm or xterm(!) but not in lxterminal, vim or nano

Last edited by Xstary (2012-10-13 15:59:13)

Offline

#4 2012-10-13 15:57:39

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Keymap/font not working

The rc.conf file has been split (it only contains the "DAEMONS" line uncommented now). See the "rc.conf" wiki page for their corresponding files.

Yes, /etc/vconsole.conf is only for the console (or "vt" - virtual terminal - or "tty"). To set a font in whatever terminal you use, either right click and choose Preferences or Settings, or look into how to set up ~/.Xresources:

https://wiki.archlinux.org/index.php/Xresources


Post the output of:

$ locale -a
$ locale

"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#5 2012-10-13 16:23:43

Xstary
Member
Registered: 2010-08-05
Posts: 15

Re: Keymap/font not working

$ locale -a
C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
deutsch
en_US
en_US.iso88591
en_US.utf8
german
POSIX
$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=de_DE.UTF-8

The strange thing is that I didn´t change anything else than moving stuff from rc.conf to the new files, so why would I have to adapt settings of my terminal (lxterminal)?

What I indeed did was running

$ locale-gen

after my last update, because it suggested so.

Edit: In my .bashrc I have

export LANG="de_DE.UTF-8"
export LC_ALL="de_DE.UTF-8"

but I didn´t change it for a long time...

Last edited by Xstary (2012-10-13 16:27:15)

Offline

#6 2012-10-13 16:51:55

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Keymap/font not working

Who told you to use LC_ALL ?

https://wiki.archlinux.org/index.php/Be … ide#Locale

Warning: Using the LC_ALL variable is strongly discouraged because it overrides everything.


Even Debian recommends against it: http://wiki.debian.org/Locale

Last edited by DSpider (2012-10-13 16:53:05)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#7 2012-10-13 17:51:50

Xstary
Member
Registered: 2010-08-05
Posts: 15

Re: Keymap/font not working

I copied my first .bashrc from someone, that´s where it must come from.

I removed LC_ALL from .bashrc but it didn´t help (did restart).
Very strange: while doing this, without restarting, and while testing around I somehow got one of these non-working characters to the terminal... but I cannot reproduce it...

So now:

LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

Edit: I also noticed that in one program the date format changed to MM/DD/YYYY, I had DD.MM.YYYY before. In the programs date settings the option "Locale" is used. So it seems that the current locale isn´t set correctly though "$ locale" shows "de_DE.UTF-8". Instead it´s probably some standard locale / US.

Maybe "de_DE.UTF-8" is no longer correct?

Last edited by Xstary (2012-10-13 18:01:01)

Offline

#8 2012-10-13 18:51:29

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,273

Re: Keymap/font not working

I have these locale settings:

$ locale
LANG=de_DE.utf8
LC_CTYPE="de_DE.utf8"
LC_NUMERIC="de_DE.utf8"
LC_TIME="de_DE.utf8"
LC_COLLATE="de_DE.utf8"
LC_MONETARY="de_DE.utf8"
LC_MESSAGES="de_DE.utf8"
LC_PAPER="de_DE.utf8"
LC_NAME="de_DE.utf8"
LC_ADDRESS="de_DE.utf8"
LC_TELEPHONE="de_DE.utf8"
LC_MEASUREMENT="de_DE.utf8"
LC_IDENTIFICATION="de_DE.utf8"
LC_ALL=

To know or not to know ...
... the questions remain forever.

Offline

#9 2012-10-14 17:41:08

Xstary
Member
Registered: 2010-08-05
Posts: 15

Re: Keymap/font not working

Interesting, changing

LANG=de_DE.UTF-8

to

LANG=de_DE.utf8

worked... Did that change...?
Are the locale settings in .bashrc for more then the terminals?

Offline

#10 2012-10-14 19:18:50

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Keymap/font not working

You don't need to export anything. Setting "LANG=de_DE.UTF-8" in "/etc/locale.conf" is enough.


Edit: Well, only if you want your system in German instead of English. "en_US.UTF-8" should cover those characters just fine (provided that the font you're using actually contains those glyphs).

Last edited by DSpider (2012-10-14 19:22:41)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#11 2012-10-15 09:50:18

Xstary
Member
Registered: 2010-08-05
Posts: 15

Re: Keymap/font not working

Now very strange: Logging in again without having changed anything and the characters do not work again!

In /etc/locale.conf I had

LOCALE="de_DE.utf8"

Offline

#12 2012-10-15 13:47:39

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Keymap/font not working

Like I said, "LANG=en_US.UTF-8" in "/etc/locale.conf" is enough, provided that the font that you're using actually contains those glyphs.


Also, make sure there isn't anything else in /etc/rc.conf, except for the DAEMONS line. This is what you get now when installing Arch.

Last edited by DSpider (2012-10-15 13:50:37)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#13 2012-10-15 13:57:04

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,765

Re: Keymap/font not working

Sidenote: 8859-1 does not have €, 8859-15 does. But both suck, just use pure utf8

Last edited by Mr.Elendig (2012-10-15 13:57:38)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#14 2012-10-21 17:40:33

Xstary
Member
Registered: 2010-08-05
Posts: 15

Re: Keymap/font not working

Ok, my configs now look like

#/etc/vconsole.conf
KEYMAP=de-latin1-nodeadkeys
#/etc/locale.conf
LANG=de_DE.UTF-8

No more setting in .bashrc about this.

$ locale -a
C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
deutsch
en_US
en_US.iso88591
en_US.utf8
german
POSIX
$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

In normal programs and in terminals everything seems to work now.
So thanks everyone!

In virtual consoles for example "€" still does not work, "ä", "ö", "ü" do.
This isn´t very important to me, but the solution would be interesting anyway.

Offline

#15 2012-10-21 18:01:26

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,765

Re: Keymap/font not working

As I said, 8859-1 aka latin1 does not have euro sign at all.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#16 2012-10-29 17:04:40

Xstary
Member
Registered: 2010-08-05
Posts: 15

Re: Keymap/font not working

So how would you set it? Add the FONT_MAP option in /etc/vconsole.conf ?

Offline

Board footer

Powered by FluxBB