You are not logged in.

#26 2012-10-14 17:58:44

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 370
Website

Re: ctrl and fn keyboard shortcuts don't work after update

Gnome 3.6 is not even in [testing], so waiting will require pretty much patience.

Offline

#27 2012-10-14 19:02:34

vrg
Member
Registered: 2012-06-18
Posts: 34

Re: ctrl and fn keyboard shortcuts don't work after update

abstracity wrote:
vrg wrote:

Same issue with my Toshiba Qosmio X505 laptop. I tried to downgrade xf86-input-evdev (2.7.3-2 -> 2.7.3-1) and xf86-input-synaptics (1.6.2-2 -> 1.6.2-1) and I lost both mouse and keyboard support, which is not a nice feeling. Luckily I was able to reinstall the newer packages and revert to the previous state. Maybe I should also downgrade xorg-server and xorg-server-common, but I don't want to mess up my system. I don't like this "solution." This is clearly not solved.

Also, is any of the bug reports being taken seriously?

That's because the older versions of the evdev and synaptics drivers were built for the older version of xorg; you must downgrade xorg-server and xorg-server-common if you downgrade those. This is only needed (if no one else finds a workaround) until Gnome 3.6 hits either [extra] or [testing].

Thanks. That makes sense. However, I think I will choose not to downgrade. I can still get around with a fairly large amount of clicks. Also, I'm not even sure that Gnome 3.6 will fix this, or that this is a Gnome bug at all. Somebody mentioned having problems with Xfce too.

Offline

#28 2012-10-14 20:44:07

abstracity
Member
From: Houston, USA
Registered: 2007-08-08
Posts: 83

Re: ctrl and fn keyboard shortcuts don't work after update

vrg wrote:
abstracity wrote:
vrg wrote:

Same issue with my Toshiba Qosmio X505 laptop. I tried to downgrade xf86-input-evdev (2.7.3-2 -> 2.7.3-1) and xf86-input-synaptics (1.6.2-2 -> 1.6.2-1) and I lost both mouse and keyboard support, which is not a nice feeling. Luckily I was able to reinstall the newer packages and revert to the previous state. Maybe I should also downgrade xorg-server and xorg-server-common, but I don't want to mess up my system. I don't like this "solution." This is clearly not solved.

Also, is any of the bug reports being taken seriously?

That's because the older versions of the evdev and synaptics drivers were built for the older version of xorg; you must downgrade xorg-server and xorg-server-common if you downgrade those. This is only needed (if no one else finds a workaround) until Gnome 3.6 hits either [extra] or [testing].

Thanks. That makes sense. However, I think I will choose not to downgrade. I can still get around with a fairly large amount of clicks. Also, I'm not even sure that Gnome 3.6 will fix this, or that this is a Gnome bug at all. Somebody mentioned having problems with Xfce too.

Gnome 3.6 fixes this because it works with the updated xorg. XFCE might not work if an updated version hasn't been released yet.


Without error there can be no brilliancy. ― Emanuel Lasker

Offline

#29 2012-10-15 01:58:49

vrg
Member
Registered: 2012-06-18
Posts: 34

Re: ctrl and fn keyboard shortcuts don't work after update

abstracity wrote:
vrg wrote:
abstracity wrote:

That's because the older versions of the evdev and synaptics drivers were built for the older version of xorg; you must downgrade xorg-server and xorg-server-common if you downgrade those. This is only needed (if no one else finds a workaround) until Gnome 3.6 hits either [extra] or [testing].

Thanks. That makes sense. However, I think I will choose not to downgrade. I can still get around with a fairly large amount of clicks. Also, I'm not even sure that Gnome 3.6 will fix this, or that this is a Gnome bug at all. Somebody mentioned having problems with Xfce too.

Gnome 3.6 fixes this because it works with the updated xorg. XFCE might not work if an updated version hasn't been released yet.

Ok, fair enough. Thanks smile

Offline

#30 2012-10-15 02:36:35

AncientPC
Member
Registered: 2012-02-11
Posts: 52

Re: ctrl and fn keyboard shortcuts don't work after update

jorgeramirez wrote:
abstracity wrote:

Downgrading the following packages solved it for me:

xf86-input-evdev (2.7.3-2 -> 2.7.3-1)
xf86-video-intel (2.20.9-2 -> 2.20.9-1)
xorg-server-common (1.13.0-2 -> 1.12.4-1)
xorg-server (1.13.0-2 -> 1.12.4-1)

I also needed to downgrade xf86-input-synaptics (1.6.2-2 -> 1.6.2-1), then it worked. Thanks!

Thanks for the information. FYI, I did not need to downgrade xf86-input-synaptics to get my media keys working for my Thinkpad X220.

Does anybody know how to pin packages to prevent them from upgrading?

Last edited by AncientPC (2012-10-15 02:39:24)

Offline

#31 2012-10-15 03:03:32

hermes
Member
From: Lucca, Italy
Registered: 2010-05-19
Posts: 99

Re: ctrl and fn keyboard shortcuts don't work after update

abstracity wrote:

Does anybody know how to pin packages to prevent them from upgrading?

Put them under IgnorePkg in your /etc/pacman.conf. See https://wiki.archlinux.org/index.php/Pa … g_upgraded


Linux Registered User #362737

Offline

#32 2012-10-15 07:49:31

Heinrichmeyer
Member
Registered: 2012-05-16
Posts: 18

Re: ctrl and fn keyboard shortcuts don't work after update

hoschi wrote:

Gnome 3.6 is not even in [testing], so waiting will require pretty much patience.

maybe it would help to recompile xfce/gnome window managers with newest xorg development files?

Offline

#33 2012-10-15 09:43:29

fredbezies
Member
Registered: 2011-07-28
Posts: 303

Re: ctrl and fn keyboard shortcuts don't work after update

Heinrichmeyer wrote:
hoschi wrote:

Gnome 3.6 is not even in [testing], so waiting will require pretty much patience.

maybe it would help to recompile xfce/gnome window managers with newest xorg development files?

Well... Gnome 3.6 will be in testing soon, I think. So why rebuilding a soon to be obsolete group, at least for gnome ?

Offline

#34 2012-10-15 11:41:00

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 370
Website

Re: ctrl and fn keyboard shortcuts don't work after update

If a simple recompile will fix this (source?), we should immediately do that.

@fredbezies:
If Gnome 3.6 will move "soon" to [testing], we will see Gnome 3.6 in [stable] (and our problem is in [stable]) in maybe one month? It is not a valid strategy to gain a constant and stable environment, through waiting for next major upgrade for package "foo". Especially Gnome...

Last edited by hoschi (2012-10-15 11:42:44)

Offline

#35 2012-10-15 16:10:48

Syrius00
Member
From: Perugia, Italy
Registered: 2012-10-01
Posts: 16

Re: ctrl and fn keyboard shortcuts don't work after update

I agree. Besides it is possible that other packages we'll update in the near future may misbehave with the packages downgraded to solve this issue.

Last edited by Syrius00 (2012-10-15 16:13:17)

Offline

#36 2012-10-15 18:29:23

zdevex
Member
Registered: 2012-08-17
Posts: 24

Re: ctrl and fn keyboard shortcuts don't work after update

This seems to be an upstream bug.  I have created a bug report with gnome upstream.  If this is affecting you as well, please post to the upstream bug report that you are effected, along with any additional info you may have about the bug so we this can hopefully be resolved as soon as possible.

https://bugzilla.gnome.org/show_bug.cgi?id=686102

-D

Last edited by zdevex (2012-10-15 18:29:46)

Offline

#37 2012-10-15 19:04:55

pedromj
Member
Registered: 2010-10-27
Posts: 51

Re: ctrl and fn keyboard shortcuts don't work after update

Has anyone tried to rebuild gnome-settings-daemon against the new Xorg 1.13.0?


Entia non sunt multiplicanda praeter necessitatem

Offline

#38 2012-10-16 00:49:26

scan
Member
Registered: 2012-10-15
Posts: 1

Re: ctrl and fn keyboard shortcuts don't work after update

Downgrade:
xf86-input-acecad: (1.5.0-3 => 1.5.0-5)
xf86-input-aiptek: (1.4.1-3 => 1.4.1-5)
xf86-input-evdev: (2.7.3-1 => 2.7.3-2)
xf86-input-joystick: (1.6.1-1 => 1.6.1-2)
xf86-input-keyboard: (1.6.2-1 => 1.6.2-2)
xf86-input-mouse: (1.8.1-1 => 1.8.1-2)
xf86-input-synaptics: (1.6.2-1 => 1.6.2-2)
xf86-input-vmmouse: (12.9.0-1 => 12.9.0-2)
xf86-input-void: (1.4.0-3 => 1.4.0-4)
xf86-video-apm: (1.2.5-1 => 1.2.5-2)
xf86-video-ark: (0.7.5-1 => 0.7.5-2)
xf86-video-ast: (0.97.0-1 => 0.97.0-2)
xf86-video-ati: (1:6.14.6-1 => 1:6.14.6-2)
xf86-video-chips: (1.2.5-1 => 1.2.5-2)
xf86-video-cirrus: (1.5.1-1 => 1.5.1-2)
xf86-video-dummy: (0.3.6-1 => 0.3.6-2)
xf86-video-fbdev: (0.4.3-1 => 0.4.3-2)
xf86-video-glint: (1.2.8-1 => 1.2.8-2)
xf86-video-i128: (1.3.6-1 => 1.3.6-2)
xf86-video-i740: (1.3.4-1 => 1.3.4-2)
xf86-video-intel: (2.20.9-1 => 2.20.9-2)
xf86-video-mach64: (6.9.3-1 => 6.9.3-2)
xf86-video-mga: (1.6.2-1 => 1.6.2-2)
xf86-video-neomagic: (1.2.7-1 => 1.2.7-2)
xf86-video-r128: (6.9.1-1 => 6.9.1-2)
xf86-video-rendition: (4.2.5-1 => 4.2.5-2)
xf86-video-s3: (0.6.5-1 => 0.6.5-2)
xf86-video-s3virge: (1.10.6-1 => 1.10.6-2)
xf86-video-savage: (2.3.6-1 => 2.3.6-2)
xf86-video-siliconmotion: (1.7.7-1 => 1.7.7-2)
xf86-video-sis: (0.10.7-1 => 0.10.7-2)
xf86-video-sisusb: (0.9.6-1 => 0.9.6-2)
xf86-video-tdfx: (1.4.5-1 => 1.4.5-2)
xf86-video-trident: (1.3.6-1 => 1.3.6-2)
xf86-video-tseng: (1.2.5-1 => 1.2.5-2)
xf86-video-v4l: (0.2.0-10 => 0.2.0-11)
xf86-video-vesa: (2.3.2-1 => 2.3.2-2)
xf86-video-vmware: (12.0.2-1 => 12.0.2-2)
xf86-video-voodoo: (1.2.5-1 => 1.2.5-2)
xorg-server: (1.12.4-1 => 1.13.0-2)
xorg-server-common: (1.12.4-1 => 1.13.0-2)

Files: x86_64 ONLY !!!
http://db.tt/YQ5WA6I8

Offline

#39 2012-10-16 06:49:42

flaresun
Member
Registered: 2012-10-16
Posts: 1

Re: ctrl and fn keyboard shortcuts don't work after update

For ATI cards also
xf86-video-ati (1:6.14.6-2 -> 1:6.14.6-1)
xf86-video-vesa (2.3.2-2 -> 2.3.2-1)

jorgeramirez wrote:
abstracity wrote:

Downgrading the following packages solved it for me:

xf86-input-evdev (2.7.3-2 -> 2.7.3-1)
xf86-video-intel (2.20.9-2 -> 2.20.9-1)
xorg-server-common (1.13.0-2 -> 1.12.4-1)
xorg-server (1.13.0-2 -> 1.12.4-1)

I also needed to downgrade xf86-input-synaptics (1.6.2-2 -> 1.6.2-1), then it worked. Thanks!

It works for me

Offline

#40 2012-10-16 06:51:52

Heinrichmeyer
Member
Registered: 2012-05-16
Posts: 18

Re: ctrl and fn keyboard shortcuts don't work after update

pedromj wrote:

Has anyone tried to rebuild gnome-settings-daemon against the new Xorg 1.13.0?

I tried yesterday compiling from source, but it failed at the point of cups integration for "print screen". At least one necessary cups struct is now opaque. It was to late in the night to further investigate in this for me.

Offline

#41 2012-10-16 06:54:56

Butcher
Member
Registered: 2009-02-04
Posts: 158

Re: ctrl and fn keyboard shortcuts don't work after update

Btw, in gnome-tweak-tool there are two options, 'laptop lid close action on battery/ac', which I have set as 'blank' (this is, nothing should happen when I close the lid), but the laptop suspends anyway. Is it the same bug? Can it be solved by downgrading?

Offline

#42 2012-10-16 07:04:32

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 816

Re: ctrl and fn keyboard shortcuts don't work after update

@butcher: It depends on systemd-logind feature. Give a look at /etc/systemd/logind.conf to change the suspend behaviour.

Offline

#43 2012-10-16 07:46:38

Butcher
Member
Registered: 2009-02-04
Posts: 158

Re: ctrl and fn keyboard shortcuts don't work after update

nierro wrote:

@butcher: It depends on systemd-logind feature. Give a look at /etc/systemd/logind.conf to change the suspend behaviour.

tru dat

Offline

#44 2012-10-16 09:24:35

akira86
Member
Registered: 2009-01-16
Posts: 118

Re: ctrl and fn keyboard shortcuts don't work after update

Heinrichmeyer wrote:
pedromj wrote:

Has anyone tried to rebuild gnome-settings-daemon against the new Xorg 1.13.0?

I tried yesterday compiling from source, but it failed at the point of cups integration for "print screen". At least one necessary cups struct is now opaque. It was to late in the night to further investigate in this for me.

You have to apply this patch (on the gnome-settings-daemon source) to build gnome-settings-daemon.
But it doesn't solve the shortcuts problem for me…

Offline

#45 2012-10-16 13:53:15

n125
Member
Registered: 2011-12-30
Posts: 38

Re: ctrl and fn keyboard shortcuts don't work after update

Oddly, the only key combination that I found to not work after this round of updates is Fn + F7. Neither xbindkeys -k nor xev seem to be able to register it. The twist is that I'm not using Gnome; I'm either using i3 or Openbox. It makes me wonder if my issue is even related...

Offline

#46 2012-10-16 14:28:10

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 816

Re: ctrl and fn keyboard shortcuts don't work after update

Using xfce here and the only combination not working is the backlight one: fn+f5/6.

Offline

#47 2012-10-17 07:04:25

snufkin
Member
From: Sweden
Registered: 2008-11-08
Posts: 71

Re: ctrl and fn keyboard shortcuts don't work after update

nierro wrote:

Using xfce here and the only combination not working is the backlight one: fn+f5/6.

Edit: Nevermind. Totally misread your post.

Last edited by snufkin (2012-10-17 07:05:29)

Offline

#48 2012-10-17 09:07:43

Heinrichmeyer
Member
Registered: 2012-05-16
Posts: 18

Re: ctrl and fn keyboard shortcuts don't work after update

i included gnome-settings-daemon --debug in my gnome-session (with gnome-session-properties). Now i get debug messages in .xsession-errors:

(gnome-settings-daemon:11792): wacom-plugin-DEBUG: No Xinput2 support, disabling plugin
(gnome-settings-daemon:11792): media-keys-plugin-DEBUG: No Xinput2 support, disabling plugin

anyone struggling with wacom support?

Last edited by Heinrichmeyer (2012-10-17 10:36:50)

Offline

#49 2012-10-17 14:00:02

pedromj
Member
Registered: 2010-10-27
Posts: 51

Re: ctrl and fn keyboard shortcuts don't work after update

From the bugzilla report:

This sounds very much like an X server bug, which is why it broke after
upgrade. Maybe the Arch people accidentally compiled it without XInput2
support?

Has anyone investigated this possibility?


Entia non sunt multiplicanda praeter necessitatem

Offline

#50 2012-10-17 22:46:39

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: ctrl and fn keyboard shortcuts don't work after update

pedromj wrote:

From the bugzilla report:

This sounds very much like an X server bug, which is why it broke after
upgrade. Maybe the Arch people accidentally compiled it without XInput2
support?

Has anyone investigated this possibility?

Seems unlikely to me. I don't even see a way to NOT compile Xi2 on new xorg servers, and also:

$ xinput --version
xinput version 1.6.0
XI version on server: 2.2

and

$ xinput test-xi2 2

gives a good deal of output.

Offline

Board footer

Powered by FluxBB