You are not logged in.

#26 2012-10-14 16:08:39

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 377

Re: Security - XScreenSaver with XFCE

WonderWoofy wrote:

@Radioactiveman, unfortunately, it seems as though the OP is kind of weeding through the suggestions, trying a couple here and there, then saying the untried are not optimal.

My solution works exactly as he wants, I have just checked it again.
If he is not willing to try my suggestion, it is his own problem.

Offline

#27 2012-10-14 17:23:27

LiranV
Member
Registered: 2012-02-27
Posts: 56

Re: Security - XScreenSaver with XFCE

I've installed Slim, configured my system to boot with systemd instead of init.
Now on boot I get slim, enter my username and password, login, but still "Shut Down", "Suspend" etc. is greyed out.
Why does this happen?

Offline

#28 2012-10-14 19:22:15

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Security - XScreenSaver with XFCE

What about it didn't work?  Would it not background?  Would it not disown?  Would it not log out? 

Also, did you try screen or tmux?  That seems to be a pretty viable option as well, and I must say that tmux is pretty great (though I know that screen has quite a few followers as well)

Offline

#29 2012-10-14 19:32:39

LiranV
Member
Registered: 2012-02-27
Posts: 56

Re: Security - XScreenSaver with XFCE

I've settled with Slim, I'ts pretty lightwight and fast.
But again I need to figure out why some options are greyed out.

Offline

#30 2012-10-14 19:36:29

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Security - XScreenSaver with XFCE

Radioactiveman wrote:

My solution works exactly as he wants, I have just checked it again.
If he is not willing to try my suggestion, it is his own problem.

It is unfortunate that so many stepped forward to help...

OP, it sounds like you are not starting consolekit/dbus correctly.  That is a whole other issue though.

Offline

#31 2012-10-14 20:40:27

Lennie
Member
From: Sweden
Registered: 2011-10-12
Posts: 146

Re: Security - XScreenSaver with XFCE

You can use sudo with no password for shutdown and reboot. Add this with visudo:

username hostname= NOPASSWD: /sbin/shutdown, /sbin/reboot

Offline

#32 2012-10-15 07:01:06

Lennie
Member
From: Sweden
Registered: 2011-10-12
Posts: 146

Re: Security - XScreenSaver with XFCE

I just removed Cdm and now start X automatic at login with a script.

My .bash_profile:

[[ -f ~/.bashrc ]] && . ~/.bashrc

if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]]; then
    exec $HOME/.scripts/xstart.sh
fi

xstart.sh:

#!/bin/bash
[[ $(fgconsole 2>/dev/null) == 1 ]] && exec startx -- vt1

xstart.sh needs to be executable.

Offline

#33 2012-10-15 14:16:22

LiranV
Member
Registered: 2012-02-27
Posts: 56

Re: Security - XScreenSaver with XFCE

WonderWoofy, Radioactiveman:
Please don't get me wrong, I know your soulutions are OK but I've decided to go with slim as DM.
Thank you very much for the help and I'm sure I'll need to use you solutions someday or another.

Lennie, Thanks for the solutions too.

But now as I said I've configured the system to work with systemd and load slim.service at startup.
Everything seems to work fine except the greyed out power (Shutdown etc.) menu entery.

Offline

#34 2012-10-15 22:51:31

root
Member
From: 127.0.0.1
Registered: 2012-04-13
Posts: 297

Re: Security - XScreenSaver with XFCE

@LiranV

If you are using SLiM note that it is ConsoleKit capable since version 1.3.3. Therefore if you are starting your DM session with ck-launch-session you have to remove that part.


\(o_X)/
                        'Cause I wanna be an Archy - An Archy in the UK // Sex Pistols

Offline

#35 2012-10-16 18:15:28

LiranV
Member
Registered: 2012-02-27
Posts: 56

Re: Security - XScreenSaver with XFCE

root wrote:

@LiranV

If you are using SLiM note that it is ConsoleKit capable since version 1.3.3. Therefore if you are starting your DM session with ck-launch-session you have to remove that part.

I run it with slim.service file using "systemctl enable slim.service" how could I check if its launched with "ck-launch-session"? And how can I change it?

Offline

#36 2012-10-16 19:27:38

root
Member
From: 127.0.0.1
Registered: 2012-04-13
Posts: 297

Re: Security - XScreenSaver with XFCE

LiranV wrote:

I run it with slim.service file using "systemctl enable slim.service" how could I check if its launched with "ck-launch-session"? And how can I change it?

It is not Slim I refer to when referring to being launched with ck-launch-session but your DM, in this case, XFCE. SLiM reads the .xinitrc file in your home folder. Therefore take a peek there and, most likely, you will have a line there similar to this,

exec ck-launch-session startxfce4

As said, remove the ck-lauch-session part and you should be fine and with no options greyed out.


\(o_X)/
                        'Cause I wanna be an Archy - An Archy in the UK // Sex Pistols

Offline

#37 2012-10-16 21:16:43

LiranV
Member
Registered: 2012-02-27
Posts: 56

Re: Security - XScreenSaver with XFCE

It works!!
Thank you soo much!
Can you please explain way this happend?
what consolekit is doing?

BTW I've tried startx after changing the .xinitrc file and it still doesn't work that way. (Works only with slim)

Offline

#38 2012-10-17 19:41:35

root
Member
From: 127.0.0.1
Registered: 2012-04-13
Posts: 297

Re: Security - XScreenSaver with XFCE

You can check the wiki for info on consolekit.

As for why it doesn't work with startx you have to bear in mind that there isn't anything handling the ConsoleKit whereas when using SLiM there is, SLiM itself.
If you are interested in having ConsoleKit support working for both startx and your login manager you may want to use a login manager that isn't ConsoleKit capable and thus you can keep the ck-launch-session variable in your .xinitrc file.


\(o_X)/
                        'Cause I wanna be an Archy - An Archy in the UK // Sex Pistols

Offline

Board footer

Powered by FluxBB