You are not logged in.

#4401 2012-10-15 17:58:13

Terseus
Member
Registered: 2007-04-26
Posts: 9

Re: The AMD/ATI Bar & Grill

I also had this problem with the catalyst package of the Vi0l0's repository catalyst-hd234k.

error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst: requires linux<3.6

Solved it by installing catalyst-hook, which doesn't depend on a particular linux version.

I suppose the problem is that the catalyst package it's just a precompiled module for a range of kernel versions while the catalyst-hook compiles a new module for every kernel, isn't it?

Offline

#4402 2012-10-15 18:01:36

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

Unia wrote:

I'm using Catalyst-DKMS from [community], which works with kernel 3.6

There's no reson for it to not to work - same as for -generator, -hook or -daemon.
Simple catalyst package brings just a module precompiled for specific kernel and so such dependency is safe and is imho a "must have" :>

Soon i will update repos with catalyst precompiled on kernel 3.6.2

@Terseus: smile indeed

Last edited by Vi0L0 (2012-10-15 18:02:27)

Offline

#4403 2012-10-15 18:17:07

Commander
Member
Registered: 2011-02-12
Posts: 36

Re: The AMD/ATI Bar & Grill

Unia wrote:
Commander wrote:

Also could anyone check out if the graphic card goes up in the power profiles for you in 12.9 beta?
Mine is stuck all the time in the lowest setting and does not want to go up.

How do we check?

You can use the AMDOverdriveCTRL to see what profile is running, but you can also use aticonfig --od-getclocks with watch or or spam it in terminal to see if the clocks go to the peak value or not.

Offline

#4404 2012-10-15 18:28:30

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

Commander wrote:
Unia wrote:
Commander wrote:

Also could anyone check out if the graphic card goes up in the power profiles for you in 12.9 beta?
Mine is stuck all the time in the lowest setting and does not want to go up.

How do we check?

You can use the AMDOverdriveCTRL to see what profile is running, but you can also use aticonfig --od-getclocks with watch or or spam it in terminal to see if the clocks go to the peak value or not.

umm... here's some simple spammer ;P :

#!/bin/bash
while true;
 do
   echo "----------------------------------"
   date +"%T"
   aticonfig --od-getclocks
   aticonfig --pplib-cmd "get fanspeed 0"
   aticonfig --od-gettemperature
   echo
  sleep  2
done

Offline

#4405 2012-10-15 18:39:34

okubax
Member
From: London
Registered: 2010-04-24
Posts: 181
Website

Re: The AMD/ATI Bar & Grill

Unia wrote:

^ I don't know what could be wrong. I just ran glxgears and got

┌─[jente @ lappy ~] 23:18:19 
└─■ fgl_glxgears
Using GLX_SGIX_pbuffer
294 frames in 5.0 seconds = 58.800 FPS
300 frames in 5.0 seconds = 60.000 FPS
297 frames in 5.0 seconds = 59.400 FPS
^C

Fglrxinfo:

┌─[jente @ lappy ~] 23:18:36 
└─■ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5000 Series
OpenGL version string: 4.2.11903 Compatibility Profile Context

That's also with Xorg 1.13 and Catalyst-dkms 12.9. I don't know what could be wrong.

Same here, I'm getting ~=60FPS in glxgears

Offline

#4406 2012-10-15 18:54:06

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

^ @okubax:
it's because you've got v-sync turned on (eventually + Tear-Free Desktop)


Commander wrote:

Also could anyone check out if the graphic card goes up in the power profiles for you in 12.9 beta?
Mine is stuck all the time in the lowest setting and does not want to go up.

working fine here (clocking up to max), tested on warsow

Offline

#4407 2012-10-15 21:55:22

Commander
Member
Registered: 2011-02-12
Posts: 36

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

^ @okubax:
it's because you've got v-sync turned on (eventually + Tear-Free Desktop)


Commander wrote:

Also could anyone check out if the graphic card goes up in the power profiles for you in 12.9 beta?
Mine is stuck all the time in the lowest setting and does not want to go up.

working fine here (clocking up to max), tested on warsow


weird my is stuck on low all the time, no idea what to do. Will probably try to remove everything and install again from aur.

Also
Simple clock/temp monitor smile

#!/bin/bash
watch -n 1 -t -c "aticonfig --od-getclock && aticonfig --od-gettemperature && aticonfig --pplib-cmd 'get fanspeed 0' && sensors | grep temp"

Offline

#4408 2012-10-16 01:05:26

caerolle
Member
Registered: 2012-09-28
Posts: 19

Re: The AMD/ATI Bar & Grill

I imagine this is something I should be able to figure out on my own, but am not having much success. When I try to install catalyst-dkms or catalyst-utils, I get:

:: catalyst-utils and libgl are in conflict. Remove libgl? [y/N]

The Wiki says:

Note: If pacman asks you about removing libgl - you may safely say "Y"

But when I answer 'y', I get:

error: failed to prepare transaction (could not satisfy dependencies)
:: ati-dri: requires libgl=9.0

Suggestions?

Thanks!

caerolle  smile

Offline

#4409 2012-10-16 01:05:57

afzalarsalan
Member
Registered: 2011-06-12
Posts: 5

Re: The AMD/ATI Bar & Grill

Okay second kernel upgrade and it still didn't automatically update the catalyst driver. I don't know what I'm doing wrong as I followed the steps to enable dkms at boot and it does report back active when I issue "systemctl status dkms". Can anyone help me out here? I had to manually reinstall the package "catalyst-dkms" in order to get the desktop to load.

Offline

#4410 2012-10-16 05:41:05

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 197

Re: The AMD/ATI Bar & Grill

caerolle wrote:

I imagine this is something I should be able to figure out on my own, but am not having much success. When I try to install catalyst-dkms or catalyst-utils, I get:

:: catalyst-utils and libgl are in conflict. Remove libgl? [y/N]

The Wiki says:

Note: If pacman asks you about removing libgl - you may safely say "Y"

But when I answer 'y', I get:

error: failed to prepare transaction (could not satisfy dependencies)
:: ati-dri: requires libgl=9.0

Suggestions?

Thanks!

caerolle  smile

pacman -Rdd ati-dri && pacman -Syu catalyst-dkms

should work

Offline

#4411 2012-10-16 05:44:01

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 197

Re: The AMD/ATI Bar & Grill

afzalarsalan wrote:

Okay second kernel upgrade and it still didn't automatically update the catalyst driver. I don't know what I'm doing wrong as I followed the steps to enable dkms at boot and it does report back active when I issue "systemctl status dkms". Can anyone help me out here? I had to manually reinstall the package "catalyst-dkms" in order to get the desktop to load.


dkms rebuild the module on the package (catalyst-dkms) upgrade/install, when you reboot the computer; perhaps you will have to reboot it twice; the first time it rebuild it, the second time the system can use it (it's a dkms.service file limitation)

Last edited by lordheavy (2012-10-16 05:44:38)

Offline

#4412 2012-10-16 07:40:42

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

lordheavy wrote:
afzalarsalan wrote:

Okay second kernel upgrade and it still didn't automatically update the catalyst driver. I don't know what I'm doing wrong as I followed the steps to enable dkms at boot and it does report back active when I issue "systemctl status dkms". Can anyone help me out here? I had to manually reinstall the package "catalyst-dkms" in order to get the desktop to load.


dkms rebuild the module on the package (catalyst-dkms) upgrade/install, when you reboot the computer; perhaps you will have to reboot it twice; the first time it rebuild it, the second time the system can use it (it's a dkms.service file limitation)

In other words: "dkms is able to build module automatically only for currently booted kernel". Am I correct?
If so systemd users will probably always* have to reboot twice, it's hard to me to imagine that fglrx module will be build before X start, especially in systemd river stream.
(* by always i mean when kernel update breaks module's compatibility, so always when 3.x -> 3.x+1, and sometimes when 3.x.z -> 3.x.z+1)

Now manually:
Let's say we booted kernel 3.5, and with pacman we've installed 3.6...
Does "dkms rebuild the module on the package (catalyst-dkms) upgrade/install" mean that it will build module for 3.6 kernel so user don't have to reboot twice?

Last edited by Vi0L0 (2012-10-16 07:49:55)

Offline

#4413 2012-10-16 10:44:22

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,471
Website

Re: The AMD/ATI Bar & Grill

I too had to manually reinstall Catalyst-DKMS again before it would rebuild my driver. With the next update I will try to reboot twice, to see if that indeed works.

Out of interest, what's the limitation in the .service file?


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#4414 2012-10-16 10:57:16

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 197

Re: The AMD/ATI Bar & Grill

Unia wrote:

I too had to manually reinstall Catalyst-DKMS again before it would rebuild my driver. With the next update I will try to reboot twice, to see if that indeed works.

Out of interest, what's the limitation in the .service file?

I guess one of the limitation of the current service file is that the graphical.target doesn't wait for the dkms to finish before starting (systemd is parallelised), perhaps adding a "Before=graphical.target" rule in the dkms.service file should be enough, but not yet tested.

Last edited by lordheavy (2012-10-16 10:58:10)

Offline

#4415 2012-10-16 11:36:15

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 197

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

In other words: "dkms is able to build module automatically only for currently booted kernel". Am I correct?
If so systemd users will probably always* have to reboot twice, it's hard to me to imagine that fglrx module will be build before X start, especially in systemd river stream.
(* by always i mean when kernel update breaks module's compatibility, so always when 3.x -> 3.x+1, and sometimes when 3.x.z -> 3.x.z+1)

Correct.

Module is rebuilt on reboot when the kernel version is changed. If not, you have to rebuild it manually with something like:
dkms build fglrx/12.9-1 (if you want to rebuild it with the current kernel)
dkms build fglrx/12.9-1 -k 3.6.1-1-ARCH (if the kernel you want to rebuild it is 3.6.1-1-ARCH) (tips: uname -r)

Vi0L0 wrote:

Now manually:
Let's say we booted kernel 3.5, and with pacman we've installed 3.6...
Does "dkms rebuild the module on the package (catalyst-dkms) upgrade/install" mean that it will build module for 3.6 kernel so user don't have to reboot twice?

No, it will be built for the current kernel, not the one that will be installed, if you want it to be installed for the upgraded kernel, you have to reboot or build it manually.

Offline

#4416 2012-10-16 11:47:11

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 197

Re: The AMD/ATI Bar & Grill

Not tested but i guess it can help; add dkms as a hook that will rebuild modules on kernel upgrade:
https://aur.archlinux.org/packages.php?ID=61135

Offline

#4417 2012-10-16 14:17:39

caerolle
Member
Registered: 2012-09-28
Posts: 19

Re: The AMD/ATI Bar & Grill

Thanks, Lordheavy, I'll give that a try!  smile

Getting the ATI card to work right has been by far my biggest issue with Linux, would just buy an Nvidia card if I was sure that would work more smoothly.

Offline

#4418 2012-10-16 16:41:29

Diadara
Member
Registered: 2012-09-10
Posts: 11

Re: The AMD/ATI Bar & Grill

Hello everyoneI am trying to make hardware accelerated video work with my hd4500/5100 serie card using 12.6 unofficial drivers.I have followed the steps in the catalyst page
vainfo gives

libva info: VA-API version 0.33.0
libva info: User requested driver 'xvba'
libva info: Trying to open /usr/lib/dri//xvba_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.33 (libva 1.1.0)
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
vainfo: Supported profile and entrypoints
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD

everything seems to work fine but i dont get any noticeble perfomance improvements with 1080p video decoding,

Even if  hardware accelerated decoding is turned off  i am getting same cpu and gpu loads around 30% for both.
Is this normal ? I was expecting zero cpu load after hardware accelerated decoding.The funny part is i am getting 40% cpu and gpu loads with mplayer with vaapi turned on compared to around 30% without it.Am I missing anything ? The gpu load makes me think that its doing something but why isnt the cpu load zero?

Offline

#4419 2012-10-16 17:22:43

Foks
Member
Registered: 2010-12-27
Posts: 18

Re: The AMD/ATI Bar & Grill

Hi Diadara,

do you use the 'mplayer-vaapi' package to play videos?
And do you remember to use '-vo vaapi -va vaapi' arguments for mplayer?

Offline

#4420 2012-10-16 18:51:08

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

kernel 3.7 rc1:
you have to include uapi directory into kernel's headers before starting...

i have prepared a patch to make catalyst work with kernel 3.7, and because it's mine i don't trust it ;P, it seems to work fine here on x86_64 though it should to be tested better, here it is: http://catalyst.apocalypsus.net/files/a … -3.7.patch
i've already added it into catalyst-generator @ AUR : https://aur.archlinux.org/packages.php?ID=41040

if you are 3.7 user, got time (and monkeys ;P) please test it smile thanks



Edit: ah, let's not forget about other distros users, those error codes should make this patch easier to find:

  CC [M]  /tmp/catalyst.Jc9FIy/src/kcl_io.o
/tmp/catalyst.Jc9FIy/src/firegl_public.c: In function ‘KCL_MEM_VM_MapRegion’:
/tmp/catalyst.Jc9FIy/src/firegl_public.c:3895:39: error: ‘VM_RESERVED’ undeclared (first use in this function)
/tmp/catalyst.Jc9FIy/src/firegl_public.c:3895:39: note: each undeclared identifier is reported only once for each function it appears in
make[1]: *** [/tmp/catalyst.Jc9FIy/src/firegl_public.o] Error 1

fglrx

Edit 5: patch works also with 3.7 rc2 , 3.7 rc3, 3.7 rc4 and 3.7 rc6 smile
(didn't test on rc5)

Edit2: in replay to next post:

Diadara wrote:

ps:i am getting the feeling that this is the wrong place to post

not at all, it's fine smile

Last edited by Vi0L0 (2012-11-18 21:11:57)

Offline

#4421 2012-10-16 19:03:59

Diadara
Member
Registered: 2012-09-10
Posts: 11

Re: The AMD/ATI Bar & Grill

i am using mplayer-vaapi,i was using  just  -vo vaapi ,but just realised that the video wasnt h264 encoded ,how stupid of me ! But now with h264 encoded files  i am  getting heavy stuttering with mplayer -vo vaapi -va vaapi, i am getting decent video perfomance with vlc  (vlc crashes when i try to play 6 channel audio files using alsa)
ps:i am getting the feeling that this is the wrong place to post

Last edited by Diadara (2012-10-17 06:35:14)

Offline

#4422 2012-10-18 13:06:41

kuglee
Member
Registered: 2011-09-02
Posts: 61

Re: The AMD/ATI Bar & Grill

Hardware acceleration is not working for me for a long time. I'm also using 12.6 beta becasue of the mobility hd4330 card.

Offline

#4423 2012-10-18 13:09:36

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 671

Re: The AMD/ATI Bar & Grill

kuglee wrote:

Hardware acceleration is not working for me for a long time. I'm also using 12.6 beta becasue of the mobility hd4330 card.

Without any sort of detail it's a bit hard to help you...

Offline

#4424 2012-10-18 18:20:05

mandos
Member
From: Greece
Registered: 2006-01-23
Posts: 100
Website

Re: The AMD/ATI Bar & Grill

I just wanted to say that many of my problems regarding kernel updates are gone b using catalyst-generator. I installed it as the wiki says and video playback is back to normal as is multi-display handling.

Of course I need to ran it manually, but if it fixes problem I'm ok with it.

Offline

#4425 2012-10-18 18:55:37

kuglee
Member
Registered: 2011-09-02
Posts: 61

Re: The AMD/ATI Bar & Grill

snack wrote:

Without any sort of detail it's a bit hard to help you...

I've tried everything (diffecent libva, different mplayer-vaapi source) but nothing seems to work to get rid of the tearing issue. Previously I had it working with mplayer-vaapi.

Last edited by kuglee (2012-10-18 18:55:58)

Offline

Board footer

Powered by FluxBB