You are not logged in.

#1 2012-10-16 16:26:26

4on6
Member
Registered: 2011-10-05
Posts: 166

Pacman fails installing Tuxguitar

I tried to install Tuxguitar but ran into the following error:

[tj@arch ~]$ LC_ALL=C sudo pacman -S tuxguitar
resolving dependencies...
looking for inter-conflicts...

Targets (2): swt-4.2-1  tuxguitar-1.2-5

Total Download Size:    1.45 MiB
Total Installed Size:   8.29 MiB

Proceed with installation? [Y/n] y
:: Retrieving packages from extra...
error: failed retrieving file 'swt-4.2-1-x86_64.pkg.tar.xz' from ftp.spline.inf.fu-berlin.de : The requested URL returned error: 404 Not Found
warning: failed to retrieve some files from extra
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

Is that a known problem (did not find anything related in the forum though) or something only I experience?

Last edited by 4on6 (2012-10-16 16:27:52)

Offline

#2 2012-10-16 16:30:49

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: Pacman fails installing Tuxguitar

Never just install a package without updateing the whole system. In your case there is a newer version of swt on the server and tthe old one got removed. E.g. Use "pacman -Syu tuxguitar"

Offline

#3 2012-10-16 16:39:24

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: Pacman fails installing Tuxguitar

Ok, I understand - but immediately ran into a new problem:

[tj@arch ~]$ LC_ALL=C sudo pacman -Syu 
:: Synchronizing package databases...
 core is up to date
 haskell is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-pandoc: requires ghc=7.4.2-1
:: haskell-pandoc: requires haskell-http=4000.2.5-1
:: haskell-pandoc: requires haskell-base64-bytestring=0.1.2.0-1
:: haskell-pandoc: requires haskell-blaze-html=0.5.1.0-1
:: haskell-pandoc: requires haskell-blaze-markup=0.5.1.1-1
:: haskell-pandoc: requires haskell-citeproc-hs=0.3.4-13
:: haskell-pandoc: requires haskell-highlighting-kate=0.5.3.2-1
:: haskell-pandoc: requires haskell-json=0.5-15
:: haskell-pandoc: requires haskell-mtl=2.1.2-1
:: haskell-pandoc: requires haskell-network=2.3.1.0-1
:: haskell-pandoc: requires haskell-pandoc-types=1.9.1-6
:: haskell-pandoc: requires haskell-parsec=3.1.3-3
:: haskell-pandoc: requires haskell-random=1.0.1.1-7
:: haskell-pandoc: requires haskell-syb=0.3.7-1
:: haskell-pandoc: requires haskell-tagsoup=0.12.8-1
:: haskell-pandoc: requires haskell-temporary=1.1.2.3-3
:: haskell-pandoc: requires haskell-texmath=0.6.1.1-1
:: haskell-pandoc: requires haskell-utf8-string=0.3.7-7
:: haskell-pandoc: requires haskell-xml=1.3.12-9
:: haskell-pandoc: requires haskell-zip-archive=0.1.1.8-5
:: haskell-pandoc: requires haskell-zlib=0.5.4.0-1

Offline

#4 2012-10-16 20:50:40

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: Pacman fails installing Tuxguitar

haskell-pandoc is an AUR package. Remove it or update it.

(these are very basic package management questions you should be able to figure out on your own)

Offline

Board footer

Powered by FluxBB