You are not logged in.

#1 2011-11-02 03:25:44

6msj
Member
Registered: 2011-10-03
Posts: 42

[SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

:: Synchronizing package databases...
core is up to date
extra                   887.1K 1424.1K/s 00:00:01 [-------------------------] 100%
community               580.2K 1192.7K/s 00:00:00 [-------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: libgl and nvidia-utils are in conflict. Remove nvidia-utils? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libgl and nvidia-utils are in conflict


I've read threads on this before but this time nvidia-utils is being asked to be removed. I'm not sure if removing nvidia-utils is safe. Before, reading some threads on here, I had to set libgl to ignore to get nvidia-utils to install.

Thanks.

Last edited by 6msj (2011-11-02 22:48:25)

Offline

#2 2011-11-02 04:01:05

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

What graphics card do you have?
Nvidia provides their own libgl implementation therefore is in conflict with the regular libgl. Yes, removing nvidia-utils is safe but you need that package if you want to use proprietary nvidia drivers.

Offline

#3 2011-11-02 05:18:04

6msj
Member
Registered: 2011-10-03
Posts: 42

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

I have a nvidia 8200m. I'm not sure what my course of action should be here and how to execute it.

Should I set an ignore on libgl and continue as normal or remove nvidia and use the regular libgl. I'm not sure the quality of differences between the two.

Thanks.

Offline

#4 2011-11-02 08:21:05

lucak3
Member
From: Italy
Registered: 2010-01-23
Posts: 72

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

It's not the recunt update that bought conflict: they are like this since years, it's normal. If you want to use official binary driver from NVIDIA, then remove libgl. It's safe, as they provide theirs implementation of that: you can see with pacman that nvidia package provides libgl.


The Linux philosophy is 'laugh in the face of danger'. Oops. Wrong one. 'Do it yourself'. That's it. - Linus Torvalds

Offline

#5 2011-11-02 08:32:35

tresh
Member
Registered: 2011-11-02
Posts: 3

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

Hello,
i currently have the same problem as 6msj on with my nVidia NVS4200M Optimus:

$ pacman -Suy
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: libgl and nvidia-utils are in conflict. Remove nvidia-utils? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libgl and nvidia-utils are in conflict

Last time i updated via 'pacman -Suy' that problem did not occur. Seems to me that one of the updates wants to fetch libgl even if it possibly shouldn't. Is there some way to check what's the package in question?

Best regards,
David

Offline

#6 2011-11-02 08:50:10

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

pacman -Qs dri

i suspect you guys installed all xorg group which include all video drivers available and somehow you forced installing nvidia-utils


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#7 2011-11-02 09:08:55

tresh
Member
Registered: 2011-11-02
Posts: 3

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

Hello,

[root@shelly tresh]# pacman -Qs dri
local/intel-dri 7.11-2
    Mesa DRI drivers for Intel
local/libirman 0.4.5-2
    Irman driver lcd library
local/nvidia 285.05.09-1
    NVIDIA drivers for linux.
local/nvidia-utils 285.05.09-1
    NVIDIA drivers utilities and libraries.
local/xf86-input-evdev 2.6.0-4 (xorg-drivers xorg)
    X.org evdev input driver
local/xf86-video-fbdev 0.4.2-5 (xorg-drivers xorg)
    X.org framebuffer video driver

Thats the whole output i get. I don't understand what do you mean by "all xorg group" and "forced installing nvidia-utils". I am using the binary nvidia driver because nouveau did not work for me. As far as i understand nvidia depends on nvidia-utils.

Offline

#8 2011-11-02 09:11:13

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

you have intel-dri  installed which has libgl dependency versioned. that package was updated recently and wants a newer libgl but it can't install it because nvidia-utils is installed.

solution: pacman -R intel-dri


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#9 2011-11-02 09:15:05

tresh
Member
Registered: 2011-11-02
Posts: 3

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

wonder wrote:

you have intel-dri  installed which has libgl dependency versioned. that package was updated recently and wants a newer libgl but it can't install it because nvidia-utils is installed.

solution: pacman -R intel-dri

Awesome, that fixed it for me. Thanks!

Offline

#10 2011-11-02 09:27:28

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

@tresh better run testdb and see if you have more dependencies problem


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#11 2011-11-02 17:09:07

6msj
Member
Registered: 2011-10-03
Posts: 42

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

This is my output using what you said wonder.

Do you want to remove these packages? [Y/n] y
(1/2) removing xf86-video-intel                    [-------------------------] 100%
(2/2) removing intel-dri
[jamesarch@]$ testdb
missing dependency for ati-dri : libgl=7.11
missing dependency for mach64-dri : libgl=7.11
missing dependency for mga-dri : libgl=7.11
missing dependency for r128-dri : libgl=7.11
missing dependency for savage-dri : libgl=7.11
missing dependency for sis-dri : libgl=7.11
missing dependency for tdfx-dri : libgl=7.11
[jamesarch@]$ sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra                   888.0K 1606.1K/s 00:00:01 [-------------------------] 100%
community               583.3K 1200.4K/s 00:00:00 [-------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: libgl and nvidia-utils are in conflict. Remove nvidia-utils? [y/N]

Offline

#12 2011-11-02 17:47:58

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

@6msj do

pacman -Rns $(pacman -Qqs xorg-drivers | grep -v xf86-input-evdev)

next time guys stop installing xorg group and read the wiki. only xorg-server + your driver is enough this days

Last edited by wonder (2011-11-02 17:48:27)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#13 2011-11-02 22:48:40

6msj
Member
Registered: 2011-10-03
Posts: 42

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

Thanks wonder.

Offline

#14 2011-11-03 16:24:25

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

wonder wrote:

next time guys stop installing xorg group and read the wiki. only xorg-server + your driver is enough this days

Isn't it time then to remove the xorg group?

Offline

#15 2011-11-03 16:35:26

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

stryder wrote:
wonder wrote:

next time guys stop installing xorg group and read the wiki. only xorg-server + your driver is enough this days

Isn't it time then to remove the xorg group?

You mean https://bbs.archlinux.org/viewtopic.php?id=124923 ?
We're following upstream on that matter: https://bugs.archlinux.org/task/23296

Offline

#16 2012-10-14 11:26:15

cirrus
Member
From: Glasgow Scotland
Registered: 2012-08-24
Posts: 124
Website

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

Just had to add , this  occurs even for users who do not have the xorg group installed , i had only nouveau and the nvidia blob installed all was well until a recent update then i too was having these conflicts , removing nouveau fixed it for me.


We do not choose, we are chosen, those that dont understand dont matter, those that understand need no explanation. We are the chosen few.
http://cirrusminor.info
http://www.danasoft.com/sig/7972427251.jpg

Offline

#17 2012-10-14 18:03:13

rebootl
Member
Registered: 2012-01-10
Posts: 427
Website

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

Same as cirrus here.
Don't remember why I kept nouveau, when I installed nvidia. If everything will work without it that's fine for me smile Updating now...

Last edited by rebootl (2012-10-14 18:03:45)


Personal website: cem.revamp-it.ch
GitHub: github.com/rebootl

Offline

#18 2012-10-16 10:16:53

slopjong
Member
Registered: 2011-07-25
Posts: 6

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

I confirm that only by removing nouveau I got rid of that issue. Btw. certain use cases require to have both installed e.g. trying to fix an issue with the nvidia driver.

Offline

#19 2012-10-17 03:43:01

AskApache
Member
Registered: 2009-10-18
Posts: 16
Website

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

Worked for me:

pacman -Rns xf86-video-nouveau

Then pacman -Syu

Offline

#20 2012-10-17 04:13:03

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,794

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

slopjong wrote:

Btw. certain use cases require to have both installed e.g. trying to fix an issue with the nvidia driver.

And vesa wouldn't work for that? Raise a bug if you feel this is really required, but it would require quite a bit of symlink hackery to have both nouveau and nvidia installed and usable on the same system, last I checked. Not something which can be easily automated by packages.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#21 2012-12-05 12:55:47

possiblefool
Member
From: UK
Registered: 2011-06-18
Posts: 29

Re: [SOLVED] Libgl and Nvidia-Utils are in conflict with the mos

Sorry to bump a dying post but I'm running into this problem upgrading dkms-nvidia.

==> Install or build missing dependencies for dkms-nvidia:
resolving dependencies...
looking for inter-conflicts...
:: nvidia-utils and libgl are in conflict. Remove libgl? [y/N] y
:: nvidia-utils and nvidia-utils-bumblebee are in conflict. Remove nvidia-utils-bumblebee? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-utils and nvidia-utils-bumblebee are in conflict

sudo pacman -Rns nvidia-utils
error: target not found: nvidia-utils


pacman -Qs dri
local/bumblebee 3.0.1-4
    Bumblebee brings Optimus Support for Linux Through VirtualGL. You need to install proper drivers separately. Can be used with Nouveau or Nvidia
local/dkms-nvidia 304.64-1
    NVIDIA dynamic kernel module (DKMS) drivers for kernel26.
local/dri2proto 2.8-1
    X11 DRI protocol
local/hdparm 9.43-1
    A shell utility for manipulating Linux IDE drive/driver parameters
local/intel-dri 9.0.1-1
    Mesa DRI drivers for Intel
local/lib32-nvidia-utils 310.19-1
    NVIDIA drivers utilities and libraries. (32-bit)
local/libgl 9.0.1-1
    Mesa 3-D graphics library and DRI software rasterizer
local/libraw1394 2.0.7-2
    Provides an API to the Linux IEEE1394 (FireWire) driver
local/libzapojit 0.0.2-1
    GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs
local/nvidia-utils-bumblebee 304.64-1
    NVIDIA drivers utilities and libraries. With LibGL and xorg modules installed in a different directory.
local/unetbootin 581-1
    Create bootable Live USB drives
local/xf86-input-evdev 2.7.3-2 (xorg-drivers xorg)
    X.org evdev input driver
local/xf86-input-keyboard 1.6.2-2 (xorg-drivers xorg)
    X.Org keyboard input driver
local/xf86-input-synaptics 1.6.2-2 (xorg-drivers xorg)
    Synaptics driver for notebook touchpads
local/xf86-video-intel 2.20.14-1 (xorg-drivers xorg)
    X.org Intel i810/i830/i915/945G/G965+ video drivers
local/xorg-xdriinfo 1.0.4-3 (xorg-apps xorg)
    Query configuration information of DRI drivers


>wonder wrote:you have intel-dri  installed which has libgl dependency versioned. that package was updated recently and wants a newer libgl but it can't install it because nvidia-utils is installed.solution: pacman -R intel-dri


My laptop has optimus so intel and nvidia drivers are required, any idea how to proceed?

Last edited by possiblefool (2012-12-05 12:56:44)

Offline

Board footer

Powered by FluxBB