You are not logged in.

#1 2012-10-17 21:35:10

tankist02
Member
Registered: 2009-02-18
Posts: 13

hplip-plugin doesn't build with current hplip

I have HP LasertJet p1606dn which used to work just fine with hplip (from official repo) and hplip-plugin (from AUR). Then hplip was updated which caused it to conflict with hplip-plugin. I had to remove hplip-plugin to continue with system upgrade. Now when I try to install hplip-plugin from AUR again (using yaourt) it says:

==> Install or build missing dependencies for hplip-plugin:
error: target not found: hplip=3.12.9

Current version of hplip is

hplip 3.12.10.a-3

What can I do - downgrade hplip back to 3.12.9?

Offline

#2 2012-10-18 15:19:20

rtoijala
Member
Registered: 2011-09-11
Posts: 29

Re: hplip-plugin doesn't build with current hplip

As zilti said in the AUR comments for hplip-plugin, you should edit the PKGBUILD, replacing the values for pkgversion, depends and md5sums with

pkgver=3.12.10a
depends=(hplip=3.12.10.a)
md5sums=('7e9065367c347c76284be168143a0588')

Last edited by rtoijala (2012-10-18 15:19:51)

Offline

#3 2012-10-27 19:36:55

jamesbond007
Member
From: Germany
Registered: 2009-06-14
Posts: 148

Re: hplip-plugin doesn't build with current hplip

The AUR package hplip-plugin has been adopted by a new maintainer now.

Has anyone successfully tested it, does it work now with the current version of hplip?

Offline

Board footer

Powered by FluxBB