You are not logged in.

#1 2012-10-19 22:27:55

Jasper1984
Member
Registered: 2012-09-06
Posts: 9

Bumblebee won't work, cant connect to socket

I use systemd, if i type `sudo journalctl`, i get

Oct 20 00:32:06 localhost bumblebeed[1948]: [ 1293.610586] [ERROR]Module bbswitch could not be loaded (timeout?)
Oct 20 00:32:06 localhost bumblebeed[1948]: [ 1293.610605] [WARN]No switching method available. The dedicated card will al
Oct 20 00:32:06 localhost bumblebeed[1948]: [ 1293.719340] [INFO]/usr/sbin/bumblebeed 3.0.1 started
Oct 20 00:32:06 localhost bumblebeed[1948]: [ 1293.719416] [ERROR]Binding failed! Error: Address already in use

I think the last line is the source of my problems.(it can do without bbswitch..)

`optirun glxspheres` gets me

[ 1648.179533] [ERROR]You've no permission to communicate with the Bumblebee daemon. Try adding yourself to the 'bumblebee' group
[ 1648.179628] [ERROR]Could not connect to bumblebee daemon - is it running?

I am in that group, of course! `chmod 777 /var/run/bumblebee.socket` makes that:

[ 2194.206851] [ERROR]Could not connect to /var/run/bumblebee.socket! Error: Connection refused
[ 2194.206969] [ERROR]Could not connect to bumblebee daemon - is it running?

That does look like it is just not running.

`systemctl status` gives: I think that 'activating' means 'not active, but trying'? Or something. (see poor naming of stuff i mean 'journalctl'? systemctl_journal would make sense)

bumblebeed.service - Bumblebee C Daemon
	  Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
	  Active: activating (auto-restart) since Sat, 20 Oct 2012 00:40:21 +0200; 46s ago
	 Process: 2357 ExecStart=/usr/sbin/bumblebeed (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/bumblebeed.service

Have had this problem for a while..

Offline

#2 2012-10-20 08:18:54

Lekensteyn
Member
From: Netherlands
Registered: 2012-06-19
Posts: 189
Website

Re: Bumblebee won't work, cant connect to socket

Try removing that socket and restart bumblebeed. After adding yourself to the bumblebee group, you need to relogin. Have you done that?

Offline

#3 2012-10-20 11:44:28

Jasper1984
Member
Registered: 2012-09-06
Posts: 9

Re: Bumblebee won't work, cant connect to socket

Yay that worked! Thanks! I checked `groups` and indeed restarted, but deleting `/var/run/bumblebeed.socket` indeed did it! This is a thing you should try with broken sockets generally?

Any idea how did this problem started? Should put up an issue, and where?

That was very simple.. I have been messing with this problem too long, in the future i'll just ask earlier if i have a problem..

Edit: i guess you're a bumblebee dev, at least you comment on many github issue threads. Anyway, thanks for the great software.

Last edited by Jasper1984 (2012-10-20 13:36:22)

Offline

#4 2012-10-20 14:49:16

Lekensteyn
Member
From: Netherlands
Registered: 2012-06-19
Posts: 189
Website

Re: Bumblebee won't work, cant connect to socket

Yes, I am a Bumblebee dev, see commit history wink I think that bumblebeed was already running, so starting it again yields the "Address already in use" error. If you are not in the "bumblebee" group, you won't be able to communicate with bumblebeed: optirun will have no clue whether you bumblebeed is running correctly or not. So adding yourself to the group and relogging should fix that.

> Module bbswitch could not be loaded (timeout?)
Have you installed bbswitch and built the module for your new kernel (sudo dkms autoinstall)?
There is also an outstanding issue in kernel 3.6 related to run-time PM in which affects bumblebeed and bbswitch. bbswitch is fixed in the dev branch, but bumblebeed might need some work. (this affects reading/writing PCI configuration space when run-time PM is enabled for the PCIe port.) If you just disable run-time PM for now, you will be fine.

Offline

#5 2012-10-20 15:01:03

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 440

Re: Bumblebee won't work, cant connect to socket

Lekensteyn wrote:

Yes, I am a Bumblebee dev, see commit history wink I think that bumblebeed was already running, so starting it again yields the "Address already in use" error. If you are not in the "bumblebee" group, you won't be able to communicate with bumblebeed: optirun will have no clue whether you bumblebeed is running correctly or not. So adding yourself to the group and relogging should fix that.

> Module bbswitch could not be loaded (timeout?)
Have you installed bbswitch and built the module for your new kernel (sudo dkms autoinstall)?
There is also an outstanding issue in kernel 3.6 related to run-time PM in which affects bumblebeed and bbswitch. bbswitch is fixed in the dev branch, but bumblebeed might need some work. (this affects reading/writing PCI configuration space when run-time PM is enabled for the PCIe port.) If you just disable run-time PM for now, you will be fine.

For me using Bumblebee and bbswitch works fine (Thinkpad Edge E530 with Nvidia GT 630) with Linux 3.6.2 and using systemd as init.
Rebuildet bbswitch(from the AUR) after kernel upgrade.


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#6 2015-04-08 16:09:52

aaa234
Member
Registered: 2015-01-07
Posts: 33

Re: Bumblebee won't work, cant connect to socket

Lekensteyn wrote:

Try removing that socket and restart bumblebeed. After adding yourself to the bumblebee group, you need to relogin. Have you done that?


I'm sry I ask the question in this old thread, I didn't find bumblebees.socket but found bumblebee.socket so I deleted it. After removing, I relogined but the error still remains, what should I do?

Offline

#7 2015-04-08 18:22:00

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,086
Website

Re: Bumblebee won't work, cant connect to socket


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#8 2015-04-08 18:23:29

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,809

Re: Bumblebee won't work, cant connect to socket

aaa234,

I am going to ask you to start a new thread that you will own.  This thread has been dormant for some time, and I have not seen the players here for some time.  Feel free to link back to this thread if you feel it is relevant.

Thanks.

Edit:  Jasonwryan was a bit faster.

Last edited by ewaller (2015-04-08 18:24:05)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB