You are not logged in.

#1 2012-10-22 00:59:59

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

upgrade trac from 0.12.3-1 to 1.0-3 failed

I want to upgrade trac to 1.0, but If I just pacman -Syu, that will cause web can not access original data.

My current workaround is keep trac in IgnorePkg of /etc/pacman.conf.

But, recently, I can not upgrade system anymore.

:: Starting full system upgrade...
:: Replace python-babel with community/python2-babel? [Y/n]
:: Replace python-genshi with community/python2-genshi? [Y/n]
warning: trac: ignoring package upgrade (0.12.3-1 => 1.0-3)
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: trac: requires python-genshi
:: trac: requires python-babel

Is there another workaround or there is a correct way to upgrade trac from 0.12.3 to 1.0?


Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

#2 2012-10-22 01:06:56

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: upgrade trac from 0.12.3-1 to 1.0-3 failed

dlin wrote:

that will cause web can not access original data.

I'm sorry, but I don't understand what the issue is. Can you rephrase it or describe the problem in more detail?

Offline

#3 2012-10-22 01:15:08

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

Re: upgrade trac from 0.12.3-1 to 1.0-3 failed

To Karol,

I do following command, but it failed.  Because the system is on production, I can not test it too long.
So, I downgrade to old version.  Do you upgrade smooth?

I guess that may caused by I've ever add some db field.

trac-admin /path/to/projenv wiki upgrade

Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

Board footer

Powered by FluxBB