You are not logged in.

#1 2012-10-21 20:00:50

creeten
Member
Registered: 2011-10-13
Posts: 7

Archlinux & iMac - can't boot after deleting rEFLt

Hello,

I havent used Linux for about 4month (Got to an iMac through work). But since OSX really annoyed me I wanted to install Archlinux again.

Tried several Tutorial for Mac installation, ended up with a blank HDD and tried arch only after several tries with OSX.
Accidently deleted rELft (Or however its called) now I can install everything, but I dont know how to boot.
I just get a blank white screen, and can boot cd or recovery mode etc. But I have no idea how to boot my Archlinux System, everything I tried failed or broke even more.

I really really hope someone here can help and explain me how I can boot Archlinux.
My partition table now consits out of 2 Partitions, root and swap.
I Also changed my Layout to MBR.

Last edited by jasonwryan (2012-10-21 20:02:28)

Offline

#2 2012-10-21 20:03:38

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,082
Website

Re: Archlinux & iMac - can't boot after deleting rEFLt

I've edited your title to remove the 'urgent' and include something that actually describes your issue
https://wiki.archlinux.org/index.php/Fo … ow_to_Post


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2012-10-21 21:55:14

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,766
Website

Re: Archlinux & iMac - can't boot after deleting rEFLt

I am far from an expert on how to install properly on a mac.  But I'm pretty good at having linux improperly installed on two macs.

If you want a smooth quick efi-based boot on your mac, stop reading here and wait for better input.  If you just want to boot into arch, however, you *can* follow all the installation guides ignoring everything mac specific and pretend your machine were like any PC.  In the end everything will work ... with a very long boot.

This is due to - from what I understand - is mac's bios compatibility mode.  When I boot up one of my macs (single boot to arch, no refit, no uefi, no efi of any sort) I get the white/gray screen for about a minute.  Then it falls back to bios compatability mode, detects the boot flag on the disk, and starts up my boot loader (grub-legacy on one, syslinux on the other).  From there everything works fine.

Have you tried waiting at that white/grey screen for a while?  I've read the delay should only be 30 seconds, but on my macbook it is almost 2 minutes, consistently.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2012-10-21 22:25:22

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Archlinux & iMac - can't boot after deleting rEFLt

@Trilby, you know you can drasticly reduce that wait if you "bless" that boot-flagged partition.  I know you can just do this from an OSX installer disc, but I believe there is also an experimental bless utility from Fedora(?) that you could try.  My old macbook went from over a minute to just a couple seconds.  It is the same amount of time I used to experience when I had set up windows with bootcamp, which I figure is the switch from crazy EFI to bios compatibility.

@OP, I sure as heck hope that you did not try and use the efibootmgr command on your iMac... though if you chaged to mbr, it sounds like you are probably using bios mode.  Try waiting it out, failing that, you may need to bless the partition you want to boot (read above).

Offline

#5 2012-10-21 23:09:39

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,766
Website

Re: Archlinux & iMac - can't boot after deleting rEFLt

Yup, but I've long since tossed those coasters/frisbies.  I also tried the bless tool in the AUR, but it only works on efi setups.  I'm fine with my set up - I very rarely reboot my mac.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#6 2012-10-22 09:24:10

creeten
Member
Registered: 2011-10-13
Posts: 7

Re: Archlinux & iMac - can't boot after deleting rEFLt

Well I tried to manually install syslinux in the MBR now (since the update function allways returned an error on setting the boot flag) and when I start my iMac, after about 10-15seconds it starts, but says "No operating System found" >.<

I also blessed the boot partition.


Edit: did everything new now, manually installed syslinux and blessed the root partition (wich is where boot is also) and syslinux boots but shows me "could not find kernel image: menu.c32"

Last edited by creeten (2012-10-22 17:55:44)

Offline

Board footer

Powered by FluxBB