You are not logged in.

#1 2012-10-22 20:08:47

Kebertx
Member
Registered: 2012-01-02
Posts: 69

[SOLVED] Console font ignored after switching to systemd

After an eon of being skeptical, I finally switched from the ever beloved initscripts to the brave new world systemd. Someday the nostalgia will subside, but I digress.

Everything works like a charm. So far I have not a complaint..... save this one: My console font has reverted to the default!

My /etc/vconsole.conf is here:

KEYMAP=us
FONT="ter-112n"
FONT_MAP=8859-1_to_uni
CONSOLEFONT="ter-112n"

Also, I get this output trying setfont on tty1:

# setfont /usr/share/kbd/consolefonts/ter-112n.psf.gz
Couldn't get a file descriptor referring to the console

Here's the riddley part: I have the consolefont hook in mkinitcpio.conf, and THAT works! It shows me terminus as the font early in the boot process, and reverts to the default monospaced font around the time when the filesystems are being mounted. I am confused. Has anyone any insight for me?

Last edited by Kebertx (2012-10-23 02:05:49)

Offline

#2 2012-10-22 20:11:20

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,090
Website

Re: [SOLVED] Console font ignored after switching to systemd

Try it without the quotes, as per the man page...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2012-10-22 20:21:00

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Console font ignored after switching to systemd

There is no such thing as "/usr/share/kbd/consolefonts/ter-112n.psf.gz" on my system.


See: https://wiki.archlinux.org/index.php/Be … and_keymap

You only need KEYMAP and FONT.

Remove CONSOLEFONT (notice the file's name?).



Edit: Oh, it's because I don't have the terminus-font package installed.

$ ls /usr/share/kbd/consolefonts/ter-112n.psf.gz
ls: cannot access /usr/share/kbd/consolefonts/ter-112n.psf.gz: No such file or directory

$ pkgfile ter-112n.psf.gz
community/terminus-font

Last edited by DSpider (2012-10-22 20:35:24)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#4 2012-10-22 20:28:21

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,691

Re: [SOLVED] Console font ignored after switching to systemd

Kebertx wrote:

Also, I get this output trying setfont on tty1:

# setfont /usr/share/kbd/consolefonts/ter-112n.psf.gz
Couldn't get a file descriptor referring to the console

I have this font on my system, and I get this error if I try to set the console font (using the command you posted) from a terminal in X. It works correctly if I am at a console (not in X).

┌[~]
└──╼ pacman -Qo /usr/share/kbd/consolefonts/ter-112n.psf.gz
/usr/share/kbd/consolefonts/ter-112n.psf.gz is owned by terminus-font 4.36-2

DSpider, do you have the terminus-font package installed?

Last edited by 2ManyDogs (2012-10-22 20:37:13)

Offline

#5 2012-10-22 20:34:24

Kebertx
Member
Registered: 2012-01-02
Posts: 69

Re: [SOLVED] Console font ignored after switching to systemd

Removed the quotes, and unneeded values. Now the file says:

KEYMAP=us
FONT=ter-112n

Still no dice. Also, I was not running the command from an X session, I was in the console. I feel in my heart this must be related to systemd, it was the only change I made.

Offline

#6 2012-10-22 20:35:12

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,691

Re: [SOLVED] Console font ignored after switching to systemd

Kebertx wrote:

Removed the quotes, and unneeded values. Now the file says:

KEYMAP=us
FONT=ter-112n

Still no dice. Also, I was not running the command from an X session, I was in the console. I feel in my heart this must be related to systemd, it was the only change I made.

I have systemd on the machine where this worked. Were you in a tmux or screen session in the console? I also get the error if I'm in tmux at the console.

(edit) I just tried changing my /etc/vconsole.conf to match yours, it it works fine for me (on a pure systemd system). I do not have the consolefont hook in mkinitcpio.conf.

Last edited by 2ManyDogs (2012-10-22 20:47:22)

Offline

#7 2012-10-22 21:25:07

Kebertx
Member
Registered: 2012-01-02
Posts: 69

Re: [SOLVED] Console font ignored after switching to systemd

2ManyDogs wrote:

I have systemd on the machine where this worked. Were you in a tmux or screen session in the console? I also get the error if I'm in tmux at the console.

(edit) I just tried changing my /etc/vconsole.conf to match yours, it it works fine for me (on a pure systemd system). I do not have the consolefont hook in mkinitcpio.conf.

Okay, that was actually the problem for setfont. I quit tmux, and it worked. The configuration file still does not work, except very early in the boot process.

Offline

#8 2012-10-22 22:14:23

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: [SOLVED] Console font ignored after switching to systemd

smile

It's a typo. You meen. ter-v12n .... not ter-v112n  .... i.e. not 112 point font... but 12 point font

KEYMAP=us
FONT=ter-v12n
FONT_MAP=

and

setfont ter-v12n

Also, I had to add my graphics driver to my MODULES= array in mkinitcpio.conf then rebuild my initramfs.

So, for my Intel HD4000 graphics I added i915 to MODULES= in mkinitcpio.conf

Last edited by hunterthomson (2012-10-22 22:15:24)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#9 2012-10-22 23:00:24

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,691

Re: [SOLVED] Console font ignored after switching to systemd

hunterthomson wrote:

smile

It's a typo. You meen. ter-v12n .... not ter-v112n  .... i.e. not 112 point font... but 12 point font

KEYMAP=us
FONT=ter-v12n
FONT_MAP=

and

setfont ter-v12n

He's not trying to set ter-v112n, he's trying to set ter-112n (no v). I have ter-112n:

┌[~]
└──╼ ls /usr/share/kbd/consolefonts/ter-1*
/usr/share/kbd/consolefonts/ter-112n.psf.gz  /usr/share/kbd/consolefonts/ter-118b.psf.gz  /usr/share/kbd/consolefonts/ter-124n.psf.gz
/usr/share/kbd/consolefonts/ter-114b.psf.gz  /usr/share/kbd/consolefonts/ter-118n.psf.gz  /usr/share/kbd/consolefonts/ter-128b.psf.gz
/usr/share/kbd/consolefonts/ter-114n.psf.gz  /usr/share/kbd/consolefonts/ter-120b.psf.gz  /usr/share/kbd/consolefonts/ter-128n.psf.gz
/usr/share/kbd/consolefonts/ter-114v.psf.gz  /usr/share/kbd/consolefonts/ter-120n.psf.gz  /usr/share/kbd/consolefonts/ter-132b.psf.gz
/usr/share/kbd/consolefonts/ter-116b.psf.gz  /usr/share/kbd/consolefonts/ter-122b.psf.gz  /usr/share/kbd/consolefonts/ter-132n.psf.gz
/usr/share/kbd/consolefonts/ter-116n.psf.gz  /usr/share/kbd/consolefonts/ter-122n.psf.gz
/usr/share/kbd/consolefonts/ter-116v.psf.gz  /usr/share/kbd/consolefonts/ter-124b.psf.gz

"setfont /usr/share/kbd/console-fonts/ter-112n.psf.gz" works for me, and it did for the OP once he stopped tmux.

"setfont /usr/share/kbd/console-fonts/ter-v12n.psf.gz" also works, and does exactly the same thing.

"FONT=ter-112n" works for me in vconsole.conf. It doesn't work for the OP. He has a consolefont hook in his mkinitcpio.conf, I don't.
"FONT=ter-v12n" also works for me, and does exactly the same thing ter-112n does.

Last edited by 2ManyDogs (2012-10-23 00:08:01)

Offline

#10 2012-10-22 23:53:12

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: [SOLVED] Console font ignored after switching to systemd

When the graphics drivers are loaded they reset your console settings. You could try adding your graphics module to the initramfs to see if the cause is that the vconsole-setup is ran before the graphics module is inserted.

Offline

#11 2012-10-23 01:38:07

Kebertx
Member
Registered: 2012-01-02
Posts: 69

Re: [SOLVED] Console font ignored after switching to systemd

Thank you for defending my typing skills, 2ManyDogs, absolutely right!
Marking this thread as solved because tomegun was right. I added radeon to my modules in mkinitcpio.conf, rebuilt, rebooted, and my life was saved!
Cheers!

Offline

#12 2012-10-23 01:51:06

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,691

Re: [SOLVED] Console font ignored after switching to systemd

That must be why it works for me then -- I have the module in my mkinitcpio.conf, but I honestly don't remember putting it there. I'm glad you got it solved.

Offline

#13 2012-10-23 09:13:26

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: [SOLVED] Console font ignored after switching to systemd

Kebertx wrote:

Thank you for defending my typing skills, 2ManyDogs, absolutely right!
Marking this thread as solved because tomegun was right. I added radeon to my modules in mkinitcpio.conf, rebuilt, rebooted, and my life was saved!
Cheers!

Awe, I see now tongue sorry about that LOL

But ah, I did tell you to add your graphics module to the modules array in mkinitcpio.conf and rebuild your initramfs.

Just saying.


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

Board footer

Powered by FluxBB