You are not logged in.

#1 2005-10-09 23:44:10

cliff99
Member
From: Sydney
Registered: 2005-10-03
Posts: 50

Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

Trying to get amule working but

[root@myhost amule1]# pacman -S amule
error: unresolvable dependencies:  amule: requires wxgtk<=2.6.1 but it is not in the sync db

any ideas?

Cliff

Offline

#2 2005-10-10 08:52:39

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

wxgtk indeed seems to be updated to 2.6.2. It seems that this there was a problem with wxgtk2.6.2 and amule (http://bugs.archlinux.org/?do=details&id=3306).
You could try to force downgrading to wxgtk2.6.1-2, atm there are still mirrors having this version wink

Offline

#3 2005-10-10 09:26:06

cliff99
Member
From: Sydney
Registered: 2005-10-03
Posts: 50

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

pressh wrote:

wxgtk indeed seems to be updated to 2.6.2. It seems that this there was a problem with wxgtk2.6.2 and amule (http://bugs.archlinux.org/?do=details&id=3306).
You could try to force downgrading to wxgtk2.6.1-2, atm there are still mirrors having this version wink

Thanks for that, can I use pacman to downgrade, hope I don't break anything else.

Offline

#4 2005-10-10 09:57:07

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

Don't think this can be automatically done using pacman (searching mirrors for this file).
One mirror which at least has this file at the moment is ftp://ftp-linux.cc.gatech.edu/pub/linux … ra/os/i686
You can either manually download the file from ftp://ftp-linux.cc.gatech.edu/pub/linux … pkg.tar.gz, and then issue the command (in the dir where you downloaded the file)

pacman --upgrade wxgtk-2.6.1-2.pkg.tar.gz

or add the server on the top of your pacman.conf file

[wxgtk-old]
Server ftp://ftp-linux.cc.gatech.edu/pub/linux/distributions/archlinux/extra/os/i686/

and then use

pacman -Su wxgtk-2.6.1-2

For more options on pacman, take a look at

man pacman

Offline

#5 2005-10-10 10:02:17

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

One more thing, you should add for the moment an

IgnorePkg = <package>

to your pacman.conf, which instructs pacman to ignore any upgrades for this package when performing a --sysupgrade

Offline

#6 2005-10-10 10:16:56

cliff99
Member
From: Sydney
Registered: 2005-10-03
Posts: 50

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

pressh wrote:

One more thing, you should add for the moment an

IgnorePkg = <package>

to your pacman.conf, which instructs pacman to ignore any upgrades for this package when performing a --sysupgrade

Greatly appreciated, getting th hang of this Archlinux slowly. Really like the package handling and I thought apt-get was the best, think I need to rethink thta now.

I'll let you know how I go!

Cliff

worked like a charm and wht's more important I learnt some more about Arch.

Offline

#7 2005-10-11 14:49:48

InfernalH
Member
From: Lithuania/Klaipeda-Vilnius
Registered: 2005-02-08
Posts: 101
Website

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

pressh wrote:

or add the server on the top of your pacman.conf file

[wxgtk-old]
Server ftp://ftp-linux.cc.gatech.edu/pub/linux/distributions/archlinux/extra/os/i686/

and then use

pacman -Su wxgtk-2.6.1-2

They have already updated this package hmm I think that old users of Arch should have old versions in /var/cache/pacman/pkg

pacman -U /var/chache/pacman/pkg/wxgtk-2.6.1-2.pkg.tar.gz

Offline

#8 2005-10-11 18:00:53

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

Just install wxgtk-2.6.2-2 (latest)
it solves the amule issue

-neri

Offline

#9 2005-10-11 20:49:58

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Amule Dependencies ? have wxgtk-2.6.2-1 need wxgtk<=2.6.1

neri wrote:

Just install wxgtk-2.6.2-2 (latest)
it solves the amule issue

-neri

Hence, everyone can now just install amule using pacman as the amule version is updated too
(the cache of some mirrors should not be used anymore!)

Offline

Board footer

Powered by FluxBB