You are not logged in.

#1 2012-10-22 19:39:38

jjacky
Member
Registered: 2011-11-09
Posts: 321
Website

MTU error (Path too long) with linux-3.6.2

I have a PC running 24/7, with an OpenVPN connection up all the time as well. I also have a (shared) ssh connection open, through said vpn. Every night an rsync job is ran, to backup some stuff over said VPN, through a shared ssh connection.

Starting a few days ago (Oct 17) I've had trouble with this, as in after rsync started, it would not be able to finish its job, getting "interrupted" (or, hanged) quite early on.

Looking in the journal, I can see error messages such as those (right after rsync starts, which happens at 02:23) :

Oct 17 02:23:05 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:06 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:06 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:06 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:06 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:07 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:09 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:13 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:22 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:23:39 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:24:13 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:25:20 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:27:21 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:29:21 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:31:21 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:33:22 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:35:22 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)
Oct 17 02:37:22 arch.local openvpn@xxx[552]: read UDPv4 [EMSGSIZE Path-MTU=1460]: Message too long (code=90)

This eventually led to the ssh connection timing out, and the rsync job failing to complete.

Also, restarting OpenVPN seems to "fix" the issue, without the need to change any settings.
That's when I realized this started happening since upgrading the kernel to 3.6.2, so I then downgraded to 3.5.6 (Oct 19) and, since then, haven't had any issue.

So I'm thinking this is some kind of bug/regression in the 3.6 kernel, but I'm not really sure what to do now.

Note: I see 3.6.3 is out (and in testing), but only looked at the changelog so far (and didn't see anything that seem related to this issue?).

Offline

#2 2012-10-22 21:34:40

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,690
Website

Re: MTU error (Path too long) with linux-3.6.2

I know very little about this - so I could well be wrong - but I've had to set my MTU to fix a different issue, and I had heard that a setting of 1500 was recommended.  Perhaps increasing from 1460 to 1500 could be worth a shot.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2012-10-22 21:37:29

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,428
Website

Re: MTU error (Path too long) with linux-3.6.2

1500 is the default MTU for most connections.  If you are using a (A)DSL modem however you want the MTU to be 1492.  8 bytes are used by the (A)DSL modem for its own uses.


We all make choices, but in the end, our choices make us.

Offline

#4 2012-10-26 15:51:39

jjacky
Member
Registered: 2011-11-09
Posts: 321
Website

Re: MTU error (Path too long) with linux-3.6.2

Thanks for your answers (and sorry about the delay).

I'm not sure how to read the error message actually, but I use default settings and `ip addr show` reports a MTU of 1500 indeed. Also, (on linux-3.6.2) I tried using OpenVPN's --mtu-test option to see what it would say (even though early on I never have a problem), and here it is:

NOTE: Empirical MTU test completed [Tried,Actual] local->remote=[1541,1541] remote->local=[1541,1541]

I'm nor really sure what it means, that I could (should?) use 1541 instead of 1500? And if so, how come it says I could go higher while I get errors with Path-MTU=1460 ? And actually, right before this result I do have a couple of those Path-MTU errors in the log, so I really don't know what to make of it, could it fail at 1460 but work higher? Does that even make sense?

I still don't know if it's really an MTU issue or not, since the kernel 3.5.6 isn't affected. Anyhow, I'll probably install 3.6.3 and see, hopefully it'll be back to normal.... if not I guess I'll have to try and set an MTU, though I'm not sure to what.
Also, would that require the OpenVPN server to have its MTU set that way as well (Since currently it also uses default settings, so MTU 1500) ?

Offline

#5 2013-01-15 12:26:03

Zygote
Member
Registered: 2013-01-15
Posts: 75

Re: MTU error (Path too long) with linux-3.6.2

Im having the same issue, except with slightly different values.

read UDPv4 [EMSGSIZE Path-MTU=1422]: Message too long (code=90)

I have no idea how to fix it though unfortunately..

Last edited by Zygote (2013-01-15 12:26:21)

Offline

#6 2013-01-15 12:54:47

brebs
Member
Registered: 2007-04-03
Posts: 3,413

Re: MTU error (Path too long) with linux-3.6.2

You can search this forum for other discussions about MTU, e.g. thread.

Offline

#7 2013-01-15 14:28:42

jjacky
Member
Registered: 2011-11-09
Posts: 321
Website

Re: MTU error (Path too long) with linux-3.6.2

IIRC what I ended up doing was using ping to determine a valid MTU, e.g:

$ ping 10.8.0.1 -M do -s 1450
PING 10.8.0.1 1450(1478) bytes of data.
From 10.8.0.3 icmp_seq=1 Frag needed and DF set (mtu = 1460)
$ ping 10.8.0.1 -M do -s 1432
PING 10.8.0.1 1432(1460) bytes of data.
1440 bytes from 10.8.0.1: icmp_seq=1 ttl=64 time=201 ms

And then I put a corresponding value under tun-mtu in the config for openvpn.

Offline

Board footer

Powered by FluxBB