You are not logged in.

#1 2012-10-25 07:26:41

mojo
Member
Registered: 2010-07-06
Posts: 5

[Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

Hi all,

Just updated nodejs to latest nodejs-0.8.12-2 - the one that requires v8 as a separate pkg. (update was part of a pacman -Syu)

architecture: x86_64
nodejs-0.8.12-2-x86_64.pkg.tar.xz
v8-3.14.0-1-x86_64.pkg.tar.xz


Installing any node module with npm results in a segmentation fault. eg:

$ npm install buffet
npm http GET https://registry.npmjs.org/buffet
npm http 304 https://registry.npmjs.org/buffet
npm http GET https://registry.npmjs.org/buffet/-/buffet-0.4.6.tgz
Segmentation fault


Downgraded to previous (nodejs 0.8.12-1) pkg as a functional workaround.

EDIT: Have reported in the arch bugtracker.

Last edited by mojo (2012-10-29 12:51:08)

Offline

#2 2012-10-25 17:34:55

Barthalion
Developer
From: Poland
Registered: 2010-02-26
Posts: 109

Re: [Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

And I've assigned your bug report to myself. (I've no idea why I didn't test npm before pushing new packages, sorry.)


Arch Linux - rolling release distro, which users want to downgrade to the previous version

Offline

#3 2012-10-25 23:24:49

adelgado
Member
Registered: 2009-07-17
Posts: 12

Re: [Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

Since this package is on the table, I'd also like to point out that nodejs-0.8.12-1 is incompatible with nodemon.

I'm only saying this as not to simply revert back.

Cheers

Offline

#4 2012-10-26 16:59:03

alessandro1997
Member
From: Rome, Italy
Registered: 2012-04-27
Posts: 1
Website

Re: [Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

Hi,

I'm having this issue as well. If I can contribute somehow let me know.

Thank you.

Offline

#5 2012-10-26 20:59:12

mojo
Member
Registered: 2010-07-06
Posts: 5

Re: [Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

@Barthalion: No worries, mate. It happens. Thanks for maintaining the package!

Offline

#6 2012-10-27 13:13:25

reztho
Member
Registered: 2007-12-16
Posts: 31

Re: [Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

@Barthalion: I was goint to add a comment to the bug tracker when I saw you actually fixed it. I actually commented the shared v8 lines too, so that's why it worked. So thanks.

Last edited by reztho (2012-10-27 13:13:41)

Offline

#7 2012-10-27 13:18:49

Barthalion
Developer
From: Poland
Registered: 2010-02-26
Posts: 109

Re: [Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

It'll take some time before I push updated package to repo as sigurd is down.

Thanks for your patience. smile

Last edited by Barthalion (2012-10-27 13:18:57)


Arch Linux - rolling release distro, which users want to downgrade to the previous version

Offline

#8 2012-10-29 12:49:59

mojo
Member
Registered: 2010-07-06
Posts: 5

Re: [Solved] nodejs-0.8.12-2 and v8, npm install results in segfault

Looks like it's been resolved (v0.8.14-1). Thanks Barthalion!

Last edited by mojo (2012-10-29 12:51:48)

Offline

Board footer

Powered by FluxBB