You are not logged in.

#26 2012-10-27 05:18:21

attila1964
Member
From: Esztergom / Hungary
Registered: 2011-10-23
Posts: 30

Re: fast tsc calibration failed after upgrade to linux 3.6

I upgraded to the newest systemd, but the same failure...

Offline

#27 2012-10-27 15:16:41

Invie
Member
From: Carnage, Destruction USA
Registered: 2012-09-08
Posts: 70

Re: fast tsc calibration failed after upgrade to linux 3.6

rasertux wrote:

I have the same error and i use Arch x86_64...

tsc: Fast TSC calibration failed

[drm:intel_panel_setup_backlight] *ERROR* Failed to get maximum backlight value

the 2 errors apears after i update the kernel to 3.6.2...

At this point, I've also upgraded my kernel as well as systemd. It was found that gnome would load the first time after reinstalling the latest ISO I had, but after that point, it was no good.

Beyond this, my screen does not allow me to see the actual loading to catch a long enough glimpse at the message printed above but I think it was accurate.

Gdm begins to load but then fails to, taking me back to the getty prompt for login. I've already tried ctrl+alt+f{1..12}.

I have to startx in order to use my computer, which is a pain. Can't even use KDE.

I have a 32-bit architexture.

[root@arch ~]# uname -r
3.6.3-1-ARCH

Last edited by Invie (2012-10-27 15:18:25)


Just living is not enough... one must have sunshine, freedom, and a little flower.  ~Hans Christian Andersen

Offline

#28 2012-10-29 22:13:52

sqlpython
Member
Registered: 2012-08-20
Posts: 9

Re: fast tsc calibration failed after upgrade to linux 3.6

Post #25
I also get the error "Fast TSC calibration failed" on the screen after upgrading to linux 3.6

Just upgraded 4 packages and the Error message is now gone..

NowThe message is back
But I received and updated/upgraded these packages..
Rebooted and the error message on Reboot went away....

[2012-10-29 17:51] upgraded glibc (2.16.0-4 -> 2.16.0-5)
[2012-10-29 17:51] upgraded binutils (2.22-10 -> 2.23-1)
[2012-10-29 17:51] upgraded gcc-libs (4.7.2-1 -> 4.7.2-2)
[2012-10-29 17:51] upgraded gcc (4.7.2-1 -> 4.7.2-2)
[2012-10-29 17:51] upgraded hwids (20121012-1 -> 20121022-1)
[2012-10-29 17:51] upgraded nspr (4.9.2-1 -> 4.9.3-1)
[2012-10-29 17:51] upgraded nss (3.13.6-1 -> 3.14-1)
[2012-10-29 17:51] upgraded syslinux (4.05-7 -> 4.06-1)
[2012-10-29 17:52] upgraded thunderbird (16.0.1-1 -> 16.0.2-1)
[2012-10-29 17:52] upgraded util-linux (2.22.1-1 -> 2.22.1-2)

  Just adding to the Database of info...
Not looking for support.
As I am from the Unholy and Unwashed hoards......
I once again Lowered my gaze and did not look directly upon the Arch as I posted..

Offline

#29 2012-11-04 05:25:50

cdteo
Member
Registered: 2008-11-20
Posts: 4

Re: fast tsc calibration failed after upgrade to linux 3.6

Offline

#30 2012-11-04 11:51:11

pouar
Member
Registered: 2011-11-03
Posts: 54
Website

Re: fast tsc calibration failed after upgrade to linux 3.6

no effect on my machine


Yep, I'm a diaperfur now, I guess

while :;do if windows sucks;then mv windows /dev/null;pacman -Sy linux;fi;done
for i in {\ metal,core,grind};do echo death$i rules\!;done

Offline

#31 2012-11-04 12:36:53

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: fast tsc calibration failed after upgrade to linux 3.6

I've been gettging those TSC messages on both my Arch installations forever. One is 686 (in Virtual Box on a Mac Pro 1,1); the other is 64-bit on a Zotac id41 (Intel Atom D525). This is what the journal in the Zotac tells me:

Nov 04 07:04:04 disney kernel: TSC synchronization [CPU#0 -> CPU#1]:
Nov 04 07:04:04 disney kernel: Measured 54 cycles TSC warp between CPUs, turning off TSC clock.
Nov 04 07:04:04 disney kernel: tsc: Marking TSC unstable due to check_tsc_sync_source failed
Nov 04 07:04:04 disney kernel: Disabled fast string operations
Nov 04 07:04:04 disney kernel:  #2 #3 OK
Nov 04 07:04:04 disney kernel: Disabled fast string operations
Nov 04 07:04:04 disney kernel: Brought up 4 CPUs

And this is what the 686 VM has to say:

Nov 04 06:47:45 kurosawa kernel: tsc: Fast TSC calibration failed
Nov 04 06:47:45 kurosawa kernel: tsc: Unable to calibrate against PIT
Nov 04 06:47:45 kurosawa kernel: tsc: using PMTIMER reference calibration
Nov 04 06:47:45 kurosawa kernel: tsc: Detected 2666.440 MHz processor

FWIW. I just ignore this stuff. I've searched around and I know that it might be overzealous reporting. Or not. The Zotac actually might have a real problem; I've googled it and it's beyond my ken.

Offline

#32 2012-11-12 04:52:26

stredini
Member
Registered: 2012-06-19
Posts: 4

Re: fast tsc calibration failed after upgrade to linux 3.6

Thank you cdteo working for me too smile

Last edited by stredini (2012-11-12 04:54:42)

Offline

#33 2012-11-13 05:52:02

cdteo
Member
Registered: 2008-11-20
Posts: 4

Re: fast tsc calibration failed after upgrade to linux 3.6

You're welcome stredini.

Offline

#34 2012-12-23 18:39:01

Joel
Member
From: Tijuana, BC, México
Registered: 2011-12-21
Posts: 85

Re: fast tsc calibration failed after upgrade to linux 3.6

Seems that helped me too, thanks smile

Linux Superman 3.6.10-1-ARCH #1 SMP PREEMPT Tue Dec 11 10:19:36 CET 2012 i686 GNU/Linux

* PC: Intel Core 2 DUO E6550 @ 2.33 GHz with 2 GB RAM: Archlinux-i686 with xfce4.
* Laptop: Intel Core 2 DUO T6600 @ 2.20 GHz with 4 GB RAM: Archlinux-x86-64 with xfce4.
* AUR contributor.

Offline

#35 2012-12-26 01:05:17

Thme
Member
From: Raleigh NC
Registered: 2012-01-22
Posts: 93

Re: fast tsc calibration failed after upgrade to linux 3.6

Ok here's what I've found to explain this. First it isn't really an issue as the kernel is only letting you know that the Its first try to set TSC failed. It just resorts to another method. The message Is harmless and trivial about what level to print it at. Adding "clocksource=apci_pm" near the beginning of "GRUB_CMDLINE_LINUX_DEFAULT=" just tells it directly to use an acpi based motherboards power management timer.
if "clocksource=acpi_pm" fails for some reason try "clocksource=hpet"...(may work) or check here to see if there are other options:

cat /sys/devices/system/clocksource/clocksource0/available_clocksource

The following links may help explain what all this means:
http://stackoverflow.com/questions/7987 … lements-it
https://patchwork.kernel.org/patch/1508791/
This may be considered solved but I'm not the one to call it. Hopefully this helps others understand what's really happening. Systemd to my knowledge doesn't have anything to do with this as it's printed pre-init in early kernel space. It may also matter how early in Grub's kernel command line "clocksource=" is added too.

Last edited by Thme (2012-12-26 01:10:17)


"You are like people in a dark room waiting for someone to turn the light on for you instead of groping around in the dark and turning it on for yourself." -J. Krishnamurti at age 19, to his students-
www.jkrishnamurti.org

Offline

Board footer

Powered by FluxBB