You are not logged in.

#1 2012-10-17 08:05:21

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

2012.10-1 archboot "2k12-R4" ISO hybrid images released

Hi Arch community,

Arch Linux (archboot creation tool) 2012.10-1, "2k12-R4" has been released.

Homepage and for more information on archboot:
http://wiki.archlinux.org/index.php/Archboot

Summary:
- major update/cleanup on all components

Hybrid image files and torrents are provided, which include
i686 and/or x86_64 core repository. Please check md5sum before using it.

Hybrid image file is a standard CD-burnable image and also a raw disk image.
    - Can be burned to CD(RW) media using most CD-burning utilities.
    - Can be raw-written to a drive using 'dd' or similar utilities.
      This method is intended for use with USB thumb drives.

Please get it from your favorite arch linux mirror:
https://downloads.archlinux.de/iso/archboot/2012.10/
<yourmirror>/iso/archboot/2012.10/

/boot for PXE/Rescue files are provided here:
https://downloads.archlinux.de/iso/arch … 12.10/boot
<yourmirror>/iso/archboot/2012.10/boot

Changelog:

GENERAL:
- kernel 3.6.2 / LTS kernel 3.0.46
- pacman 4.0.3 usage
- RAM recommendations: 768 MB

Kernel changes:
- bump to latest 3.6.x series and bump lts to latest 3.0.x series

Environment changes:
- changed UEFI booting on USB media to use gummiboot with EFISTUB,
  for booting LTS kernels in UEFI use efilinux-efi
- Removal of UEFI CD booting support (only UEFI USB is supported)
- added grub's iso loopback support
  (below for example):
  iso_loop_dev=UUID=XXXX
  iso_loop_path=/blah/archboot.iso
- added memdisk boot support (only in BIOS mode)
- change to zsh as default shell
- change to systemd live environment
- replace binaries with corresponding symlinks, saves 40MB RAM
- synced with latest mkinitcpio changes
- replaced cpufreq with cpupower
- generate enough entropy for pacman with haveged during boot
- login with agetty autologin
- added arch-install-scripts, arch-wiki-lite, gpg-agent, grub(2), xl2tpd,
  usb_modeswitch, wvdial, amd and intel ucode,
  refind-efi, efilinux-efi and gummiboot-efi to live environment
- updated mirrorlist
- added memdisk support
- removed grub legacy
- removed rtc hook

setup changes:
- HIGHLIGHT:
  new network setup with netcfg
  now supports wifi and lan setup
- added checkspace before install packages
- use new crypttab syntax
- added 1MB gap on autoprepare between partitions,
  to avoid mdadm issues
- added grub loopback and memdisk mount support
- added refind-efi, gummiboot-efi and efilinux-efi support
- fixed unmounting of partitions on deeper locations
- fixed check on virtio media
- update to new config file layout
  in order to respect the rc.conf cleanup
- hide kernel messages during mounting
- hide parted errors during checks
- added PARTUUID and PARTLABEL support
- added option to copy pacman entropy to installed system
- added initscripts/systemd switch (default: systemd installation)
- more systemd fixes
- removed grub legacy
- fix permission on /sys and /proc during installation

quickinst changes:
- remove bootloader information
- added checkspace before install packages
- added initscripts/systemd switch (default: systemd installation)
- fix permission on /sys and /proc during installation

Further documentation can be found on-disk and on the wiki.
Thanks to all beta testers, which reported bugs during this development period.
Have fun!

greetings
tpowa

Last edited by tpowa (2012-10-17 10:24:12)

Offline

#2 2012-10-17 10:03:01

MaNNa
Member
Registered: 2012-07-05
Posts: 13

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Great news tpowa!

Have been waiting for this one as it has all the latest fixes, and especially systemd!

Much appreciate all the excellent hard work you and the team have put into this.

Thank you!


In God's love,
†MaNNa <{{{><  ...to You all thanks and glory Lord Yeshua!

And Jesus prayed to The Father, "And this is the way to eternal life - to know You, the Only True God, and Jesus Christ the One You sent to earth.

Offline

#3 2012-10-18 11:13:19

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Thank you for your hard work.

I reinstalled my server about two months ago with 2012.08-beta and I chose to use btrfs for / and /home, but after one month, the system complained it had run out of hard disk - I asked around on the forum, but I didn't find a solution. So for the past month I have been looking for some time to reinstall again, using ext4 this time.

Yesterday I tried twice with the 2012.09-beta, but both times I ended up with an unbootable system: systemd complained about missing dependencies, dropped me into a recovery shell but would not recognize any keyboard input. That's when I saw there was a new version of the installer available.

About 10 minutes later I logged in on the new install. Flawless install using eth0/dhclient, ntpdate, GPT, auto-prepare for the HD, ext4, systemd, (only) base packages, grub(2)-bios. The only warning I got was that grub couldn't find a certain .img, but that was before the install of grub, so it is probably harmless noise.

I have lost a lot of (precious) time yesterday, but it is nothing compared to the time you devs spend over and over again to get it all working. Thank you for that!

Vincent
PS, it might still be relevant because I didn't check with 2012.10, but using the 2012.09-beta, I noticed that the mount options I specified for all of my mountpoints (discard, relatime), was used as the label for that device, and thus formatting that device failed every time. Auto-prepare worked like a charm.

Last edited by zenlord (2012-10-18 11:13:53)

Offline

#4 2012-10-18 12:59:55

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

zenlord wrote:

PS, it might still be relevant because I didn't check with 2012.10, but using the 2012.09-beta, I noticed that the mount options I specified for all of my mountpoints (discard, relatime), was used as the label for that device, and thus formatting that device failed every time. Auto-prepare worked like a charm.

Where did you specify the mount options? I don't think setup asks for them. It asks for options for the creation tool.

Offline

#5 2012-10-20 17:19:05

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

If for any reason UEFI CD boot support is required: Use https://gist.github.com/3924023 script

# ./archboot_uefi_cd.sh <path_to_old_ISO>

Output file will be /tmp/ARCHBOOT.iso

Offline

#6 2012-10-27 14:15:47

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 227

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Used dd to USB but UEFI mode boot option does not show up in my boot menu and non-UEFI mode boot errors out with "isolinux.bin missing or corrupt".

unetbootin does get the UEFI mode boot to show up but all I get is a blinking underline cursor in the top left of the screen. Non-UEFI mode boot seems to work just fine.

md5sum for  archlinux-2012.10-1-archboot-x86_64.iso c53c85936d4b85f7841ac48cc01f6d48 is correct.

Last edited by KairiTech (2012-10-27 14:18:42)


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#7 2012-10-27 14:55:03

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

KairiTech wrote:

Used dd to USB but UEFI mode boot option does not show up in my boot menu and non-UEFI mode boot errors out with "isolinux.bin missing or corrupt".

unetbootin does get the UEFI mode boot to show up but all I get is a blinking underline cursor in the top left of the screen. Non-UEFI mode boot seems to work just fine.

md5sum for  archlinux-2012.10-1-archboot-x86_64.iso c53c85936d4b85f7841ac48cc01f6d48 is correct.

https://wiki.archlinux.org/index.php/Un … B_from_ISO

Offline

#8 2012-10-28 03:30:25

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 227

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Worked perfectly thanks. Didn't have to change the filesystem label though.


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#9 2012-10-29 16:32:41

Heema
Member
From: Egypt
Registered: 2008-08-12
Posts: 60

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

i mounted the iso and copied it to a fat32 formatted usb

when i boot i chose uefi: usb disk

then i get an error message :  "No loader found. Configuration files in \loader\entries\*.conf are needed."


i have a ssd formatted with GPT and a UEFI motherboard

Last edited by Heema (2012-10-29 18:45:27)

Offline

#10 2012-11-10 14:48:23

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

All UEFI users with gummiboot "No loader found. Configuration files in \loader\entries\*.conf are needed." issues, use rEFInd instead.

1. Install "refind-efi" pkg.

2. Replace existing (USB)/EFI/boot/bootx64.efi with /usr/lib/refind/refind_x64.efi

3. Create (USB)/EFI/boot/refind.conf with the following contents

timeout 5

textonly

resolution 1024 768

showtools about,reboot,shutdown,exit

scan_driver_dirs EFI/tools/drivers_x64

scanfor manual,internal,external,optical

scan_delay 1

#also_scan_dirs boot

dont_scan_dirs EFI/boot

#scan_all_linux_kernels

max_tags 0

default_selection "Arch Linux x86_64 Archboot"

menuentry "Arch Linux x86_64 Archboot" {
	icon /EFI/refind/icons/os_arch.icns
	loader /boot/vmlinuz_x86_64
	initrd /boot/initramfs_x86_64.img
	ostype Linux
	graphics off
	options "gpt loglevel=7 add_efi_memmap none=UEFI_ARCH_x86_64"
}

menuentry "Arch Linux LTS x86_64 Archboot via EFILINUX" {
	icon /EFI/refind/icons/os_arch.icns
	loader /EFI/efilinux/efilinuxx64.efi
	initrd /boot/initramfs_x86_64.img
	ostype Linux
	graphics off
	options "-f \boot\vmlinuz_x86_64_lts gpt loglevel=7 add_efi_memmap none=UEFI_ARCH_x86_64"
}

menuentry "UEFI x86_64 Shell v2" {
	icon /EFI/refind/icons/tool_shell.icns
	loader /EFI/tools/shellx64_v2.efi
	graphics off
}

menuentry "UEFI x86_64 Shell v1" {
	icon /EFI/refind/icons/tool_shell.icns
	loader /EFI/tools/shellx64_v1.efi
	graphics off
}

and boot with that USB.

Last edited by the.ridikulus.rat (2013-02-02 03:18:51)

Offline

#11 2012-11-10 14:58:02

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

tpowa: Patch to replace gummiboot-efi with refind-efi in Archboot : https://gist.github.com/1080899 .

Offline

#12 2012-11-14 15:34:27

bergqvistjl
Member
Registered: 2011-01-05
Posts: 41

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

the.ridikulus.rat wrote:

All UEFI users with gummiboot "No loader found. Configuration files in \loader\entries\*.conf are needed." issues, use rEFInd instead.

1. Install extra/refind-efi 0.4.7-2 or above package

2. Replace existing (USB)/EFI/boot/bootx64.efi with /usr/lib/refind/refindx64.efi

3. Create (USB)/EFI/boot/refind.conf with the following contents

timeout 5

hideui singleuser

textonly
#resolution 1024 768

use_graphics_for osx

showtools about,reboot,shutdown,exit

scan_driver_dirs EFI/tools/drivers_x64

scanfor manual,internal,external,optical

scan_delay 1

#also_scan_dirs boot

dont_scan_dirs EFI/boot

#scan_all_linux_kernels

max_tags 0

default_selection "Arch Linux x86_64 Archboot"

menuentry "Arch Linux x86_64 Archboot" {
	icon /EFI/refind/icons/os_arch.icns
	loader /boot/vmlinuz_x86_64
	initrd /boot/initramfs_x86_64.img
	ostype Linux
	graphics off
	options "gpt loglevel=7 pci=nocrs add_efi_memmap none=UEFI_ARCH_x86_64"
}

menuentry "Arch Linux LTS x86_64 Archboot via EFILINUX" {
	icon /EFI/refind/icons/os_arch.icns
	loader /EFI/efilinux/efilinuxx64.efi
	initrd /boot/initramfs_x86_64.img
	ostype Linux
	graphics off
	options "-f \boot\vmlinuz_x86_64_lts gpt loglevel=7 pci=nocrs add_efi_memmap none=UEFI_ARCH_x86_64"
}

menuentry "UEFI x86_64 Shell v2" {
	icon /EFI/refind/icons/tool_shell.icns
	loader /EFI/tools/shellx64_v2.efi
	graphics off
}

menuentry "UEFI x86_64 Shell v1" {
	icon /EFI/refind/icons/tool_shell.icns
	loader /EFI/tools/shellx64_v1.efi
	graphics off
}

and boot with that USB.

EDIT: The menu text in refind-efi 0.4.7-2 will be right aligned. That is due to a minor string formatting issue in rEFInd source which has been fixed in upstream git repo. Anyway this does not affect the working of refindx64.efi .

This doesnt work for me, when i select any of the options in rEFInd, i just get "can't load vmlinux... not found" errors. I adjusted the paths in the menu options in the conf file correctly (so it says /arch/boot/initramfs_x86_64.img instead of /boot/initramfs_x86_64.img) but that didn't make any difference? Do you have any ideas cos i'm tearing my hair out here.

Offline

#13 2012-11-26 12:32:23

lord_rel
Member
Registered: 2007-04-04
Posts: 29

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

after testing the iso in virtualbox and on a physical machine

i seem to be getting a grub error after install

error: disk `hostdisk//dev/sda,msdos1' not found.
error: you need to load the kernel first.

while easily fixed by changing to hd0,msdos1 it should be fixed

Last edited by lord_rel (2012-11-27 08:33:12)

Offline

#14 2013-01-19 23:37:58

Guest One
Member
Registered: 2013-01-19
Posts: 4

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Hi,

is this project still active or not?

Offline

#15 2013-01-20 08:32:17

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Sure why you ask?

Offline

#16 2013-01-20 13:26:12

Guest One
Member
Registered: 2013-01-19
Posts: 4

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Just because i don't like the new Arch install way.
Thanks!

Offline

#17 2013-02-02 01:59:28

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

the.ridikulus.rat wrote:

All UEFI users with gummiboot "No loader found. Configuration files in \loader\entries\*.conf are needed." issues, use rEFInd instead.

1. Install extra/refind-efi 0.4.7-2 or above package

2. Replace existing (USB)/EFI/boot/bootx64.efi with /usr/lib/refind/refindx64.efi

3. Create (USB)/EFI/boot/refind.conf with the following contents

timeout 5

hideui singleuser

textonly
#resolution 1024 768

use_graphics_for osx

showtools about,reboot,shutdown,exit

scan_driver_dirs EFI/tools/drivers_x64

scanfor manual,internal,external,optical

scan_delay 1

#also_scan_dirs boot

dont_scan_dirs EFI/boot

#scan_all_linux_kernels

max_tags 0

default_selection "Arch Linux x86_64 Archboot"

menuentry "Arch Linux x86_64 Archboot" {
	icon /EFI/refind/icons/os_arch.icns
	loader /boot/vmlinuz_x86_64
	initrd /boot/initramfs_x86_64.img
	ostype Linux
	graphics off
	options "gpt loglevel=7 pci=nocrs add_efi_memmap none=UEFI_ARCH_x86_64"
}

menuentry "Arch Linux LTS x86_64 Archboot via EFILINUX" {
	icon /EFI/refind/icons/os_arch.icns
	loader /EFI/efilinux/efilinuxx64.efi
	initrd /boot/initramfs_x86_64.img
	ostype Linux
	graphics off
	options "-f \boot\vmlinuz_x86_64_lts gpt loglevel=7 pci=nocrs add_efi_memmap none=UEFI_ARCH_x86_64"
}

menuentry "UEFI x86_64 Shell v2" {
	icon /EFI/refind/icons/tool_shell.icns
	loader /EFI/tools/shellx64_v2.efi
	graphics off
}

menuentry "UEFI x86_64 Shell v1" {
	icon /EFI/refind/icons/tool_shell.icns
	loader /EFI/tools/shellx64_v1.efi
	graphics off
}

and boot with that USB.

EDIT: The menu text in refind-efi 0.4.7-2 will be right aligned. That is due to a minor string formatting issue in rEFInd source which has been fixed in upstream git repo. Anyway this does not affect the working of refindx64.efi .



I downloaded refined-efi, but when I tried to replace existing (USB)/EFI/boot/bootx64.efi with /usr/lib/refind/refindx64.efi (I ran

cp /usr/lib/refind/refindx64.efi sdb/EFI/boot/boot.64.efi

) I got the error:

cp: cannot stat /ur/lib/refind/refindx64.efi: no such file or directory

Last edited by AlecB (2013-02-02 02:03:37)


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#18 2013-02-02 03:15:38

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

AlecB wrote:

I downloaded refined-efi, but when I tried to replace existing (USB)/EFI/boot/bootx64.efi with /usr/lib/refind/refindx64.efi (I ran

cp /usr/lib/refind/refindx64.efi sdb/EFI/boot/boot.64.efi

) I got the error:

cp: cannot stat /ur/lib/refind/refindx64.efi: no such file or directory

The /usr/lib/refind/refindx64.efi has been renamed to /usr/lib/refind/refind_x64.efi in recent refind-efi pkgs to match the upstream binary filenames.

Offline

#19 2013-02-02 03:39:58

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Now I get :

cp: accessing  /dev/sdb/EFI/boot/boot.64.efi: no such file or directory

I think my usb is at stb. Thanks for the help.


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#20 2013-02-13 13:52:53

Guest One
Member
Registered: 2013-01-19
Posts: 4

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

Any plan to release a new iso in the near future?

Offline

#21 2013-02-18 09:10:33

mianka
Member
From: BE LEUVEN
Registered: 2006-05-30
Posts: 208

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

I just installed archboot (latest edition) on a 27" dual-core Intel Imac.The installation worked perfectly. When I start Arch starts running, messages fly by on the screen and then the screen turns black and the computer continues loading linux.

I can log in do pings, do pacman -Syu it all works but I am flying blind, I see just a black screen. I searched the wiki,forum and the general internet but all blackscreen occurrences seem during startup.

Anyone seen this before and/or found a solution?

It has a ATI 4670 graphic chip.


addendum & SOLVED

see http://community.linuxmint.com/tutorial/view/842

It now works like a doddle.

Thank you!

Last edited by mianka (2013-02-19 21:50:10)

Offline

#22 2013-03-20 17:18:42

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,322
Website

Re: 2012.10-1 archboot "2k12-R4" ISO hybrid images released

New ISO released: closing


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB