You are not logged in.

#1 2012-03-18 13:27:49

arys
Member
Registered: 2012-02-02
Posts: 5

Laptop-Mode messes up Wifi

My Laptop is a Lenovo Edge E320 with a Intel Centrino Wireless-N 1000. My wifi was working a few months ago pretty fine with laptop-mode-tools enabled, but since a system upgrade about 3 months ago I can't connect to anything if I have laptop-mode-tools enabled and run on battery. I even turned off power management in /etc/laptop-mode/conf.d/wireless*, but the problem is still present.
iwconfig reports nothing unusual, setting txpower manually to max doesn't help. However, with power management disabled I get a few networks, with lower signals than the one I want to connect to (again, txpower at max). Reloading the driver via rmmod iwlwifi; modprobe iwlwifi 11n_disable=1 swcrypto=1 works, although it's an unnecessary effort to do this every time I want to use my laptop with laptop-mode.
Any ideas?

Additional info:
dmesg | grep iwlwifi

[    7.574104] iwlwifi 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    7.574114] iwlwifi 0000:02:00.0: setting latency timer to 64
[    7.574177] iwlwifi 0000:02:00.0: pci_resource_len = 0x00002000
[    7.574179] iwlwifi 0000:02:00.0: pci_resource_base = ffffc90005b60000
[    7.574181] iwlwifi 0000:02:00.0: HW Revision ID = 0x0
[    7.574271] iwlwifi 0000:02:00.0: irq 41 for MSI/MSI-X
[    7.574308] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[    7.574373] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    7.595753] iwlwifi 0000:02:00.0: device EEPROM VER=0x15d, CALIB=0x6
[    7.595755] iwlwifi 0000:02:00.0: Device SKU: 0X50
[    7.595756] iwlwifi 0000:02:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[    7.595764] iwlwifi 0000:02:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[    7.848327] iwlwifi 0000:02:00.0: loaded firmware version 39.31.5.1 build 35138
[   15.217495] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[   15.278254] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[   24.468691] iwlwifi 0000:02:00.0: Error sending POWER_TABLE_CMD: time out after 2000ms.
[   24.468702] iwlwifi 0000:02:00.0: Current CMD queue read_ptr 24 write_ptr 25
[   24.468709] iwlwifi 0000:02:00.0: set power fail, ret = -110
[   38.101889] iwlwifi 0000:02:00.0: Error sending REPLY_SCAN_CMD: time out after 2000ms.
[   38.101909] iwlwifi 0000:02:00.0: Current CMD queue read_ptr 24 write_ptr 26
[   68.060549] iwlwifi 0000:02:00.0: Error sending REPLY_SCAN_CMD: time out after 2000ms.
[   68.060565] iwlwifi 0000:02:00.0: Current CMD queue read_ptr 24 write_ptr 27

Last edited by arys (2012-03-18 14:13:27)

Offline

#2 2012-03-18 20:24:51

@op
Member
Registered: 2011-04-05
Posts: 49

Re: Laptop-Mode messes up Wifi

Hi arys,

I've got quite the same problem here and it seems to be a known issue. There are several bug reports open and especially this one looks promising
http://bugzilla.intellinuxwireless.org/ … gi?id=2315
Let's hope for a solution in near future.

Offline

#3 2012-05-03 09:26:52

shakabra
Member
Registered: 2012-05-03
Posts: 1

Re: Laptop-Mode messes up Wifi

I've had the same problem. In the /etc/laptop-mode/conf.d/wireless-iwl-power.conf I changed the default setting:

 IWL_BATT_POWER=3 

to this:

IWL_BATT_POWER=2

Everything works fine now. Before the change I had a 40% packet loss while on AC pinging my own router. Now it's perfect and good battery still too.

Offline

#4 2012-10-20 18:16:31

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

Noticed the same problem on Thinkpad X230, except in my case iwlwifi module crashes with the below kernel log. Stopping laptop-mode service altogether fixes it -- disabling wireless-* part of laptop-mode however does not.
Gonna try to change IWL_BATT_POWER and will report back how it goes.

It did start happening after last kernel upgrade, likely!

Oct 20 08:46:27 localhost kernel: [ 1452.045321] ------------[ cut here ]------------
Oct 20 08:46:27 localhost kernel: [ 1452.045341] WARNING: at drivers/net/wireless/iwlwifi/iwl-io.c:127 iwl_grab_nic_access+0x7f/0xf0 [iwlwifi]()
Oct 20 08:46:27 localhost kernel: [ 1452.045343] Hardware name: 2306CTO
Oct 20 08:46:27 localhost kernel: [ 1452.045345] Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
Oct 20 08:46:27 localhost kernel: [ 1452.045347] Modules linked in: sha1_ssse3 sha1_generic ecb ppp_mppe ppp_async crc_ccitt ppp_generic slhc fuse iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi snd_hda_codec_realtek btusb bl
uetooth arc4 microcode aesni_intel aes_x86_64 aes_generic uvcvideo ghash_clmulni_intel cryptd videobuf2_vmalloc videobuf2_memops kvm_intel videobuf2_core videodev kvm media coretemp crc32c_intel iwlwifi sdhci_pci sdhci thinkp
ad_acpi mmc_core lpc_ich mac80211 serio_raw snd_hda_intel mfd_core pcspkr psmouse i2c_i801 snd_hda_codec snd_hwdep snd_pcm nvram cfg80211 snd_page_alloc e1000e rfkill snd_timer tpm_tis snd mei soundcore ac tpm battery tpm_bio
s evdev wmi cpufreq_userspace cpufreq_powersave thermal acpi_cpufreq mperf processor ext4 crc16 jbd2 mbcache sd_mod ahci libahci xhci_hcd ehci_hcd libata scsi_mod usbcore usb_common i915 video button i2c_algo_bit intel_agp in
tel_gtt drm_kms_helper drm i2c_core
Oct 20 08:46:27 localhost kernel: [ 1452.045426] Pid: 0, comm: swapper/2 Not tainted 3.5.6-1-ARCH #1
Oct 20 08:46:27 localhost kernel: [ 1452.045428] Call Trace:
Oct 20 08:46:27 localhost kernel: [ 1452.045430]  <IRQ>  [<ffffffff81051a3f>] warn_slowpath_common+0x7f/0xc0
Oct 20 08:46:27 localhost kernel: [ 1452.045442]  [<ffffffff81051b36>] warn_slowpath_fmt+0x46/0x50
Oct 20 08:46:27 localhost kernel: [ 1452.045453]  [<ffffffffa046db68>] ? iwl_grab_nic_access_silent+0x188/0x200 [iwlwifi]
Oct 20 08:46:27 localhost kernel: [ 1452.045462]  [<ffffffffa046dc5f>] iwl_grab_nic_access+0x7f/0xf0 [iwlwifi]
Oct 20 08:46:27 localhost kernel: [ 1452.045470]  [<ffffffffa046e0db>] iwl_read_prph+0x3b/0x180 [iwlwifi]
Oct 20 08:46:27 localhost kernel: [ 1452.045476]  [<ffffffff8108ed7c>] ? trigger_load_balance+0x6c/0x270
Oct 20 08:46:27 localhost kernel: [ 1452.045485]  [<ffffffffa047fc9e>] iwl_trans_pcie_queue_stuck_timer+0xbe/0x180 [iwlwifi]
Oct 20 08:46:27 localhost kernel: [ 1452.045493]  [<ffffffffa047fbe0>] ? iwl_trans_rxq_free_rx_bufs+0xf0/0xf0 [iwlwifi]
Oct 20 08:46:27 localhost kernel: [ 1452.045498]  [<ffffffff810621c5>] run_timer_softirq+0x135/0x3c0
Oct 20 08:46:27 localhost kernel: [ 1452.045503]  [<ffffffff8101b9d9>] ? read_tsc+0x9/0x20
Oct 20 08:46:27 localhost kernel: [ 1452.045509]  [<ffffffff8105a490>] __do_softirq+0xb0/0x210
Oct 20 08:46:27 localhost kernel: [ 1452.045513]  [<ffffffff810a88b4>] ? tick_program_event+0x24/0x30
Oct 20 08:46:27 localhost kernel: [ 1452.045519]  [<ffffffff8148ab5c>] call_softirq+0x1c/0x30
Oct 20 08:46:27 localhost kernel: [ 1452.045524]  [<ffffffff81016565>] do_softirq+0x65/0xa0
Oct 20 08:46:27 localhost kernel: [ 1452.045529]  [<ffffffff8105a916>] irq_exit+0x96/0xc0
Oct 20 08:46:27 localhost kernel: [ 1452.045534]  [<ffffffff8148b49e>] smp_apic_timer_interrupt+0x6e/0x99
Oct 20 08:46:27 localhost kernel: [ 1452.045538]  [<ffffffff8148a20a>] apic_timer_interrupt+0x6a/0x70
Oct 20 08:46:27 localhost kernel: [ 1452.045540]  <EOI>  [<ffffffffa017030c>] ? acpi_idle_enter_bm+0x287/0x2cb [processor]
Oct 20 08:46:27 localhost kernel: [ 1452.045557]  [<ffffffffa0170305>] ? acpi_idle_enter_bm+0x280/0x2cb [processor]
Oct 20 08:46:27 localhost kernel: [ 1452.045564]  [<ffffffff81355549>] cpuidle_enter+0x19/0x20
Oct 20 08:46:27 localhost kernel: [ 1452.045568]  [<ffffffff81355b96>] cpuidle_idle_call+0xa6/0x330
Oct 20 08:46:27 localhost kernel: [ 1452.045572]  [<ffffffff8101decf>] cpu_idle+0xbf/0x130
Oct 20 08:46:27 localhost kernel: [ 1452.045578]  [<ffffffff8147070d>] start_secondary+0x203/0x20a
Oct 20 08:46:27 localhost kernel: [ 1452.045582] ---[ end trace 3f6ee7966c4895b9 ]---
Oct 20 08:46:28 localhost dhcpcd[1626]: wlan0: carrier lost
Oct 20 08:46:28 localhost avahi-daemon[537]: Withdrawing address record for 192.168.0.3 on wlan0.
Oct 20 08:46:28 localhost kernel: [ 1453.106041] ieee80211 phy0: >Hardware restart was requested
Oct 20 08:46:28 localhost kernel: [ 1453.106046] ------------[ cut here ]------------
Oct 20 08:46:28 localhost kernel: [ 1453.106066] WARNING: at drivers/net/wireless/iwlwifi/iwl-trans.h:565 iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]()
Oct 20 08:46:28 localhost kernel: [ 1453.106068] Hardware name: 2306CTO
Oct 20 08:46:28 localhost kernel: [ 1453.106071] iwl_trans_wait_tx_queue_empty bad state = 0
Oct 20 08:46:28 localhost kernel: [ 1453.106073] Modules linked in: sha1_ssse3 s

Last edited by bassu (2012-10-20 18:17:46)


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#5 2012-10-22 03:30:58

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

bassu wrote:

Stopping laptop-mode service altogether fixes it -- disabling wireless-* part of laptop-mode however does not.
Gonna try to change IWL_BATT_POWER and will report back how it goes.

What fixed this for me, 'options iwlwifi wd_disable=0' in /etc/modprobe.conf.  tongue
Finally no more driver crashes wink

Seems like I came across an Intel wifi driver problem coupled with the latest kernel bug!


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#6 2012-10-22 03:53:35

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Laptop-Mode messes up Wifi

@bassu, you know that zero is the default.  So you are not actually changing anything, though I am unsure of what the watchdog defaults to.  If you would like to explicitly disable the watchdog, it needs to be one.

Offline

#7 2012-10-25 05:33:09

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

WonderWoofy wrote:

@bassu, you know that zero is the default.  So you are not actually changing anything, though I am unsure of what the watchdog defaults to.  If you would like to explicitly disable the watchdog, it needs to be one.

It is indeed. That was a typo. I had it as one.

parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)

The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#8 2012-10-27 05:50:06

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

To people out there having similar problems with iwlwifi.

Update: I managed to get rid of the driver crashes by disabling watchdog. But after sometime, usually a few days (yes, I never turn off my Thinkpad, I do suspend it every day or a two), there is a crash. Errors leading up to crash are different but crashes are the same. Now tinkering on the causes; this specifically happens after during idle times when power cord is plugged in.


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#9 2012-10-27 17:17:24

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

Update: Created a bug report with Intel's bugzilla. No response so far.


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#10 2012-10-27 17:24:29

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

Update: I dug into this problem a little bit more. Disabling watchdog only delays the problem but doesn't fix it. But I have found a way to reproduce it. Engage a continuous network load for 20 minutes or so. Stop and leave the system idle for a minute or two. The moment you start the network activity again, boom, there's an irrecoverable crash. And it does NOT matter that laptop-mode is running or not! :-/

Last edited by bassu (2012-10-27 17:27:50)


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#11 2012-11-10 14:12:21

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

Update: Resolved. Been up for 3 days without recurrence. Tested with several suspensions.


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#12 2012-12-03 17:17:29

Munksgaard
Member
Registered: 2012-12-03
Posts: 7

Re: Laptop-Mode messes up Wifi

bassu wrote:

Update: Resolved. Been up for 3 days without recurrence. Tested with several suspensions.

I'm still having problems, how did you resolve it?

Heres is my crash log (and a bit of stuff from before the crash): https://gist.github.com/4196463

Offline

#13 2012-12-23 22:40:43

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: Laptop-Mode messes up Wifi

Munksgaard wrote:
bassu wrote:

Update: Resolved. Been up for 3 days without recurrence. Tested with several suspensions.

I'm still having problems, how did you resolve it?

Heres is my crash log (and a bit of stuff from before the crash): https://gist.github.com/4196463

Switch to "linux-ck" kernel. Install it through AUR (there's also a detailed wiki on it) and report back if you continue to encounter the same crash.
Also, drop laptop-mode and use "powerdown" instead. It is quite simplistic and easy to use.


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#14 2013-01-13 17:25:14

Munksgaard
Member
Registered: 2012-12-03
Posts: 7

Re: Laptop-Mode messes up Wifi

bassu wrote:
Munksgaard wrote:
bassu wrote:

Update: Resolved. Been up for 3 days without recurrence. Tested with several suspensions.

I'm still having problems, how did you resolve it?

Heres is my crash log (and a bit of stuff from before the crash): https://gist.github.com/4196463

Switch to "linux-ck" kernel. Install it through AUR (there's also a detailed wiki on it) and report back if you continue to encounter the same crash.
Also, drop laptop-mode and use "powerdown" instead. It is quite simplistic and easy to use.

Hey, thanks for the reply, but it didn't solve my problem sad I still get the same errors.

Offline

#15 2013-01-17 10:46:58

Munksgaard
Member
Registered: 2012-12-03
Posts: 7

Re: Laptop-Mode messes up Wifi

In fact, now now my system has started crashing with errors indicating that something has gone wrong with iwlwifi. How do i get a dump of the crash text? I don't really see any log files in /var/log, and i suspect journald is the cause?

Offline

Board footer

Powered by FluxBB