You are not logged in.

#1 2012-10-20 18:29:21

Aweather
Member
Registered: 2012-10-20
Posts: 4

[Solved] Choppy Gnome for non root users

Hi all,

My gnome windows are choppy if I drag them around and the transition animations are not smooth for non root users. Whenever I switch to root, everything is fine when I login as root and launch gnome, but whenever I use any other nonroot users, the desktop performance becomes choppy. I believe it is a configuration issue since everything is totally fine in root.

I'm quite new to linux so I'm not sure if there is anything that I'm missing.

I've tried the following with no luck.
1. create a new account so it won't get affected by previous configurations
2. reinstall gnome


My CPU is G540, with intel HD graphics 2000. I'm using xf86-video-intel as my driver.

Any thoughts would be appreciated.

Thanks
Aweather

Last edited by Aweather (2012-10-29 03:46:35)

Offline

#2 2012-10-28 17:03:29

costat
Member
Registered: 2012-10-28
Posts: 2

Re: [Solved] Choppy Gnome for non root users

Hi,

I'd like to add that I am experiencing the exact same issue on two machines.  One is using intel HD graphics 3000 and the other intel HD graphics 4000.

On a non root account gnome is too choppy to use, while logged in as root it is perfectly smooth.

If anyone has any ideas I'd greatly appreciate some help.

Offline

#3 2012-10-28 17:37:41

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: [Solved] Choppy Gnome for non root users

Did you add your user to video group? https://wiki.archlinux.org/index.php/Us … ser_groups

PS I hope you guys know that login into X as root is bad idea?

Last edited by masteryod (2012-10-28 17:40:43)

Offline

#4 2012-10-28 17:53:04

costat
Member
Registered: 2012-10-28
Posts: 2

Re: [Solved] Choppy Gnome for non root users

Well that did it.  I figured it was something simple.

And yes, I just logged in as root after finding this post to see if my issue was actually the same.

Thanks!

Offline

#5 2012-10-28 18:30:49

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [Solved] Choppy Gnome for non root users

adding your user to the video group is not a fix but a crappy workaround that may actually cause problems. There has been some discussion about this recently: https://bbs.archlinux.org/viewtopic.php?id=151561

The real problem is that your user session is not properly registered by ConsoleKit/logind. To fix this, we would have to know how you log in / start your Gnome session.

Last edited by 65kid (2012-10-28 18:32:36)

Offline

#6 2012-10-28 18:50:17

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: [Solved] Choppy Gnome for non root users

65kid wrote:

adding your user to the video group is not a fix but a crappy workaround that may actually cause problems. There has been some discussion about this recently: https://bbs.archlinux.org/viewtopic.php?id=151561

Whoa I did not know that. Aweather and costat if you're running systemd installation you should check this out. I've got two computer on pure systemd with user in groups as old wiki was suggesting (lp, video, audio, etc) and I didn't encounter any problems so far. Thanks for the heads up

Last edited by masteryod (2012-10-28 18:54:24)

Offline

#7 2012-10-28 18:50:49

Aweather
Member
Registered: 2012-10-20
Posts: 4

Re: [Solved] Choppy Gnome for non root users

65kid wrote:

adding your user to the video group is not a fix but a crappy workaround that may actually cause problems. There has been some discussion about this recently: https://bbs.archlinux.org/viewtopic.php?id=151561

The real problem is that your user session is not properly registered by ConsoleKit/logind. To fix this, we would have to know how you log in / start your Gnome session.

Thanks for the suggestion. I do not have gdm in my rcconf. I first log in without GUI and start my gnome with xinit under command line. I have exec ck-session-launch gnome-session to run gnome.

Is this the information that you are asking? Thanks!!

Offline

#8 2012-10-28 18:56:16

Šaran
Member
From: Bosnia
Registered: 2011-09-03
Posts: 407

Re: [Solved] Choppy Gnome for non root users

Thanks 65kid!

Offline

#9 2012-10-28 19:06:51

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [Solved] Choppy Gnome for non root users

Aweather wrote:
65kid wrote:

adding your user to the video group is not a fix but a crappy workaround that may actually cause problems. There has been some discussion about this recently: https://bbs.archlinux.org/viewtopic.php?id=151561

The real problem is that your user session is not properly registered by ConsoleKit/logind. To fix this, we would have to know how you log in / start your Gnome session.

Thanks for the suggestion. I do not have gdm in my rcconf. I first log in without GUI and start my gnome with xinit under command line. I have exec ck-session-launch gnome-session to run gnome.

Is this the information that you are asking? Thanks!!

Follow the instructions in the following links, meaning you have to make sure that X starts on the same tty that you log in to and you use startx (maybe xinit is the problem). I do not know if Gnome 3.4 still requires the "ck-launch-session", you may have to try. Gnome 3.6 however, which is already in [testing], afaik already uses logind instead of ConsoleKit, so you will have to remove "ck-launch-session" as soon as Gnome 3.6 hits [extra].

https://wiki.archlinux.org/index.php/Sy … emd-logind
https://wiki.archlinux.org/index.php/Start_X_at_Login

Offline

#10 2012-10-29 03:46:02

Aweather
Member
Registered: 2012-10-20
Posts: 4

Re: [Solved] Choppy Gnome for non root users

Wow thanks.

systemctl1 enable gdm did the trick.

Offline

#11 2012-10-29 03:56:39

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] Choppy Gnome for non root users

If you enable gdm, you know you are then running the xserver as root, and there are aparently some sercurity implications with this.  Granted, this is coming from someone who has set up X to run as a service, so hey, what do I know? 

As far as the groups stuff is concerned, I looked at the file that handles that uaccess stuff, and there is no indication that it actually takes care of tagging the video stuff with uaccess.  I was trying to use mplayer in the framebuffer, which worked fine before. But once I removed myself from all "unnecessary" groups, it stopped working without being root.

So read the end of that linked thread above.  As I did something to fix my framebuffer at least.  I imagine, you could simply find the proper device node and add that as well.  But like I said in the other thread, I am unsure if there are security implications with this setup.

Offline

#12 2012-10-29 04:27:19

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] Choppy Gnome for non root users

Okay, nevermind.  The first time I looked over 70-uaccess.rules, I skipped over the relevent line. 

Here it is in all its glory

# DRI video devices
SUBSYSTEM=="drm", KERNEL=="card*", TAG+="uaccess"

Offline

Board footer

Powered by FluxBB