You are not logged in.

#1 2012-10-31 11:47:28

trsk
Member
Registered: 2012-10-14
Posts: 38

Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Hi!

A few hours ago, I updated my Gnome Shell to 3.6. It was a big update:

[2012-10-31 07:55] removed libwebkit3 (1.8.3-1)
[2012-10-31 07:55] removed libwebkit (1.8.3-1)
[2012-10-31 07:55] removed pyatspi (2.4.0-1)
[2012-10-31 07:55] upgraded glib2 (2.32.4-1 -> 2.34.1-1)
[2012-10-31 07:55] upgraded atk (2.4.0-1 -> 2.6.0-1)
[2012-10-31 07:55] installed harfbuzz (0.9.5-1)
[2012-10-31 07:55] upgraded pango (1.30.1-1 -> 1.32.1-1)
[2012-10-31 07:55] upgraded polkit (0.105-1 -> 0.107-4)
[2012-10-31 07:55] upgraded colord (0.1.21-2 -> 0.1.24-1)
[2012-10-31 07:55] upgraded dconf (0.12.1-2 -> 0.14.0-1)
[2012-10-31 07:55] upgraded at-spi2-core (2.4.2-1 -> 2.6.1-1)
[2012-10-31 07:55] upgraded at-spi2-atk (2.4.0-1 -> 2.6.1-1)
[2012-10-31 07:55] upgraded gtk3 (3.4.4-1 -> 3.6.1-1)
[2012-10-31 07:55] upgraded gdl (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:55] upgraded libanjuta (3.4.4-1 -> 3.6.1-1)
[2012-10-31 07:55] upgraded vte-common (0.32.2-1 -> 0.34.1-1)
[2012-10-31 07:55] upgraded vte3 (0.32.2-1 -> 0.34.1-1)
[2012-10-31 07:55] upgraded libtasn1 (2.14-1 -> 3.0-1)
[2012-10-31 07:55] upgraded gnutls (3.1.3-1 -> 3.1.3-2)
[2012-10-31 07:55] upgraded gsettings-desktop-schemas (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:55] upgraded glib-networking (2.32.3-1 -> 2.34.0-1)
[2012-10-31 07:55] upgraded libsoup (2.38.1-1 -> 2.40.1-1)
[2012-10-31 07:55] installed gstreamer (1.0.2-1)
[2012-10-31 07:55] installed gst-plugins-base-libs (1.0.2-1)
[2012-10-31 07:56] installed webkitgtk3 (1.10.1-1)
[2012-10-31 07:56] upgraded devhelp (3.4.1-1 -> 3.6.0-2)
[2012-10-31 07:56] upgraded glade (3.12.1-1 -> 3.14.1-1)
[2012-10-31 07:56] upgraded gnome-icon-theme-symbolic (3.4.0-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded gnome-icon-theme (3.4.0-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded vala (0.16.1-1 -> 0.18.0-1)
[2012-10-31 07:56] upgraded anjuta (3.4.4-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded baobab (3.4.1-2 -> 3.6.2-1)
[2012-10-31 07:56] installed gst-plugins-base (1.0.2-1)
[2012-10-31 07:56] upgraded libgnome-keyring (3.4.1-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded libsoup-gnome (2.38.1-1 -> 2.40.1-1)
[2012-10-31 07:56] upgraded totem-plparser (3.4.2-1 -> 3.4.3-1)
[2012-10-31 07:56] upgraded libtracker-sparql (0.14.2-1 -> 0.14.3-1)
[2012-10-31 07:56] upgraded brasero (3.4.1-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded cantarell-fonts (0.0.10-1 -> 0.0.10.1-1)
[2012-10-31 07:56] installed chromaprint (0.7-1)
[2012-10-31 07:56] installed spandsp (0.0.6pre21-1)
[2012-10-31 07:56] installed gst-plugins-bad (1.0.2-1)
[2012-10-31 07:56] upgraded gdk-pixbuf2 (2.26.3-1 -> 2.26.4-1)
[2012-10-31 07:56] installed gst-plugins-good (1.0.2-1)
[2012-10-31 07:56] upgraded json-glib (0.14.2-1 -> 0.15.2-1)
[2012-10-31 07:56] upgraded clutter (1.10.6-1 -> 1.12.2-1)
[2012-10-31 07:56] upgraded clutter-gst (1.6.0-1 -> 1.9.92-1)
[2012-10-31 07:56] upgraded clutter-gtk (1.2.0-1 -> 1.4.0-1)
[2012-10-31 07:56] upgraded libgee (0.6.5-1 -> 0.6.6-1)
[2012-10-31 07:56] upgraded gnome-video-effects (0.4.0-1 -> 0.4.0-2)
[2012-10-31 07:56] upgraded libcroco (0.6.5-1 -> 0.6.8-1)
[2012-10-31 07:56] upgraded librsvg (2.36.3-1 -> 2.36.4-1)
[2012-10-31 07:56] upgraded gnome-desktop (1:3.4.2-1 -> 1:3.6.1-1)
[2012-10-31 07:56] upgraded cheese (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded e2fsprogs (1.42.5-1 -> 1.42.6-1)
[2012-10-31 07:56] upgraded ptlib (2.10.5-1 -> 2.10.7-2)
[2012-10-31 07:56] upgraded opal (3.10.5-1 -> 3.10.7-2)
[2012-10-31 07:56] upgraded ekiga (3.3.2-6 -> 3.9.90-1)
[2012-10-31 07:56] upgraded telepathy-glib (0.18.2-1 -> 0.20.0-1)
[2012-10-31 07:56] upgraded rest (0.7.12-1 -> 0.7.90-1)
[2012-10-31 07:56] installed libsecret (0.10-1)
[2012-10-31 07:56] upgraded gnome-online-accounts (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded libgweather (3.4.1-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded gcr (3.4.1-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded libgdata (0.12.0-1 -> 0.13.2-1)
[2012-10-31 07:56] upgraded evolution-data-server (3.4.4-1 -> 3.6.1-1)
[2012-10-31 07:56] installed libzeitgeist (0.3.18-3)
[2012-10-31 07:56] upgraded folks (0.6.9-2 -> 0.8.0-1)
[2012-10-31 07:56] upgraded libnice (0.1.2-1 -> 0.1.3-1)
[2012-10-31 07:56] upgraded farstream (0.1.2-1 -> 0.2.1-1)
[2012-10-31 07:56] upgraded telepathy-farstream (0.4.0-1 -> 0.6.0-1)
[2012-10-31 07:56] upgraded iptables (1.4.15-1 -> 1.4.16.2-1)
[2012-10-31 07:56] upgraded iproute2 (3.5.1-1 -> 3.6.0-2)
[2012-10-31 07:56] installed dhclient (4.2.4.1-3)
[2012-10-31 07:56] upgraded networkmanager (0.9.6.0-2 -> 0.9.6.4-1)
[2012-10-31 07:56] upgraded telepathy-mission-control (5.12.1-1 -> 5.14.0-1)
[2012-10-31 07:56] upgraded empathy (3.4.2.3-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gobject-introspection (1.32.1-2 -> 1.34.1.1-1)
[2012-10-31 07:56] upgraded libpeas (1.4.0-2 -> 1.6.1-1)
[2012-10-31 07:56] upgraded eog (3.4.3-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded eog-plugins (3.4.1-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded epiphany (3.4.3-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded evince (3.4.0-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gtkhtml4 (4.4.4-1 -> 4.6.0-1)
[2012-10-31 07:56] upgraded evolution (3.4.4-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded file-roller (3.4.2-1 -> 3.6.1.1-1)
[2012-10-31 07:56] upgraded gcalctool (6.4.2.1-1 -> 6.6.1-1)
[2012-10-31 07:56] upgraded gnome-session (3.4.2-3 -> 3.6.1-1)
[2012-10-31 07:56] upgraded pygobject-devel (3.2.2-2 -> 3.4.1.1-1)
[2012-10-31 07:56] upgraded python2-gobject (3.2.2-2 -> 3.4.1.1-1)
[2012-10-31 07:56] installed ibus (1.4.99.20121006-1)
[2012-10-31 07:56] upgraded gnome-settings-daemon (3.4.2-1 -> 3.6.1-2)
[2012-10-31 07:56] upgraded gdm (3.4.1-3 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gtksourceview3 (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded gedit (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gjs (1.32.0-2 -> 1.34.0-1)
[2012-10-31 07:56] upgraded glibmm (2.32.1-1 -> 2.34.0-1)
[2012-10-31 07:56] upgraded gnome-backgrounds (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded udisks2 (1.94.0-2 -> 2.0.0-1)
[2012-10-31 07:56] upgraded gvfs (1.12.3-3 -> 1.14.0-1)
[2012-10-31 07:56] upgraded gvfs-obexftp (1.12.3-3 -> 1.14.0-1)
[2012-10-31 07:56] upgraded gnome-bluetooth (3.4.2-1 -> 3.6.0-2)
[2012-10-31 07:56] installed colord-gtk (0.1.23-1)
[2012-10-31 07:56] upgraded gnome-color-manager (3.4.2-2 -> 3.6.0-1)
[2012-10-31 07:56] upgraded gnome-contacts (3.4.1-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gnome-menus (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded network-manager-applet (0.9.6.2-1 -> 0.9.6.4-1)
[2012-10-31 07:56] installed libpwquality (1.2.0-1)
[2012-10-31 07:56] warning: directory permissions differ on usr/share/polkit-1/rules.d/
filesystem: 700  package: 755
[2012-10-31 07:56] upgraded gnome-control-center (3.4.2-1 -> 3.6.2-1)
[2012-10-31 07:56] upgraded gnome-dictionary (3.4.0-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded gnome-disk-utility (3.4.1-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded tracker (0.14.2-1 -> 0.14.3-1)
[2012-10-31 07:56] installed libzapojit (0.0.2-1)
[2012-10-31 07:56] upgraded gnome-documents (0.4.2-1 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gnome-font-viewer (3.4.0-1 -> 3.6.0-1)
[2012-10-31 07:56] upgraded gnome-games (3.4.2-2 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gnome-keyring (3.4.1-3 -> 3.6.1-1)
[2012-10-31 07:56] upgraded gnome-nettool (3.1.1-1 -> 3.2.0-1)
[2012-10-31 07:57] upgraded gnome-packagekit (3.4.2-2 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-panel (3.4.2.1-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-power-manager (3.4.0-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded libxklavier (5.2.1-2 -> 5.3-1)
[2012-10-31 07:57] upgraded libgnomekbd (3.4.0.2-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-screensaver (3.4.4-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded gnome-screenshot (3.4.1-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-search-tool (3.4.0-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-settings-daemon-updates (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded zenity (3.4.0-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded mutter (3.4.1-2 -> 3.6.1-2)
[2012-10-31 07:57] upgraded nautilus (3.4.2-1 -> 3.6.2-1)
[2012-10-31 07:57] upgraded gnome-shell (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded gnome-system-log (3.4.1-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gtkmm3 (3.4.1-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-system-monitor (3.4.1-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-terminal (3.4.1.1-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gnome-themes-standard (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded gnome-tweak-tool (3.4.0.1-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded yelp-xsl (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded yelp (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded gnome-user-docs (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gpm (1.20.6-10 -> 1.20.7-1)
[2012-10-31 07:57] upgraded gpsd (3.6-2 -> 3.7-1)
[2012-10-31 07:57] upgraded grilo (0.1.18-1 -> 0.2.2-1)
[2012-10-31 07:57] installed libwebp (0.2.0-1)
[2012-10-31 07:57] upgraded gthumb (3.0.1-2 -> 3.1.2-1)
[2012-10-31 07:57] upgraded gucharmap (3.4.1.1-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded gvfs-afc (1.12.3-3 -> 1.14.0-1)
[2012-10-31 07:57] upgraded gvfs-smb (1.12.3-3 -> 1.14.0-1)
[2012-10-31 07:57] upgraded libpurple (2.10.6-1 -> 2.10.6-2)
[2012-10-31 07:57] installed webkitgtk2 (1.10.1-1)
[2012-10-31 07:57] upgraded mousetweaks (3.4.2-1 -> 3.6.0-1)
[2012-10-31 07:57] upgraded nautilus-open-terminal (0.19-2 -> 0.19-3)
[2012-10-31 07:57] upgraded nautilus-sendto (3.0.3-1 -> 3.6.0-1)
[2012-10-31 07:57] installed python2-atspi (2.6.0-2)
[2012-10-31 07:57] upgraded orca (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded pidgin (2.10.6-1 -> 2.10.6-2)
[2012-10-31 07:57] upgraded rhythmbox (2.97-2 -> 2.98-2)
[2012-10-31 07:57] upgraded seahorse (3.4.1-1 -> 3.6.2-1)
[2012-10-31 07:57] upgraded seahorse-nautilus (3.6.0-1 -> 3.6.1-1)
[2012-10-31 07:57] installed libmusicbrainz5 (5.0.1-1)
[2012-10-31 07:57] upgraded sushi (0.4.1-2 -> 3.6.0-1)
[2012-10-31 07:57] upgraded totem (3.4.3-1 -> 3.6.2-1)
[2012-10-31 07:57] upgraded vinagre (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded vino (3.4.2-1 -> 3.6.1-1)
[2012-10-31 07:57] upgraded xf86-input-acecad (1.5.0-3 -> 1.5.0-5)
[2012-10-31 07:57] upgraded xf86-input-aiptek (1.4.1-3 -> 1.4.1-5)
[2012-10-31 07:57] upgraded xf86-input-evdev (2.7.3-1 -> 2.7.3-2)
[2012-10-31 07:57] upgraded xf86-input-joystick (1.6.1-1 -> 1.6.1-2)
[2012-10-31 07:57] upgraded xf86-input-keyboard (1.6.2-1 -> 1.6.2-2)
[2012-10-31 07:57] upgraded xf86-input-mouse (1.8.1-1 -> 1.8.1-2)
[2012-10-31 07:57] upgraded xf86-input-vmmouse (12.9.0-1 -> 12.9.0-2)
[2012-10-31 07:57] upgraded xf86-input-void (1.4.0-3 -> 1.4.0-4)
[2012-10-31 07:57] upgraded xf86-video-intel (2.20.9-1 -> 2.20.12-1)
[2012-10-31 07:57] upgraded xorg-server-common (1.12.4-1 -> 1.13.0-3)
[2012-10-31 07:57] upgraded xorg-server (1.12.4-1 -> 1.13.0-3)
[2012-10-31 07:57] upgraded xorg-xinit (1.3.2-1 -> 1.3.2-3)
[2012-10-31 07:57] upgraded xterm (285-1 -> 286-1)
[2012-10-31 08:01] installed gavl (1.4.0-1)
[2012-10-31 08:01] installed xine-lib (1.2.2-3)
[2012-10-31 08:01] installed opencv (2.4.2-5)
[2012-10-31 08:01] installed frei0r-plugins (1.3-4)

Unfortunately, it broke multiple things: (edited 31.10.12 18:47)

1. I can't suspend or hibernate after boot unless I logout and login again; I get a polkit prompt for my password, but it doesn't work; I also can't "unlock" any gnome settings (the "unlock" button is greyed out) unless I re-login, so this probably has sth to do with polkit. I tried chmod 755 on /usr/share/polkit-1/rules.d/ to no avail.
2. Gnome no longer recognises the lid close event. I had to temporarily work around this by using logind (systemd).
3. Rhythmbox doesn't play any music files; if I try to open its preferences, it segfaults.

Has anyone got similar issues? Any ideas?

Last edited by trsk (2012-10-31 17:47:08)

Offline

#2 2012-10-31 11:59:32

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

The frontpage mentions that consolekit was replaced by logind. Probably you should look in that direction.

Offline

#3 2012-10-31 12:01:35

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Hm, /etc/systemd/logind.conf hasn't been changed; it also worked prior to this particular update. Do you know where else to look?

Offline

#4 2012-10-31 12:03:57

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

zenlord wrote:

The frontpage mentions that consolekit was replaced by logind. Probably you should look in that direction.

Care to be a bit more specific?

Where should one go for more info?

Edit: I don't need a link to www.archlinux.org about the announcement, I'd like help / troubleshooting information.

Last edited by pezz (2012-10-31 12:07:40)

Offline

#5 2012-10-31 12:07:35

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

@pezz, can you suspend? Can you unlock gnome settings centre for root actions?

Offline

#6 2012-10-31 12:11:57

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

trsk wrote:

@pezz, can you suspend? Can you unlock gnome settings centre for root actions?

If Network settings are anything to go by, nope. All greyed out.

Still searching for info, very difficult to diagonose, and who knows - my setup might be just broken (but, then again, it worked before going to 3.6 and removing myself from a bunch of groups).

Offline

#7 2012-10-31 12:15:41

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Could you go to "User Accounts" and try to add a user?
I can't because it's locked, but I can't unlock it as long as I don't logout and re-login. I think this could also be the reason for our problems connected to UPower which relies on the same authentication mechanism (but potentially transparently, without asking for password).

Offline

#8 2012-10-31 12:18:28

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,094

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Are you actually booting with systemd?

Offline

#9 2012-10-31 12:18:59

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

trsk wrote:

Could you go to "User Accounts" and try to add a user?

Yeah, locked and can't unlock it.

Offline

#10 2012-10-31 12:19:38

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

arojas wrote:

Are you actually booting with systemd?

I'm fully systemd, have been for ages.

Offline

#11 2012-10-31 12:21:13

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,329
Website

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

All pacnew files in /etc/pam.d merged?

Offline

#12 2012-10-31 12:21:25

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

So am I.

Does anyone know which packet is responsible for unlocking e. g. the settings centre? Is it polkit or pam? There's definitely something wrong about it in this constellation...

EDIT:
@Allan: yes.

EDIT2:
loginctl actually does print my sessions correctly.

Last edited by trsk (2012-10-31 12:22:49)

Offline

#13 2012-10-31 12:24:51

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Allan wrote:

All pacnew files in /etc/pam.d merged?

No pacnew / save files for pam for me.

I tried messing around with pam.d files (adding pam_systemd.so in various places) in order to try and get it going, no good.

All back to stock now though, same problems.

Offline

#14 2012-10-31 12:27:05

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

trsk wrote:

EDIT2:
loginctl actually does print my sessions correctly.

I get my "seat" listed properly and all that, but:

% loginctl show-session $XDG_SESSION_ID | grep Active
Active=no

Offline

#15 2012-10-31 12:28:18

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Well, I get

Active=yes

Which probably means that this is not the core of our auth issues...

However, I'm also able to play audio, it's just rhythmbox that doesn't work.

Last edited by trsk (2012-10-31 12:29:14)

Offline

#16 2012-10-31 12:32:45

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

trsk wrote:

Well, I get

Active=yes

Damn... hmm

Offline

#17 2012-10-31 15:00:50

Pi3R1k
Member
Registered: 2012-10-31
Posts: 3

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Same problem for me this morning :
- can't unlock any gnome settings
- when i want to suspend , hibernate or stop, i get a polkit prompt and gnome freeze

loginctl show-session $XDG_SESSION_ID | grep Active      
 Active=no

You just have to disable gdm-plymouth :

sudo systemctl disable gdm-plymouth.service

and enable gdm :

sudo systemctl enable gdm.service

reboot


after :

loginctl show-session $XDG_SESSION_ID | grep Active      
 Active=yes

http://comments.gmane.org/gmane.linux.a … eral/46651

Last edited by Pi3R1k (2012-10-31 23:20:39)

Offline

#18 2012-10-31 15:29:35

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

@Pi3R1k: Do you happen to experience any of the problems we mentioned (suspend, reboot, unlocking settings, rhythmbox)?

Offline

#19 2012-10-31 17:20:55

pezz
Member
From: Geelong, Australia
Registered: 2010-05-23
Posts: 49

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

I've never used Plymouth.

Offline

#20 2012-10-31 17:49:53

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

I've just updated my first post to reflect my latest observations:
- hibernation actually works (using the dbus command or a hotkey), but suffers from the same (polkit?) problem as suspend-to-ram;
- Gnome no longer recognises the lid close event -- I had to temporarily work around this by using logind (systemd).

Offline

#21 2012-10-31 18:39:49

breecummins
Member
Registered: 2012-10-31
Posts: 11

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

@trsk: How did you work around the lid close issue? I am able to suspend using the suspend hard key or

systemctl suspend

but my machine no longer suspends on lid close events since I updated to Gnome 3.6 this morning. I disabled the acpid.service in systemd and altered the logind.conf file as directed in the wiki:

HandlePowerKey=ignore 
HandleSuspendKey=ignore 
HandleHibernateKey=ignore   
HandleLidSwitch=ignore 

I believe that my gnome settings are correct:

>> gsettings get org.gnome.settings-daemon.plugins.power lid-close-ac-action
'suspend'
>> gsettings get org.gnome.settings-daemon.plugins.power lid-close-battery-action
'suspend' 

I have rebooted and still don't suspend on lid close. Any ideas?

Offline

#22 2012-10-31 19:32:04

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

@breecummins: Gnome 3.6 (in contrast to 3.4) correctly issues systemd inhibits, so you no longer need to ignore the power events in logind.conf (just return to the defaults). You can view the inhibits with:

systemd-inhibit --list

My Gnome does not, for some reason, handle the lid close event, but it doesn't inhibit systemd from doing it, either. Therefore, if you restore logind.conf to its defaults, the system should get suspended on the lid event (by systemd) regardless of the Gnome setting.

Do you experience the other two issues I mentioned above (polkit, rhythmbox)?

Last edited by trsk (2012-10-31 19:33:06)

Offline

#23 2012-10-31 20:10:48

breecummins
Member
Registered: 2012-10-31
Posts: 11

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

@trsk: Thank you, restoring system defaults to logind.conf worked. I am now confused why suspend on lid close didn't work right after the update, but I'm unable to reproduce the error by re-enabling acpid.service. *shrugs*

I don't use rhythmbox and I am not experiencing your polkit errors. I don't have to logout/in for suspend or hibernate and I am able to unlock User Accounts in gnome settings.

Offline

#24 2012-10-31 20:16:39

trsk
Member
Registered: 2012-10-14
Posts: 38

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

Thank you for your feedback, that's very interesting... When did you migrate to systemd?

EDIT: Which kernel are you using? I've sticked with 3.5.6-1 because of serious power regressions ( https://bbs.archlinux.org/viewtopic.php?pid=1176627 ).

Last edited by trsk (2012-10-31 20:47:31)

Offline

#25 2012-10-31 21:04:04

breecummins
Member
Registered: 2012-10-31
Posts: 11

Re: Update to Gnome 3.6: can't suspend, polkit authentication problems etc

I only migrated to systemd last week, and I have the newest kernel, 3.6.4-1. I got the kernel update along with gnome 3.6 this morning. I do not have the power regression issues mentioned in the link you posted, but I'm also on an AMD chip, not Intel Sandy Bridge.

Offline

Board footer

Powered by FluxBB