You are not logged in.

#1 2012-10-10 13:10:16

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

shutdown stuck at "Power down." hibernate does not do anything

Recently I've had trouble with my laptop not always auto powering off when it goes to init 0 / halt / poweroff / shutdown -h now ..

I assume this is a small problem related to some power management.

I also wish to get "systemctl hibernate" to work but it only blanks the screen for a few seconds with the blinking cursor and then resumes again - no password entering on LUKS partitions root/swap so hibernate is interrupted somehow .. suspend works however ..

The power-down only occasionally doesn't shut off automatically, so it's very hard to say what is causing the problem.

How can I troubleshoot these problems ?

Last edited by dezza (2012-10-21 19:14:11)

Offline

#2 2012-10-21 18:31:54

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

No one knows? No one with a laptop ?

Offline

#3 2012-10-21 19:08:43

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: shutdown stuck at "Power down." hibernate does not do anything

I am sure many people have ideas, I think it is more the way you have asked your question.

https://wiki.archlinux.org/index.php/Fo … troduction

See second bullet point... as well as the third and fourth.

Offline

#4 2012-10-21 19:17:08

illusionist
Member
From: localhost
Registered: 2012-04-03
Posts: 498

Re: shutdown stuck at "Power down." hibernate does not do anything

For hibernate, here is the wiki entry: Systemd: Hibernate

EDIT: Try this to shutdown :

dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Stop

Last edited by illusionist (2012-10-21 19:19:48)


  Never argue with stupid people,They will drag you down to their level and then beat you with experience.--Mark Twain
@github

Offline

#5 2012-10-21 19:55:44

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

I already read that-

illusionist wrote:

For hibernate, here is the wiki entry: Systemd: Hibernate

Shouldn't the systemctl work out of the box or should you really replace it with uwsusp ? Or is it only suspend/sleep that works without any extra installs ?

Only suspicious errors I found in logs is:

Oct 21 16:58:20 localhost kernel: [   17.113356] ACPI Warning: 0x000000000000e040-0x000000000000e05f SystemIO conflicts with Region \SMB0 1 (20120711/utaddress-251)

Offline

#6 2012-10-21 22:11:21

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: shutdown stuck at "Power down." hibernate does not do anything

Well, did you at least set up your kernel command line with "resume=/dev/whatever" and possibly add the resume hook to your initramfs or as it is called around here initcpio?  I had to do both of those things, but I did not have to use uwsusp.  So I guess it should work out of the box in a sense... you just have to tell it where to look for the restore image.

Offline

#7 2012-10-21 22:13:44

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

I did but both hibernation and shutdown stops working at random with no errors

Offline

#8 2012-10-21 22:20:23

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,663

Re: shutdown stuck at "Power down." hibernate does not do anything

Logs? Increase logging level and logs?

How do you shutdown/hibernate? Are you using a DE?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#9 2012-10-22 05:57:19

illusionist
Member
From: localhost
Registered: 2012-04-03
Posts: 498

Re: shutdown stuck at "Power down." hibernate does not do anything

Are you using pure systemd or mixed one with initscripts ?
Your logs would be helpful and if nothing works maybe try strace. hmm


  Never argue with stupid people,They will drag you down to their level and then beat you with experience.--Mark Twain
@github

Offline

#10 2012-10-23 07:31:21

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

Thanks alot for your suggestions so far I am very grateful, for your patience smile

I will increase the logging level, move my old logs to a temporary directory and reproduce the error. Any specific loglevel I should increase, or all of them ?

The last time the shutdown was prevented/didn't work was:
http://paste.kde.org/578330/
Line: 1931 and forward ...

See: Line 2035

Oct 23 08:33:00 localhost kernel: [    0.000000] ACPI BIOS Bug: Warning: 32/64X FACS address mismatch in FADT - 0xB2FE4E40/0x00000000B2FE4D40, using 32 (20120711/tbfadt-521)

I am using systemd currently (mixed) -- but will probably eventually transition fully, I might as well do this now unless there are any complications ?

Last edited by dezza (2012-10-23 09:12:46)

Offline

#11 2012-10-25 01:52:31

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,663

Re: shutdown stuck at "Power down." hibernate does not do anything

Is your system completely up to date? I ask because your system seems to think that systemd-initctl doesn't exist but it should do so I'm wondering if you've got an older version of systemd or if something else has gone wrong.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#12 2012-10-31 16:54:43

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

cfr wrote:

Is your system completely up to date? I ask because your system seems to think that systemd-initctl doesn't exist but it should do so I'm wondering if you've got an older version of systemd or if something else has gone wrong.

Yes it is recently updated ...

Where do you see the systemd-initctl error?

systemctl | grep -i initctl

systemd-initctl.socket                                                                      loaded active listening     /dev/initctl Compatibility Named Pipe

I would increase the logging level if I could tell where and how to do it.

Offline

#13 2012-10-31 17:24:21

Minsc
Member
Registered: 2012-07-16
Posts: 78

Re: shutdown stuck at "Power down." hibernate does not do anything

Not sure if this is relevant, but my laptop does the same when the power is not plugged in (running off battery) and I have to switch it off manually after seeing the "Power down" message by holding the power button. This doesn't happen when the laptop is running when plugged in.

Offline

#14 2012-10-31 18:16:29

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

Minsc wrote:

Not sure if this is relevant, but my laptop does the same when the power is not plugged in (running off battery) and I have to switch it off manually after seeing the "Power down" message by holding the power button. This doesn't happen when the laptop is running when plugged in.

I will have to test this !

Thanks alot for your answer !

Offline

#15 2012-11-01 00:31:04

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,663

Re: shutdown stuck at "Power down." hibernate does not do anything

Just meant there seems to be something it doesn't like:

Oct 23 06:50:02 localhost systemd-initctl[27872]: Received environment initctl request. This is not implemented in systemd.

But maybe this is expected...

Last edited by cfr (2012-11-01 00:31:20)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#16 2012-11-02 07:40:16

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

Minsc wrote:

Not sure if this is relevant, but my laptop does the same when the power is not plugged in (running off battery) and I have to switch it off manually after seeing the "Power down" message by holding the power button. This doesn't happen when the laptop is running when plugged in.

I just tried today, with both AC and Battery - it also prevented "Power down." this time.

cfr wrote:

Just meant there seems to be something it doesn't like:

Oct 23 06:50:02 localhost systemd-initctl[27872]: Received environment initctl request. This is not implemented in systemd.

But maybe this is expected...

I'm not sure, just switched to systemd.

Last edited by dezza (2012-11-19 21:36:56)

Offline

#17 2012-11-25 07:57:30

dezza
Member
From: Denmark
Registered: 2007-04-05
Posts: 126

Re: shutdown stuck at "Power down." hibernate does not do anything

dezza wrote:
Minsc wrote:

Not sure if this is relevant, but my laptop does the same when the power is not plugged in (running off battery) and I have to switch it off manually after seeing the "Power down" message by holding the power button. This doesn't happen when the laptop is running when plugged in.

I just tried today, with both AC and Battery - it also prevented "Power down." this time.

cfr wrote:

Just meant there seems to be something it doesn't like:

Oct 23 06:50:02 localhost systemd-initctl[27872]: Received environment initctl request. This is not implemented in systemd.

But maybe this is expected...

I'm not sure, just switched to systemd.

I managed to get rid of both errors I think!

I added 'shutdown' hook in mkinitcpio.conf required by encrypted roots (my / is encrypted) ... and hibernation and suspend + shutdown / systemctl poweroff works as expected smile

Last edited by dezza (2012-11-25 07:57:55)

Offline

Board footer

Powered by FluxBB