You are not logged in.

#1 2012-10-31 23:17:04

GreenTime
Member
Registered: 2011-08-22
Posts: 5

[SOLVED] arch-chroot: Command not found

Hey,
I installed Windows 8 alongside Archlinux, so I need to restore my bootloader. I've downloaded the recent image of Arch, made it onto a bootable usb pen drive and booted it without any problems. However, I can't seem to find the arch-chroot binaries (and manually chroot-ing into /mnt after mounting everything fails because bash is not found).
Am I doing something wrong or is the wiki out of date?

Last edited by GreenTime (2012-11-01 10:16:56)

Offline

#2 2012-11-01 01:33:17

mhertz
Member
From: Denmark
Registered: 2010-06-19
Posts: 664

Re: [SOLVED] arch-chroot: Command not found

You're doing something wrong.

Download latest iso and use dd to write it to usb and verify md5 on iso and usb.

Edit: Normally I roll my own iso with archiso, but to be absolutelly sure on my answer to you, then i've just downloaded latest official iso and tested in a vm, and as expected, arch-chroot is present and working fine.

Last edited by mhertz (2012-11-01 01:49:59)

Offline

#3 2012-11-01 10:19:25

GreenTime
Member
Registered: 2011-08-22
Posts: 5

Re: [SOLVED] arch-chroot: Command not found

dd worked fine, thanks. Previously, I tried creating the usb stick with Linux Live USB Creator (which, according to archwiki, fails) but the "Universal USB Installer" which - according to the wiki - should have worked fine also failed.

Offline

Board footer

Powered by FluxBB