You are not logged in.

#1 2012-11-01 11:47:58

mumo
Member
Registered: 2012-05-06
Posts: 22

Yesterdays Update broke Grub(?) [UEFI]

Hi there,

i'm getting quite desperate by now. after my daily "pacman -Syu" my machine won't boot anymore.

I got a quite fresh Arch64 native systemd-installation with Grub as bootloader - installed following this wiki:

https://wiki.archlinux.org/index.php/GR … _PARTITION


Until yesterdays update everything worked just great. Now Grub is stuck on "Loading initial Ramdisk" - even trying Fallback.

I seriously got no idea. Everything looks right to me (?):


grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod reiserfs
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9096ba57-bae3-4037-b8cf-cd6a46cf2dd2
else
  search --no-floppy --fs-uuid --set=root 9096ba57-bae3-4037-b8cf-cd6a46cf2dd2
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=de_DE
  insmod gettext
fi
terminal_input console
terminal_output gfxterm
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch GNU/Linux, mit Linux core repo kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-true-9096ba57-bae3-4037-b8cf-cd6a46cf2dd2' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod reiserfs
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9096ba57-bae3-4037-b8cf-cd6a46cf2dd2
	else
	  search --no-floppy --fs-uuid --set=root 9096ba57-bae3-4037-b8cf-cd6a46cf2dd2
	fi
	echo	'Linux core repo kernel wird geladen …'
	linux	/boot/vmlinuz-linux root=UUID=9096ba57-bae3-4037-b8cf-cd6a46cf2dd2 ro  quiet
	echo	'Initiale Ramdisk wird geladen …'
	initrd	/boot/initramfs-linux.img
}
menuentry 'Arch GNU/Linux, with Linux core repo kernel (Fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-fallback-9096ba57-bae3-4037-b8cf-cd6a46cf2dd2' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod reiserfs
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9096ba57-bae3-4037-b8cf-cd6a46cf2dd2
	else
	  search --no-floppy --fs-uuid --set=root 9096ba57-bae3-4037-b8cf-cd6a46cf2dd2
	fi
	echo	'Linux core repo kernel wird geladen …'
	linux	/boot/vmlinuz-linux root=UUID=9096ba57-bae3-4037-b8cf-cd6a46cf2dd2 ro  quiet
	echo	'Initiale Ramdisk wird geladen …'
	initrd	/boot/initramfs-linux-fallback.img
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

fstab

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>


tmpfs		/tmp	tmpfs	nodev,nosuid	0	0

# UUID=9096ba57-bae3-4037-b8cf-cd6a46cf2dd2
/dev/sda2           	/         	reiserfs  	rw,relatime	0 1

# UUID=1825e7cd-2e8b-4534-92de-f01ff6ecac0e
/dev/sda3           	/home     	ext4      	rw,relatime	0 2

# UUID=F2CE-77C1
/dev/sda1           	/boot/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro	0 2

structure of /boot:

ls /boot:

[color=blue]efi  grub[/color]  initramfs-linux-fallback.img  initramfs-linux.img  vmlinuz-linux

/boot/efi contains folders /EFI/arch_grub according to wiki.


ls /boot/grub:

[color=blue]fonts[/color]  grub.cfg  grub.cfg.example  grubenv [color=blue]locale  themes  x86_64-efi[/color]

Can anyone help? smile

MB: Asrock 970 Extreme 3

Offline

#2 2012-11-01 11:56:42

nobody44
Member
Registered: 2011-08-25
Posts: 28

Re: Yesterdays Update broke Grub(?) [UEFI]

Do you have more than 4 GB RAM? Solution: Add "mem=4G" to your command line (Press E in GRUB).

See here: Thread

Offline

#3 2012-11-01 11:58:11

krzemin
Member
Registered: 2009-02-11
Posts: 3

Re: Yesterdays Update broke Grub(?) [UEFI]

Hi,

I have the same problem. After pacman -Suy I rebooted the system, but it don't boot up any more. Hangs on a grub "Loading initial ramdisk ...". I installed linux-lts kernel (booted via archlinux iso), but it also hangs on the same message. My motherboard is Asrock 970 Extreme 3 too.

Any help would be appreciated.

Offline

#4 2012-11-01 12:00:48

krzemin
Member
Registered: 2009-02-11
Posts: 3

Re: Yesterdays Update broke Grub(?) [UEFI]

@nobody44: I've successfully booted with mem=4G. It seems really like a kernel issue, thanks.

Offline

#5 2012-11-01 12:11:12

mumo
Member
Registered: 2012-05-06
Posts: 22

Re: Yesterdays Update broke Grub(?) [UEFI]

thank you nobody.

works like a charm smile just missing 8G ram - hopefully this is getting fixed soon.

Offline

#6 2012-11-01 18:36:58

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: Yesterdays Update broke Grub(?) [UEFI]

Wow, this is a very severe bug. Same problem here. The same workaround also works for me. Downgraded to the previous kernel also works. Without the workaround.

Last edited by LB06 (2012-11-01 18:55:16)

Offline

Board footer

Powered by FluxBB