You are not logged in.

#1 2012-11-02 02:44:42

riccardo
Member
From: IT
Registered: 2012-08-05
Posts: 50

[SOLVED] net-auto-wireless.service failed

Hello,

after a new installation of Arch with systemd, net-auto-wireless.service failed to load.

net-auto-wireless.service - Provides automatic netcfg wireless connection
      Loaded: loaded (/usr/lib/systemd/system/net-auto-wireless.service; enabled)
      Active: failed (Result: exit-code) since Fri, 2012-11-02 03:16:30 CET; 26min ago
     Process: 197 ExecStart=/usr/bin/netcfg-wpa_actiond $WIRELESS_INTERFACE (code=exited, status=1/FAILURE)
      CGroup: name=systemd:/system/net-auto-wireless.service

Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: wlan0-FASTWEB-1-PASI
Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: nl80211: 'nl80211' generic netlink not found
Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: Failed to initialize driver 'nl80211'
Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: Could not read interface wlan0 flags: No such device
Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: WEXT: Could not set interface 'wlan0' UP
Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: Could not read interface wlan0 flags: No such device
Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: WEXT: Could not set interface 'wlan0' UP
Nov 02 03:16:28 arch netcfg-wpa_actiond[197]: wlan0: Failed to initialize driver interface
Nov 02 03:16:30 arch systemd[1]: Failed to start Provides automatic netcfg wireless connection.
Nov 02 03:16:30 arch systemd[1]: Unit net-auto-wireless.service entered failed state

It seems that is a problem with "nl80211". The only way to connect is to run wifi-menu.

How can I solve the problem?


Thank you!
Riccardo

Last edited by riccardo (2012-11-02 23:03:42)


Arch Linux x86_64 | GNOME | Genuine Intel® CPU U7300 @ 1.30GHz × 2 | 3,7 GiB | Corsair Force 3 SSD 120 GiB

Offline

#2 2012-11-02 02:55:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] net-auto-wireless.service failed

Did you install rfkill?

Offline

#3 2012-11-02 09:45:04

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: [SOLVED] net-auto-wireless.service failed

Copy this unit to /etc/systemd/system: https://github.com/brain0/netcfg/blob/w … 40.service. Then run

# systemctl disable net-auto-wireless.service
# systemctl enable net-auto-wireless@wlan0.service

This should fix it. This will hopefully be merged into the next netcfg release.

Offline

#4 2012-11-02 16:17:14

riccardo
Member
From: IT
Registered: 2012-08-05
Posts: 50

Re: [SOLVED] net-auto-wireless.service failed

brain0 wrote:

Copy this unit to /etc/systemd/system: https://github.com/brain0/netcfg/blob/w … 40.service. Then run

# systemctl disable net-auto-wireless.service
# systemctl enable net-auto-wireless@wlan0.service

This should fix it. This will hopefully be merged into the next netcfg release.

Thank you. Now it's working. But is it a bug?

So, If I have to add a new wi-fi connection, have I to do the same? How can I see the connection icon in the panel?


Thank you again.
Riccardo


Arch Linux x86_64 | GNOME | Genuine Intel® CPU U7300 @ 1.30GHz × 2 | 3,7 GiB | Corsair Force 3 SSD 120 GiB

Offline

#5 2012-11-02 16:19:03

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: [SOLVED] net-auto-wireless.service failed

This is a bug in netcfg - with the old unit, it doesn't wait for the interface to exist.

What is the "connection icon"? netcfg has no such thing.

Offline

#6 2012-11-02 16:28:23

riccardo
Member
From: IT
Registered: 2012-08-05
Posts: 50

Re: [SOLVED] net-auto-wireless.service failed

brain0 wrote:

What is the "connection icon"? netcfg has no such thing.

I explain myself better: I'm using Gnome as DM, in the panel (upper right) there isn't the connection icon. How can I see it?


Thank you.
Riccardo

Last edited by riccardo (2012-11-02 16:28:41)


Arch Linux x86_64 | GNOME | Genuine Intel® CPU U7300 @ 1.30GHz × 2 | 3,7 GiB | Corsair Force 3 SSD 120 GiB

Offline

#7 2012-11-03 16:11:53

Stebalien
Member
Registered: 2010-04-27
Posts: 1,218
Website

Re: [SOLVED] net-auto-wireless.service failed

That's the network manager applet. If you want to use it, you have to use network-manager to manage your connections instead of netcfg.


Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email: honeypot@stebalien.com

Offline

#8 2012-11-03 16:54:29

riccardo
Member
From: IT
Registered: 2012-08-05
Posts: 50

Re: [SOLVED] net-auto-wireless.service failed

Stebalien wrote:

That's the network manager applet. If you want to use it, you have to use network-manager to manage your connections instead of netcfg.

Ok. How can I use network-manager instead of netcfg? Through systemd (systemctl disable/enable)?


Thank you.
Riccardo


Arch Linux x86_64 | GNOME | Genuine Intel® CPU U7300 @ 1.30GHz × 2 | 3,7 GiB | Corsair Force 3 SSD 120 GiB

Offline

#9 2012-11-03 16:56:53

riccardo
Member
From: IT
Registered: 2012-08-05
Posts: 50

Re: [SOLVED] net-auto-wireless.service failed

brain0 wrote:

This is a bug in netcfg - with the old unit, it doesn't wait for the interface to exist.

Has this bug been solved with the November snapshot?


Thank you.
Riccardo


Arch Linux x86_64 | GNOME | Genuine Intel® CPU U7300 @ 1.30GHz × 2 | 3,7 GiB | Corsair Force 3 SSD 120 GiB

Offline

#10 2012-11-03 22:23:08

riccardo
Member
From: IT
Registered: 2012-08-05
Posts: 50

Re: [SOLVED] net-auto-wireless.service failed

riccardo wrote:
Stebalien wrote:

That's the network manager applet. If you want to use it, you have to use network-manager to manage your connections instead of netcfg.

Ok. How can I use network-manager instead of netcfg? Through systemd (systemctl disable/enable)?


Thank you.
Riccardo

I answer myself: maybe I will try network-manager installing it instead of netcfg smile


Riccardo


Arch Linux x86_64 | GNOME | Genuine Intel® CPU U7300 @ 1.30GHz × 2 | 3,7 GiB | Corsair Force 3 SSD 120 GiB

Offline

Board footer

Powered by FluxBB