You are not logged in.

#1 2012-11-04 00:38:27

Registered: 2012-09-05
Posts: 10

[Solved] Dbus Failing and No Supend

I'm not usually one of those guys who likes to come in and ask someone to do all the work for him, so if you could kinda point me in the right direction here, I certainly don't mind doing most of the leg work here. That said, I am still very much a beginner compared to people who have been using Linux for any length of time, so I apologize in advance for not being able to give more information.

Starting from the beginning, I did a full system upgrade last week with pacman -Syu, and there were a ton of things that needed upgrading. Probably about 40 packages if I remember. I didn't think there would be that many. Anyway, the first problem I noticed after upgrading was that the Suspend option in XFCE was disabled. It's still there, but clicking on it does nothing, and it's discolored as well.

At this point, I decided a restart was in order. During the boot process, when it came time to start up dbus - which is the second thing on my daemons list - it said FAILED in big red letters where it usually says DONE. However, after the boot finishes and I log in, putting `rc.d list` into a terminal shows dbus as running and automatically started.

I read a little about dbus on your wiki, which is excellent by the way, and it says that dbus is responsible for sending system messages. I don't see how these two issues can be related, but like I said, I'm not an expert.

Here are some system specs that may or may not be related/helpful:

Compaq Presario R3000,
AMD64 Processor,
1.5BG RAM (1GB added by me)

XFCE Desktop,
LXDM Login,
I also have Gnome installed, but I don't use it.

Daemon List in /etc/rc.conf

DAEMONS=(syslog-ng dbus hal @network wicd !net-auto-wireless crond alsa lxdm)

Last edited by ScottyC- (2012-11-05 14:50:15)


#2 2012-11-04 02:44:01

From: Pasadena, CA
Registered: 2009-07-13
Posts: 14,615

Re: [Solved] Dbus Failing and No Supend

Are you sure you are still running initscripts. or are you running systemd?

Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
How to Ask Questions the Smart Way


#3 2012-11-04 03:42:25

Registered: 2012-09-05
Posts: 10

Re: [Solved] Dbus Failing and No Supend

I'm trying not to sound like a moron here, but how does one find out for sure? I'm guessing I'm on systemd, because the wiki says that it's the default, and I just installed Arch a few months ago.


#4 2012-11-04 03:53:24

Bug Wrangler
Registered: 2012-09-01
Posts: 5,969

Re: [Solved] Dbus Failing and No Supend

It's only been the default for less than a month. If you want to know for sure, do: more /proc/1/comm. It'll either say systemd or init. You need to be running systemd for everything to work right, such as the suspend issue you mentioned.

Last edited by Scimmia (2012-11-04 03:54:57)


#5 2012-11-04 03:54:46

From: Canada
Registered: 2011-12-06
Posts: 1,644

Re: [Solved] Dbus Failing and No Supend

If you installed Arch a few months ago then initscripts was the default then.  Systemd only became the default within the last month.  You should try to switch over as Arch is now systemd and going forward more and more of Arch will depend on that and break in subtle ways if you aren't systemd.

The systemd wiki entry:

I found to be very painless when I switched over using it.

We all make choices, but in the end, our choices make us.


#6 2012-11-05 14:49:47

Registered: 2012-09-05
Posts: 10

Re: [Solved] Dbus Failing and No Supend

Thanks for the info, guys. As it turns out, I am still using the initscript system, so I will looking into changing over to Systemd pretty soon.


Board footer

Powered by FluxBB