You are not logged in.

#1 2012-11-05 07:07:26

mibadt
Member
Registered: 2009-09-25
Posts: 362

Swap not mounted?

Hi,
I'm on a fully updated Arch_X86-64/KDE.
While investigating hiberanation recovery problems I've found that it looks like my swap partition in not mounted.
Am I right?
How do I fix it?
Thanks

--terminal output------------

# cd /etc
[root@Miki_Arch etc]# cat fstab | grep swap
UUID=19746a40-d8a0-45e4-8c4b-15c70d3c4dab swap swap defaults 0 0

[root@Miki_Arch etc]# cat mtab | grep swap

[root@Miki_Arch etc]# swapon -s
Filename                                Type            Size    Used    Priority
/dev/sda5                               partition       9213240 248     -1

[root@Miki_Arch etc]# mount swap
mount: /etc/fstab: parse error: ignore entry at line 14.
mount: mount point swap does not exist

Best regards,
Michael Badt

Offline

#2 2012-11-05 09:19:16

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,316

Re: Swap not mounted?

Not that I believe its related, but have you tried to fix the syntax error on line 14 of /etc/fstab yet?

Offline

#3 2012-11-05 13:15:05

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: Swap not mounted?

No. Swap partitions are not mounted, that's why you don't see it in mtab, and why "mount swap" does not work. Rather, they are enabled with swapon, which you have done as "swap -s" shows it as active.

Offline

Board footer

Powered by FluxBB