You are not logged in.

#1 2012-11-03 23:52:51

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

[SOLVED] Using Headphones as Speakers

I'm currently using a custom built computer, and don't have speakers, so I'm using headphones as my speakers. Today I decided to get them setup on the back of my motherboard, rather than having them sticking out of the front of my case.

I've currently got them plugged in the "center" jack, but I cannot get sound. Plugging them in the front of the case provides me with sound, so I assume that ALSA is outputting only to the front headphone jack on the front of my case. How do I fix this??

Last edited by Chessmaster942 (2012-11-05 20:50:40)

Offline

#2 2012-11-04 00:27:43

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,670

Re: [SOLVED] Using Headphones as Speakers

Are all the levels in alsamixer unmuted? Have you read the wiki alsa topic, especially the troubleshooting section?

Offline

#3 2012-11-04 00:50:21

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

The levels are unmuted, and I've read through the troubleshooting...

Offline

#4 2012-11-04 00:53:56

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,670

Re: [SOLVED] Using Headphones as Speakers

Have you ever had sound output from the back panel (are you sure it's not a hardware problem)? What have you tried other than plugging the headphones in and deciding they don't work? Did you try plugging them in the left or right jack?

Please post the output of the following commands (use [ code ] tags in your post):

aplay -l
cat ~/.asoundrc
amixer

Last edited by 2ManyDogs (2012-11-04 00:58:11)

Offline

#5 2012-11-04 01:07:57

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

I've tried every jack there, one of them just plays white noise, but it is a mic jack, so it shouldn't work.

"aplay -l":
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
"cat ~/.asoundrc":
cat: /home/john/.asoundrc: No such file or directory
"amixer":
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 21536 [33%] [on]
  Front Right: Capture 21536 [33%] [on]

Last edited by Chessmaster942 (2012-11-04 01:11:46)

Offline

#6 2012-11-04 01:09:55

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,670

Re: [SOLVED] Using Headphones as Speakers

Please use [code ] tags (quote my post above yours to see how this is done). It makes the output much easier to read.

That's really all you got from "amixer"?

Take a look at this wiki topic.

(edit) thanks for adding the code tags.

And again, have you ever had sound from the back panel (in another distro, or Windows)?

Last edited by 2ManyDogs (2012-11-04 01:13:49)

Offline

#7 2012-11-04 01:13:25

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

Thats honestly all I get.

Thanks for the wiki article, I'm installing from the AUR right now...

Offline

#8 2012-11-04 01:49:57

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

Well, I tried to install from the AUR, but both AUR packages give me error 404, and I cannot seem to fix them...

https://aur.archlinux.org/packages.php?ID=35862
https://aur.archlinux.org/packages.php?ID=40138

Tryin to find where that leaves me...

Offline

#9 2012-11-04 23:07:11

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

I downloaded and installed the drivers from the realtek website, alsa now detects my card, but I still can't get any sound...

Offline

#10 2012-11-04 23:42:33

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

Just tested my mic with the chip on the back of my board... it works fine.

Offline

#11 2012-11-05 01:06:54

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

I just saw your second part, I've never used the back panel before this...

Offline

#12 2012-11-05 02:03:48

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,670

Re: [SOLVED] Using Headphones as Speakers

I'm sorry, I really don't know what's wrong. Do you get more output from "amixer" now? Maybe someone who knows more about sound will come along...

Offline

#13 2012-11-05 03:11:50

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

Ironically, amixer doesn't display anything different. Thanks for the help you have provided, even though it ultimately didn't fix the problem.

Tomorrow, I'm going to work on completely wiping alsa, and pulseaudio, as I now cannot get anything but white noise, with interference from my front headphone jack, so hopefully that will help.

Last edited by Chessmaster942 (2012-11-05 11:45:31)

Offline

#14 2012-11-05 20:50:05

Chessmaster942
Member
Registered: 2012-10-29
Posts: 28

Re: [SOLVED] Using Headphones as Speakers

I FINALLY GOT IT!

I removed pulseaudio and pulseaudio-alsa, reconfigured alsa via KDE's volume manager, and then used the output that had the white noise before, and it now works.
I did have to install the drivers you pointed to earlier, and that was also a major part.

Thanks for the help!

Last edited by Chessmaster942 (2012-11-05 20:50:22)

Offline

#15 2012-11-05 22:14:29

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,670

Re: [SOLVED] Using Headphones as Speakers

Nicely done. :-) Thanks for the update.

Last edited by 2ManyDogs (2012-11-05 22:15:41)

Offline

Board footer

Powered by FluxBB