You are not logged in.

#1 2012-11-02 10:29:58

splatterdash
Member
Registered: 2011-06-07
Posts: 72

AUR upgrade issues with packer

I've been getting these errors lately with packer: (example for upgrading dropbox)

error: 'dropbox-*.pkg.tar': could not find or read package

It's happening to all my AUR updates. The package was downloaded, built, and then this pops up, making me unable to upgrade any AUR packages. Has anyone encountered a similar issue?

Offline

#2 2012-11-02 13:28:48

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

Have you searched your build directory? If the packages have been build OK, they should be there.
Is this the literal error you get, with the glob star:

error: 'dropbox-*.pkg.tar': could not find or read package

Offline

#3 2012-11-02 14:37:34

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,153

Re: AUR upgrade issues with packer

If it's looking for "*.pkg.tar" packages, then it's not likely to find any, makepkg produces "*.pkg.tar.xz" files by default. I'm not familiar with packer, but check your config (if applicable).


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#4 2012-11-02 15:14:19

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

WorMzy wrote:

If it's looking for "*.pkg.tar" packages, then it's not likely to find any, makepkg produces "*.pkg.tar.xz" files by default.

OP might have changed the compression of locally built packages.
I have.

Last edited by karol (2012-11-02 15:14:53)

Offline

#5 2012-11-04 14:52:42

sknd
Member
From: Brzeszcze, Poland
Registered: 2011-01-20
Posts: 53

Re: AUR upgrade issues with packer

i have exactly the same problem...

the packeges are built ok (*.pkg.tar.xz) but something (pacman? packer?) is looking for pkg.tar only... i canot find anything in their .conf files


Jaki koniec świata.Ziemia to nie cały świat ,a tylko mały Wąchock we wszechświecie.

Offline

#6 2012-11-04 20:57:49

splatterdash
Member
Registered: 2011-06-07
Posts: 72

Re: AUR upgrade issues with packer

karol: Where is packer's build directory? Yes, the error is with the glob star. And I don't recall changing anything, by the way.

Offline

#7 2012-11-04 22:54:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

splatterdash wrote:

karol: Where is packer's build directory?

It's /tmp/packerbuild-0/ for me. You should have subdirectories with built packages there e.g. /tmp/packerbuild-0/cower/cower/cower-7-1-i686.pkg.tar.

Offline

#8 2012-11-05 03:00:35

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: AUR upgrade issues with packer

I have exactly this problem, in addition, the behavior of the search for packages in Packer is very slow. . . the way I have to fix it is to install the packages manually.

Offline

#9 2012-11-05 08:16:22

splatterdash
Member
Registered: 2011-06-07
Posts: 72

Re: AUR upgrade issues with packer

Hmm..

I don't remember changing any compression options. But in my build directory, I find *.tar.gz archives. I suppose packer is not working because it expects *.tar files?

Offline

#10 2012-11-05 15:21:58

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

splatterdash wrote:

Hmm..

I don't remember changing any compression options. But in my build directory, I find *.tar.gz archives. I suppose packer is not working because it expects *.tar files?

Can you post the whole filename? If it's foo-tar.gz, then it's just the AUR tarball. Arch packages have 'pkg' in them, like cower-7-1-i686.pkg.tar.whatever.

Offline

#11 2012-11-05 23:40:37

splatterdash
Member
Registered: 2011-06-07
Posts: 72

Re: AUR upgrade issues with packer

Here's the result of running tree on one of the packages (the downgrade package, in this case):

|-- downgrade
|   |-- PKGBUILD
|   |-- downgrade
|   |-- downgrade-3.2-1-any.pkg.tar.xz
|   |-- pkg
|   |   `-- usr
|   |       `-- bin
|   |           `-- downgrade
|   `-- src
|       `-- downgrade -> /tmp/packerbuild-0/downgrade/downgrade/downgrade
`-- downgrade.tar.gz

I didn't check the folder contents last time, and only saw downgrade.tar.gz. Apparently packer managed to create the .pkg.tar.xz file, but somehow couldn't detect it hmm.

Offline

#12 2012-11-06 02:48:24

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

The tree looks the same for me and I had no problems with 'packer -S downgrade' / 'packer downgrade' neither with a week old nor with freshly-compiled packer.

Offline

#13 2012-11-06 07:14:50

splatterdash
Member
Registered: 2011-06-07
Posts: 72

Re: AUR upgrade issues with packer

Hmm...this is weird.

I tried upgrading using 'packer -S downgrade', and it works! I've always used 'packer -Syu --auronly' all this time. When I switched back to 'packer -Syu --auronly' to update the rest of my unupgraded AUR packages, the same error showed up.

So I guess the solution for now is to upgrade them manually one by one. I'm still puzzled as to what's causing the error, though.

Offline

#14 2012-11-06 07:29:05

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

I think it's time to post your findings in https://bbs.archlinux.org/viewtopic.php?id=88115

Offline

#15 2012-11-06 20:08:53

sknd
Member
From: Brzeszcze, Poland
Registered: 2011-01-20
Posts: 53

Re: AUR upgrade issues with packer

for me the problem is gone, but im not sure why, i didn't make nay changes in makepkg.conf or pacman.conf, i know i reinstalled some packages, pacman, pacman-color, packer... didn't help;) but next day (reboot?) problem was gone...

and yes - for me it also worked: packer - S something   , but didn't work packer -Syu... weird indeed.


Jaki koniec świata.Ziemia to nie cały świat ,a tylko mały Wąchock we wszechświecie.

Offline

#16 2012-11-10 15:44:31

dom96
Member
Registered: 2012-09-01
Posts: 4

Re: AUR upgrade issues with packer

I've been having the exact same problem for the past month or so, has anyone found a solution?

Offline

#17 2012-11-14 15:24:39

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

What version are you using?

$ pacman -Q packer
packer 20121106-1

I regularly update packer and I don't recall having such issues.

Offline

#18 2012-11-20 14:46:10

legiv
Member
Registered: 2010-04-23
Posts: 8

Re: AUR upgrade issues with packer

Apparently the format  of the "Download" link for all AUR package has changed.  For example packer is looking for "https://aur.archlinux.org/packages/ownc … ent.tar.gz" and the download link is actual "https://aur.archlinux.org/packages/ow/o … ent.tar.gz" -- note the extra "/ow/" subdirectory.  Based on a quick search all the download links now add the first two letters of the package name as this subdirectory.

So, is this a problem with the AUR site or is this going to be a permenant "feature" that packer needs to hande?

Offline

#19 2012-11-20 17:10:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

legiv wrote:

Apparently the format  of the "Download" link for all AUR package has changed.  For example packer is looking for "https://aur.archlinux.org/packages/ownc … ent.tar.gz" and the download link is actual "https://aur.archlinux.org/packages/ow/o … ent.tar.gz" -- note the extra "/ow/" subdirectory.  Based on a quick search all the download links now add the first two letters of the package name as this subdirectory.

So, is this a problem with the AUR site or is this going to be a permenant "feature" that packer needs to hande?

https://bbs.archlinux.org/viewtopic.php … 7#p1186357

Offline

#20 2012-11-20 18:24:48

legiv
Member
Registered: 2010-04-23
Posts: 8

Re: AUR upgrade issues with packer

Ah soooo -- said the blind man...  Packer will need a little tweaking.

Offline

#21 2012-11-20 21:08:02

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: AUR upgrade issues with packer

What is the problem? Can you post the exact command?
packer (version 20121106-1) works fine here. What version are you using?

Offline

#22 2012-11-20 21:45:38

legiv
Member
Registered: 2010-04-23
Posts: 8

Re: AUR upgrade issues with packer

No problem now -- except my own stupidity not checking for a newer version...

Offline

Board footer

Powered by FluxBB