You are not logged in.

#1 2012-11-07 08:04:49

ecognito
Member
Registered: 2009-05-30
Posts: 21

[Solved] CUPS doesn't see my Epson Stylus CX5500 printer

CUPS does not see my Epson Sytle CX5500 printer (all-in-one scanner/printer) when it is connected via USB.

When I open http://localhost:631/admin/ and click "Add Printer" it just ain't listed. :-(

Output of lsusb is:

Bus 003 Device 002: ID 0a81:0101 Chesen Electronics Corp. Keyboard
Bus 004 Device 002: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0
Bus 005 Device 002: ID 04b8:083f Seiko Epson Corp. Stylus CX4300/CX4400/CX5500/CX5600/DX4400/DX4450
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Following suggestions in these forums for similar issues with other printers, I've added the following to /etc/udev/rules.d:

ATTR{idVendor}=="04b8", ATTR{idProduct}=="083f", MODE:="0660", GROUP:="lp"
KERNEL=="lp[0-9]", SYMLINK+="%k", GROUP="lp"

For ls -l /dev/bus/usb/005/002:

crw-rw----+ 1 root lp 189, 513 Nov  7 18:48 /dev/bus/usb/005/002

And ls -l /dev/usb yields:

crw-rw---- 1 root lp 180, 0 Nov  7 18:48 lp0

So all the group ownership and permissions looks right.

I've tried blacklisting the usblp kernel module but it makes no difference either way.

I can see the driver file, which is /usr/share/cups/model/C/stp-escp2-cx5500.5.2.ppd.gz (part of the gutenprint package).

Just doesn't want to work.

Any ideas?

Last edited by ecognito (2012-11-14 10:26:02)

Offline

#2 2012-11-13 01:02:46

ecognito
Member
Registered: 2009-05-30
Posts: 21

Re: [Solved] CUPS doesn't see my Epson Stylus CX5500 printer

Bump. (Probably wasn't such a good idea posting on the eve of a national election in some foreign country - hopefully more eyeballs now that things have calmed down a bit. :-)

Offline

#3 2012-11-13 05:22:41

cyrus
Member
From: Auckland
Registered: 2011-02-14
Posts: 16
Website

Re: [Solved] CUPS doesn't see my Epson Stylus CX5500 printer

If you are using systemd, edit /etc/cups/cupsd.conf and /etc/cups/client.conf as root to use the Systemd socket instead of the default.

/usr/lib/systemd/system/cups.socket

in place of

/var/run/cups/cups.sock

Make sure to restart CUPS after that.

Offline

#4 2012-11-13 06:24:58

ecognito
Member
Registered: 2009-05-30
Posts: 21

Re: [Solved] CUPS doesn't see my Epson Stylus CX5500 printer

If you are using systemd...

Have updated those files, did a full reboot to be paranoid, and no change. CUPS still does not see the printer when I go to "Add Printer".

Thanks.

E.

Offline

#5 2012-11-13 06:50:45

cyrus
Member
From: Auckland
Registered: 2011-02-14
Posts: 16
Website

Re: [Solved] CUPS doesn't see my Epson Stylus CX5500 printer

In /etc/cups/cupsd.conf set your LogLevel to 'debug' instead of 'warn' and maybe

# tail -n 100 -f /var/log/cups/error_log

will give you an indication of what's wrong.

Offline

#6 2012-11-13 13:43:55

Painless
Member
Registered: 2006-02-06
Posts: 174

Re: [Solved] CUPS doesn't see my Epson Stylus CX5500 printer

Do you have avahi-daemon enabled?  I find some printer diagnostics utils fail without it.

Offline

#7 2012-11-14 10:25:09

ecognito
Member
Registered: 2009-05-30
Posts: 21

Re: [Solved] CUPS doesn't see my Epson Stylus CX5500 printer

Well, it looks like when all else fails, completely uninstalling cups, libcups and all your printer drivers and installing them again fixes things. Go figure.

Offline

Board footer

Powered by FluxBB