You are not logged in.

#1 2012-11-07 15:34:23

vendion
Member
From: Cleveland, TN
Registered: 2010-03-10
Posts: 190
Website

[solved] Pacman not respecting "noauto" flag in /etc/fstab

Why does Pacman not respect entries in /etc/fstab that has the "noauto" flag set in the mount options?  All this does is slows Pacman down when preforming installations or upgrades when it gets to the "checking for file conflicts".  This also spits out warnings such as:

warning: could not get filesystem information for /mnt/share: No such device

when the file system is not mounted.  If I were to mount those file systems (NFS mounts)  and re-run Pacman it is nice and quick with no warnings as expected, is this done by design or is it a bug?

Edit:  Caused by "checksize" option being set in /etc/pacman.conf

Last edited by vendion (2012-11-07 16:37:18)

Offline

#2 2012-11-07 15:43:49

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,701

Re: [solved] Pacman not respecting "noauto" flag in /etc/fstab


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#3 2012-11-07 16:33:22

vendion
Member
From: Cleveland, TN
Registered: 2010-03-10
Posts: 190
Website

Re: [solved] Pacman not respecting "noauto" flag in /etc/fstab

Ah I guess my initial search was too specific as I did not see those, but yes that is exactly my issue I had checkspace on and it was causing Pacman to hang.  I guess I need to wait until that patch makes it into the stable version.

Offline

Board footer

Powered by FluxBB