You are not logged in.

#1 2012-11-08 09:41:30

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

[SOLVED] Can't find root partition after upgrade

After upgrading to Linux 3.6.6, the boot fails with something like "can't find root, UUID=..." and I get a root shell. Choosing to recovery mode in GRUB doesn't make a difference.

I don't have any sda devices in /dev.

/proc/partitions is empty.

I have Macbook Pro 7,1.

Ubuntu on other partition works.

Any idea how to fix this?

Last edited by dontbugme (2012-11-08 17:53:46)

Offline

#2 2012-11-08 10:23:06

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: [SOLVED] Can't find root partition after upgrade

Now I realize that I did a probably stupid thing. I removed mdadm and lvm2 thinking that I don't need them. So the mdadm kernel module is missing. Could this be the problem? I don't use RAID or LVM.

Last edited by dontbugme (2012-11-08 10:23:55)

Offline

#3 2012-11-08 11:03:00

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: [SOLVED] Can't find root partition after upgrade

Tried to boot latest Arch iso, it can't mount /dev/disk/by-label/ARCH...:

Waiting 30 seconds for device /dev/disk/by-label/ARCH...

In /dev I have sda but no sda1, sda2 etc.

Offline

#4 2012-11-08 11:19:49

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,776
Website

Re: [SOLVED] Can't find root partition after upgrade

dontbugme wrote:

Now I realize that I did a probably stupid thing. I removed mdadm and lvm2 thinking that I don't need them. So the mdadm kernel module is missing. Could this be the problem? I don't use RAID or LVM.

I don't use these either ... but this does sound like a very plausible cause of this error.  Are you sure you aren't using either?

In any case, it's easy enough to add them back and see if that solves this.  Boot into live media, chroot, add back the modules to mkinitcpio.conf and rebuild the initramfs.  If nothing else this would verify that these are not the problem.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#5 2012-11-08 12:28:49

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: [SOLVED] Can't find root partition after upgrade

From chroot, I installed mdadm, lvm2 and downgraded back to linux-3.6.2 (from 3.6.6). Unfortunately, that didn't help. The only difference is that uname shows kernel 3.6.2 instead of 3.6.6.

Offline

#6 2012-11-08 13:51:34

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: [SOLVED] Can't find root partition after upgrade

I'm happy to announce that I fixed it. I looked into pacman history and two of the recently upgraded packages could have possibly caused the problem: hwids and mkinitcpio. I downgraded both of them (to versions 0.10-1 and 20121012-1) and reinstalled linux 3.6.6 (in order to regenerate initramdisk with the just downgraded mkinitcpio).

Offline

#7 2012-11-08 14:37:27

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,776
Website

Re: [SOLVED] Can't find root partition after upgrade

dontbugme wrote:

reinstalled linux 3.6.6 (in order to regenerate initramdisk with the just downgraded mkinitcpio).

For future reference, f you didn't need to upgrade the kernel, you can just run `mkinitcpio -p linux` to regenerate the initramfs.

If it's all working you can edit your first post to mark the title as solved.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#8 2012-11-12 15:17:24

ivanhoe1024
Member
Registered: 2012-11-12
Posts: 3

Re: [SOLVED] Can't find root partition after upgrade

Dear Trilby and dontbugme, I've got the same problem here, but I can not solve it! I've got a Macbookpro 7,1. Same error after upgrade.

I tried to downgrade mkinitcpio to 0.10-1, hwids to 20120922-1 or something similar (I haven't got in my cache dir 20121012-1, so I used an older one), and rebuild initramdisk with mkinitcpio -p linux. Nothing changed!

I then tried to downgrade the whole kernel, i.e. linux, linux-headers and nvidia driver to the former versions, 3.5.6-1, but the problem is still there... Have you got advices about what may I try now?! Thank you!

Offline

#9 2012-11-12 15:26:00

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,776
Website

Re: [SOLVED] Can't find root partition after upgrade

My only advice is to start a new thread detailing your problem.  Threads marked as solved rarely get much attention.

Also, your problem is clearly not the same - so it should not be in this thread anyway.  Some of the symptoms may appear similar, but if it were the same problem, it would respond to the same solution.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#10 2012-11-12 15:56:16

ivanhoe1024
Member
Registered: 2012-11-12
Posts: 3

Re: [SOLVED] Can't find root partition after upgrade

Thanks for the attention. I'm trying right now to post my problem on the archlinux italian forum (because I'm italian!). I hope I can find some help there, otherwise I'll post a new thread on this forum!

Offline

Board footer

Powered by FluxBB