You are not logged in.

#1 2012-11-08 12:29:06

myrlin
Member
Registered: 2010-06-11
Posts: 271

Systemd - Reboot Failures

I am using Openbox/fbpanel/lxdm on an old Dell Dimension 3000.

Since changing to Systemd, my system usually (but not always) freezes on reboot. It was absolutely fine before.  I have been completely unable to find any cause, or fix.

It usually freezes at the same point, just after this line:

 [ok] stopped target Remote File Systems 

All I get is a blinking cursor, and the machine will not respond to anything other than a "hard" reboot. I have looked at the various logs, but found nothing of use.

The same result occurs whether I try to reboot from lxdm, fbpanel, openbox or the command line.

I would be very grateful for any suggestions on how to track this down and fix it, since the constant hard rebooting is must be putting the filesyatem at risk.

Many thanks in advance.

Offline

#2 2012-11-08 14:03:44

p0x8
Member
Registered: 2012-09-20
Posts: 67

Re: Systemd - Reboot Failures

Have you waited long enough to determine if it freezes indefinitely or if systemd is just waiting for a stuck process to timeout?

The early debug shell can help you determine if and which services are stuck on shutdown.

Offline

#3 2012-11-08 19:01:49

myrlin
Member
Registered: 2010-06-11
Posts: 271

Re: Systemd - Reboot Failures

Many thanks for your reply, p0x8.

I have waited for about 20 minutes, so I guess it really has hung, but thank you for the pointer to the early debug shell. I'll give it a try.

Offline

#4 2012-11-08 19:04:03

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Systemd - Reboot Failures

If you scroll down a tad on the page that p0x8 linked to, you will find this.

Offline

#5 2013-01-02 12:40:50

myrlin
Member
Registered: 2010-06-11
Posts: 271

Re: Systemd - Reboot Failures

The Christmas holiday period enabled me to investigate this problem properly. Various attempts to debug/fix had failed, so I carried out a complete clean install, but still without success. There were three discrete problems of which I was aware: powerdown lockup, Pysol lockup on loading, and SMPlayer lockup when trying to play files. I noticed that these problems were either all present, or none of them were, and that they coincided with the random occurance of a stream of kernel messages at the previous boot. Further observation indicated that these messages may be related to my TV card, a Hauppage HVR3000. I removed the card, and everything has been fine ever since.

The HVR 3000 worked perfectly before I switched to systemd, so I guess it has fallen victim to systemd's "aggressive parallelisation". I assume modules are being loaded at boot time which conflict with those required for the base system.

I am keen to get this card working again, since it provides DVB-T, DVB-S, Video and FM on my PC, but I have absolutely no idea where to start. In the meantime, it sits on my desk!

I would be really grateful if anyone has any ideas.

Offline

Board footer

Powered by FluxBB