You are not logged in.

#1 2012-11-09 12:03:04

Registered: 2011-12-09
Posts: 254

pip error when install django-cms

Hi, I ran into compatibility errors using django-cms and it's dependencies which are mostly in aur, so I uninstalled all and decided to use pip. I installed python2-pip as Django only supports up to python2.7. Pip installed fine but when I run it to install Django-cms is errors out with:

Traceback (most recent call last):
  File "/usr/lib/python2.7/", line 163, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/pip/", line 2, in <module>
    from .runner import run
ValueError: Attempted relative import in non-package

So I looked at the corresponding python script and found that the line:

 pkg_name = mod_name.rpartition('.')[0]

The value for mod_name doesn't have any '.' in it so the value requested is empty. The module that it is operating on is pip.
This script attempts to run a module in the main namespace. Does anyone have an idea of how to fix this?

thanks for any help you may give.


Last edited by jk121960 (2012-11-09 12:03:44)

Arch Awesome, Ranger & Vim the coding triple threat.


Board footer

Powered by FluxBB