You are not logged in.

#1 2012-11-07 03:28:33

kevin_chn
Member
Registered: 2011-04-27
Posts: 15

IBus failure after recent upgrade

Hi folks,

I recently moved to pure systemd as suggested, and I made other upgrades as well.

ibus is one of them, and unsurprisingly, it stopped working.

In the first place, nothing happened when I pressed the enable key combination (ctrl + space), which worked fine before.

I read ArchWiki and added some env variables to .bashrc, but nothing worked.

If I manually launch ibus-daemon, it says:

IBUS-Message: 11:23:28.878481: Engine xkb:us:altgr-intl:eng is already registered by other component

Then, I followed someone's advice and reverted to the previous version:

sudo pacman -U /var/cache/pacman/pkg/ibus-1.4.2-2-x86_64.pkg.tar.xz

My old configuration came back, when I checked ibus-setup.

But I still couldn't enable ibus.

Is this something related to things like GTK3 or so? I tried adding env variables like $GTK_IM_MODULE=ibus, in vain.

I don't mind reverting to old versions, as long as I can type in ibus again.

Thank you in advance.

Offline

#2 2012-11-07 12:03:35

peterfyj
Member
Registered: 2012-11-07
Posts: 3

Re: IBus failure after recent upgrade

I have similar problems (including the IBUS-Message) but I can at least enable ibus by typing shift.  The original combinations are not functioning any more and ibus seems to ignore my settings such as 'Share the same input method among all applications'.  All these happen after an upgrade to gnome 3.6.  Hope that someone could help.

Offline

#3 2012-11-07 12:25:55

kevin_chn
Member
Registered: 2011-04-27
Posts: 15

Re: IBus failure after recent upgrade

I found that in the recent release of gnome, the input framework is integrated to 'languages and regions', and appears as 'Input Source'.

I finally was able to trigger Chinese Pinyin in 'Input Sources'. Nevertheless, I still don't know how I can add alternative input modules like googlepinyin or sunpinyin. It seems that all the useable input modules are hard coded in the 'Input Sources' list.

And some shortcuts to change input methods are not supported anymore, like Ctrl + LeftShift.

Last edited by kevin_chn (2012-11-07 12:26:50)

Offline

#4 2012-11-07 17:46:25

yungtrizzle
Member
From: Nanjing, China
Registered: 2011-04-24
Posts: 130

Re: IBus failure after recent upgrade

Currently the ibus package does not ship with any input sources, those are packaged separately. Actually it seems the last update broke something unrelated to systemd.


No trees No codes : equal exchange

Offline

#5 2012-11-08 02:09:37

Laputa
Member
Registered: 2012-06-16
Posts: 5

Re: IBus failure after recent upgrade

same here, i can enable the input method , but ibus ignores my setting  'Share the same input method among all applications'.

i'm using awesomeWM

peterfyj wrote:

I have similar problems (including the IBUS-Message) but I can at least enable ibus by typing shift.  The original combinations are not functioning any more and ibus seems to ignore my settings such as 'Share the same input method among all applications'.  All these happen after an upgrade to gnome 3.6.  Hope that someone could help.

Offline

#6 2012-11-09 21:00:40

psli
Member
From: Santa Clara, CA
Registered: 2012-10-18
Posts: 8

Re: IBus failure after recent upgrade

I am also having a similar problem.  I can enable ibus and use the pinyin engine, but it defaults to using Double pinyin input method, even though the the configuration is set to use Full Pinyin.  Changes to the configuration are not saved.  I am using awesome.  There was another update to ibus today (which i assume is the one referred to in here https://code.google.com/p/ibus/issues/detail?id=1542 but that doesn't seem to have fixed the problem.

Offline

#7 2012-11-10 02:09:44

peterfyj
Member
Registered: 2012-11-07
Posts: 3

Re: IBus failure after recent upgrade

After the recent upgrade of ibus and ibus-pinyin, the problem has disappeared.  I guess the status of this post should be changed now.

Offline

#8 2012-11-10 09:24:46

stozi
Member
Registered: 2010-03-02
Posts: 148

Re: IBus failure after recent upgrade

I disagree with peterfyj. Stil not outputing exactly what I type, preferences still refuse to be changed.
I'm on the latest update, I've deleted ~/.config/ibus and reinstalled ibus & ibus-pinyin, no luck.

Last edited by stozi (2012-11-10 09:26:47)

Offline

#9 2012-11-10 19:25:54

psli
Member
From: Santa Clara, CA
Registered: 2012-10-18
Posts: 8

Re: IBus failure after recent upgrade

stozi, if you're just wanting to use pinyin input, try using ibus-rime from the AUR for now.  It seems to function properly; we can probably just use that until the issue gets resolved.

Offline

#10 2012-11-11 03:35:03

bhrgunatha
Member
Registered: 2009-12-16
Posts: 74

Re: IBus failure after recent upgrade

yungtrizzle wrote:

Currently the ibus package does not ship with any input sources, those are packaged separately. Actually it seems the last update broke something unrelated to systemd.

Yes. For me it's seriously broken.
I'm using KDE.

yaourt -Qs ibus
extra/ibus 1.4.99.20121109-1
    Next Generation Input Bus for Linux
community/ibus-chewing 1.4.2-2
    Chinese Chewing Engine for IBus Framework
community/ibus-m17n 1.3.4-2
    M17N engine for IBus
community/ibus-pinyin 1.4.99.20120808-1
    Pinyin (Chinese) input method for the IBus framework
community/ibus-qt 1.3.1-5
    IBus qt library and IBus qt input method plugin

It completely forgotten ALL of my setting including input methods I've chosen and shortcut keys.

ibus-qt obviously is not work with ibus-1.4-99
All ibus related windows are ugly as hell

None of my input methods work.

Now I'm going to try rolling back various different versions of ibus and the input methods to find something that works.
This is really a pain.


EDIT:
I should say I think the settings issue is something to do with gconf as I get this message trying to remove and reinstall ibus-pinyin and ibus-chewing

(gconftool-2:2059): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: No protocol specified
Autolaunch error: X11 initialization failed.

Last edited by bhrgunatha (2012-11-11 03:48:56)

Offline

#11 2012-11-11 03:41:05

nowind10
Member
Registered: 2012-07-23
Posts: 1

Re: IBus failure after recent upgrade

similar with fcitx

Offline

#12 2012-11-11 05:04:46

peterfyj
Member
Registered: 2012-11-07
Posts: 3

Re: IBus failure after recent upgrade

stozi wrote:

I disagree with peterfyj. Stil not outputing exactly what I type, preferences still refuse to be changed.
I'm on the latest update, I've deleted ~/.config/ibus and reinstalled ibus & ibus-pinyin, no luck.

It's  weird because my ibus-pinyin was not functioning properly right after the upgrade, but after re-installation, everything's fine.  Did you re-install with previous configuration files replaced?  I don't know the quick way but you can try:

# pacman -Rn ibus-pinyin && pacman -S ibus-pinyin

.

Offline

#13 2012-11-11 15:37:58

bhrgunatha
Member
Registered: 2009-12-16
Posts: 74

Re: IBus failure after recent upgrade

OK I've been trying lots of combination of settings and rolling back version of ibus itself and the related input schemes.

On my system (KDE 4.9.3-1)  3.6.6-1-ARCH #1 SMP PREEMPT x86_64

ibus-qt - doesn't work - very ugly controls inside dialogs - using the ibus-ui-gtk3 library
ibus-pinyin doesn't work
ibus-m17n works (only tried bopomofo (symbols) and pinyin)
ibus-rime works (only tried bopomofo and terra pinyin)
ibus-chewing doesn't work - always gives gconf warnings when installing/removing

Looking at the processes running I have

ibus-x11 --kill-daemon
ibus-daemon --xim
    ibus-ui-gtk3 
    ibus-engine-simple 
    ibus-dconf 

Note - no libibus-qt loaded

When I try and configure ibus after it's loaded, it remembers my settings, but for example, changing the key that enables/disables it has absolutely no effect.
Only Ctrl+Space works.

It seems on top of everything ibus has changed the way it works as well.
Now I have to add an English|US IME and hitting Ctrl+Space lets me cycle through the IMEs installed.
However it's still ignoring my settings.

I use emacs, so Ctrl+Space is not acceptable - I have to kill ibus when I use emacs sad

Offline

#14 2012-11-11 18:00:06

stozi
Member
Registered: 2010-03-02
Posts: 148

Re: IBus failure after recent upgrade

I was using ibus-sunpinyin without too much trouble, except that ibus overwrites my dvorak layout and sunpinyin doesn't give you fantizi. I guess there'll just be a wait until I can type pinyin with a dvorak layout producing fanti. This for me has been one of the major advantages of arch over ms.

Offline

#15 2012-11-11 20:57:25

iosonofabio
Member
From: Italy
Registered: 2008-10-09
Posts: 101

Re: IBus failure after recent upgrade

I confirm the issue. Moreover, once activated iBus overrides xkb settings. Vice versa, if I call xkb directly via

 setxkbmap -layout "us" 

it overrides iBUS. There is an open bug issue (#32327) about the new Xorg (maybe systemd-related) not managing xkb layouts correctly, this looks related.

Offline

#16 2012-11-15 12:46:35

marcelof
Member
Registered: 2009-01-08
Posts: 6

Re: IBus failure after recent upgrade

kevin_chn wrote:

Hi folks,

I recently moved to pure systemd as suggested, and I made other upgrades as well.

ibus is one of them, and unsurprisingly, it stopped working.

I think it was broken before, it stopped working for me before my systemd thing, I thought it'd fix itself somehow after upgrading but it just broke more and more.

My solution: SCIM

it's a shame because it was working just fine. And right now I don't remember why I switched to iBus in the first place but I was happy with it.
Anyway whatever reason was there to switch from SCIM to iBus for me, I don't seem to find it now, SCIM is doing just fine, settings are not crazy and pinyin/anthy are doing their jobs.

EDIT: I thought I should add some information to my post:

-The first thing I noticed was my shortcuts gone. It was fine since the default stuff was still working, no rush...
-Then one day anthy and pinyin are gone...
-After reinstalling iBus, ibus-anthy and ibus-pinyin they add up okay, but the settings won't save, and now I need to add an english keyboard for typing in english...
-After a second reinstall with conf files sweeped away, Anthy loses its icon (wtf), it works anyway, but the same problems decribed by most of you.

Then I switched back to SCIM after year(s?) of paceful iBus.

Last edited by marcelof (2012-11-15 12:57:50)

Offline

#17 2012-11-16 20:15:00

darkfeline
Member
Registered: 2012-02-14
Posts: 94

Re: IBus failure after recent upgrade

I don't think the problem is with systemd, gnome or KDE.  With the recent(ish) ibus update to the unstable 1.4.99 in the official arch repos, a bunch of problems have appeared.  You can see in the ibus configuration window that the "preview input method" can't be used and I couldn't get "next input method" to work either; lots of global and per-input-method options aren't saved, and stuff is broken everywhere.  It looks like ibus unstable is not even in a completed state to be used yet.

What I want to know is why is ibus unstable branch in the official Arch repos?  Shouldn't that be relegated to the AUR?

Offline

#18 2012-11-16 20:47:57

kesara
Member
From: Colombo, Sri Lanka
Registered: 2006-10-08
Posts: 6
Website

Re: IBus failure after recent upgrade

I'm using ibus (from extra) and ibus-sayura (from AUR), after resent updates, I cannot use ibus.

Offline

#19 2012-11-17 13:00:45

NgoHuy
Member
Registered: 2011-10-27
Posts: 23

Re: IBus failure after recent upgrade

kesara wrote:

I'm using ibus (from extra) and ibus-sayura (from AUR), after resent updates, I cannot use ibus.

I have them same problem. I found that ibus-engine-* didn't run.
anyone can help me ?
I use Gnome 3.6 and language and region doesn't show them.

kind regard

Last edited by NgoHuy (2012-11-17 13:23:15)

Offline

#20 2012-11-20 16:27:21

caasi
Member
Registered: 2012-03-21
Posts: 44
Website

Re: IBus failure after recent upgrade

Same problem here, ibus does not work and 'language and region' doesn't show them.

Offline

#21 2012-11-21 03:27:06

mike_nzk
Member
Registered: 2012-07-24
Posts: 10

Re: IBus failure after recent upgrade

Same problem. After yesterday's upgrade, ibus does not run after startup and even if i manually launch ibus-daemon, i can't type Chinese. Also there is not any 'Chinese Pinyin' in 'language and region', only 'Chinese' present. I can't type Chinese characters currently.

Offline

#22 2012-11-21 05:51:39

mike_nzk
Member
Registered: 2012-07-24
Posts: 10

Re: IBus failure after recent upgrade

mike_nzk wrote:

Same problem. After yesterday's upgrade, ibus does not run after startup and even if i manually launch ibus-daemon, i can't type Chinese. Also there is not any 'Chinese Pinyin' in 'language and region', only 'Chinese' present. I can't type Chinese characters currently.

After an hour of struggle, I managed to solve the problem by:
1.adding these 3 lines to ~/.profile:
export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
2.adding startup command 'ibus-daemon -x -d' to gnome-session-properties

Then I'm curious why ibus worked without these changes before...
In addition, now comes a new problem: even if I select English(US) as current keyboard, ibus-pinyin still appear.

Offline

#23 2013-01-12 08:50:35

xiliyi
Member
Registered: 2011-05-14
Posts: 37

Re: IBus failure after recent upgrade

Hi forums,

sorry for reviving this thread, but is there a regular fix for Ibus or Fcitx by now? Even after searching and tinkering, neither of them work on my system (arch x64 on ThinkPad x201, Xmonad, aur/rxvt-unicode-chinese).

Help greatly appreciated!

Offline

#24 2013-01-12 09:53:08

iosonofabio
Member
From: Italy
Registered: 2008-10-09
Posts: 101

Re: IBus failure after recent upgrade

Now both ibus and ibus-pinyin are updated to stable version 1.5:

local/ibus 1.5.1-1 
Next Generation Input Bus for Linux
local/ibus-pinyin 1.5.0-2
    Pinyin (Chinese) input method for the IBus framework

Hence the ibus preferences GUI has changed and only shows keybindings for "Next input method", no "Activate", "Toggle", etc. And that keybinding works (here at least).

Note, however, that IBUS overrides the X server's keyboard languages and the grp:toggle mechanism. Hence, whatever you put e.g. in Xorg.conf (or *.d folder) is ignored while you're using IBUS (and works again when you stop using it).

I personally start it in my window manager (i3) startup file with:

ibus-daemon --xim --replace --daemonize &

and, caveat the above, it works well on my X200s + uxterm.

Offline

#25 2013-01-13 09:27:45

xiliyi
Member
Registered: 2011-05-14
Posts: 37

Re: IBus failure after recent upgrade

Hi iosonofabio,

neither the ibus from extra nor ibus-git from aur work with either ibus-pinyin or others (like googlepinyin, rime-pinyin etc.)! ibus starts and switches between input methods, but no characters appear, only letters.
With fcitx I can actually write characters, but pinyin doesn’t work correctly: typing „woshi“ gives me some characters for „wo sang chi“ (I mulberry eat, I believe). I suppose this is double pinyin, which I don’t know how to use. It doesn’t save my settings (although the configuration files are owned by me) so I can’t change any settings.

Offline

Board footer

Powered by FluxBB