You are not logged in.

#1 2012-11-09 23:54:24

Zamboniman
Member
Registered: 2010-06-20
Posts: 15

[Solved] System does not power off, hangs at "System Halted"

Not sure if this is systemd or kernel related, and after the recent round of upgrades it happens on one of my computers and not the other.

I'm using systemd and do have systemd-sysvcompat installed, but no daemons are started with initscripts.

When I power off from the KDE desktop using the poweroff icon in the tray, it gets to the point where it says "System Halted" on the console screen
but the computer does not power off. If I power off using the physical power button on the computer, exactly the same thing happens.

However, if I power off using "sudo systemctl start poweroff.target" it works perfectly.

How can I get it to work properly again in KDE or if I hit the power button? Why does it work perfectly on one computer but not the other?

Last edited by Zamboniman (2012-11-10 03:41:24)

Offline

#2 2012-11-10 00:18:56

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,794
Website

Re: [Solved] System does not power off, hangs at "System Halted"

It sounds like your current buttons are bound to the "halt" command.  Halt used to poweroff, but this has recently been fixed so halt simply halts.

Check the bindings for those buttons/menu options and ensure they call shutdown or poweroff instead.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2012-11-10 02:04:27

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,124

Re: [Solved] System does not power off, hangs at "System Halted"

Like Trilby stated, things have changed since systemd logind took over from consolekit.  This post might help: https://bbs.archlinux.org/viewtopic.php?id=147388

The search function on the forums is a valuable resource.


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

#4 2012-11-10 03:19:19

Zamboniman
Member
Registered: 2010-06-20
Posts: 15

Re: [Solved] System does not power off, hangs at "System Halted"

Thank you. I did search, and found some information that was not relevant. I did not find the thread referenced above for whatever reason. My search skills are usually pretty good for this sort of thing, so I don't know why I didn't find it. I fixed the relevant entry in /usr/share/config/kdm/kdmrc. Still haven't found where I change the hardware button. I'll search again.

Offline

#5 2012-11-10 03:40:03

Zamboniman
Member
Registered: 2010-06-20
Posts: 15

Re: [Solved] System does not power off, hangs at "System Halted"

Okay, this has now been solved. Thanks are due to bgc1954 and Trillby for pointing me in the right direction. Very much appreciated.

My search ability, usually very good, completely failed me on this one. However, a few hints was all I needed.

For the record:

To make the power button poweroff instead of halt: edit /etc/systemd/logind.conf and uncomment HandlePowerKey and make sure its value is set to poweroff.

To make kde poweroff properly, edit /usr/share/config/kdm/kdmrc and look for the [Shutdown] section. Ensure HaltCmd is uncommented and set to /sbin/poweroff.

As to why the behaviour was different on my other computer, for some reason the relevant kdmrc entry on that computer was commented out. Apparently that makes it work correctly. I don't know why they were different, as I don't recall changing either.

Offline

Board footer

Powered by FluxBB